fix patches
This commit is contained in:
parent
fc9bf0ff0a
commit
52a3bbce13
@ -1,4 +1,4 @@
|
||||
From b80670a266c8d138d11a3b62577afd18d17ee6bd Mon Sep 17 00:00:00 2001
|
||||
From 6fa0780b933babbb3c5f16e0bb865eaf141b6412 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Thu, 20 Feb 2014 11:36:38 +0000
|
||||
Subject: [PATCH] poppler fixes
|
||||
@ -11,12 +11,12 @@ Change-Id: Iaad3d6ba494a00e7581c5d7a35ec3ec5f57134dc
|
||||
3 files changed, 3 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index b8def00..5c34e29 100644
|
||||
index 30f7def..eced7e9 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -10425,16 +10425,6 @@ if test $_os != Android -a $_os != iOS -a \( -z "$enable_pdfimport" -o "$enable_
|
||||
@@ -10515,16 +10515,6 @@ if test $_os != Android -a $_os != iOS -a \( -z "$enable_pdfimport" -o "$enable_
|
||||
AC_MSG_RESULT([external])
|
||||
SYSTEM_POPPLER=YES
|
||||
SYSTEM_POPPLER=TRUE
|
||||
PKG_CHECK_MODULES( POPPLER, poppler >= 0.8.0 )
|
||||
- AC_LANG_PUSH([C++])
|
||||
- save_CXXFLAGS=$CXXFLAGS
|
||||
@ -32,7 +32,7 @@ index b8def00..5c34e29 100644
|
||||
POPPLER_CFLAGS=$(printf '%s' "$POPPLER_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
|
||||
else
|
||||
diff --git a/sdext/Module_sdext.mk b/sdext/Module_sdext.mk
|
||||
index 5299cd8..94baf45 100644
|
||||
index f706e9c..94baf45 100644
|
||||
--- a/sdext/Module_sdext.mk
|
||||
+++ b/sdext/Module_sdext.mk
|
||||
@@ -26,11 +26,6 @@ $(eval $(call gb_Module_add_targets,sdext,\
|
||||
@ -40,7 +40,7 @@ index 5299cd8..94baf45 100644
|
||||
))
|
||||
|
||||
-$(eval $(call gb_Module_add_check_targets,sdext,\
|
||||
- CppunitTest_pdfimport \
|
||||
- CppunitTest_sdext_pdfimport \
|
||||
- Executable_pdf2xml \
|
||||
- Executable_pdfunzip \
|
||||
-))
|
||||
@ -48,10 +48,10 @@ index 5299cd8..94baf45 100644
|
||||
|
||||
# vim:set noet sw=4 ts=4:
|
||||
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
||||
index f7e4a98..d1218578 100644
|
||||
index 067a132..342e4eb 100644
|
||||
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
||||
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
||||
@@ -58,7 +58,9 @@
|
||||
@@ -54,7 +54,9 @@
|
||||
class GfxPath;
|
||||
class GfxFont;
|
||||
class PDFDoc;
|
||||
@ -63,5 +63,5 @@ index f7e4a98..d1218578 100644
|
||||
(POPPLER_VERSION_MAJOR > (major) || \
|
||||
(POPPLER_VERSION_MAJOR == (major) && POPPLER_VERSION_MINOR > (minor)) || \
|
||||
--
|
||||
1.8.5.3
|
||||
1.9.0
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user