make libwpd-based filters work correctly with newest libwpd
This commit is contained in:
parent
b971209b99
commit
4c02e83a2c
50
0001-Use-inconditionally-the-libwpd-0.9.5-path.patch
Normal file
50
0001-Use-inconditionally-the-libwpd-0.9.5-path.patch
Normal file
@ -0,0 +1,50 @@
|
||||
From 32afec7662fed6eea0714a8bf23e9f040672cb5a Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Fridrich=20=C5=A0trba?= <fridrich.strba@bluewin.ch>
|
||||
Date: Thu, 25 Jul 2013 15:43:58 +0200
|
||||
Subject: [PATCH] Use inconditionally the libwpd >= 0.9.5 path
|
||||
|
||||
Since libwpd does not output the version number anymore
|
||||
|
||||
Change-Id: I1bc3f7081552795fc2ed33f033a093fa5b40fda8
|
||||
(cherry picked from commit 93d0e38ccc06060f20073a9461c53f471a1b9c03)
|
||||
Reviewed-on: https://gerrit.libreoffice.org/5102
|
||||
Reviewed-by: David Tardon <dtardon@redhat.com>
|
||||
Tested-by: David Tardon <dtardon@redhat.com>
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
writerperfect/source/common/WPXSvStream.cxx | 4 ----
|
||||
2 files changed, 1 insertion(+), 5 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index b4ce4a2..03d2ef8 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -7221,7 +7221,7 @@ libo_CHECK_SYSTEM_MODULE([libcmis],[CMIS],[libcmis-0.3 >= 0.3.1])
|
||||
dnl ===================================================================
|
||||
dnl Check for system libwpd
|
||||
dnl ===================================================================
|
||||
-libo_CHECK_SYSTEM_MODULE([libwpd],[WPD],[libwpd-0.9 libwpd-stream-0.9],["-I${WORKDIR}/UnpackedTarball/libwpd/inc"],["-L${OUTDIR}/lib -lwpdlib"])
|
||||
+libo_CHECK_SYSTEM_MODULE([libwpd],[WPD],[libwpd-0.9 >= 0.9.5 libwpd-stream-0.9 >= 0.9.5],["-I${WORKDIR}/UnpackedTarball/libwpd/inc"],["-L${OUTDIR}/lib -lwpdlib"])
|
||||
|
||||
dnl ===================================================================
|
||||
dnl Check for system lcms2
|
||||
diff --git a/writerperfect/source/common/WPXSvStream.cxx b/writerperfect/source/common/WPXSvStream.cxx
|
||||
index a79ac6c..e0c8d8c 100644
|
||||
--- a/writerperfect/source/common/WPXSvStream.cxx
|
||||
+++ b/writerperfect/source/common/WPXSvStream.cxx
|
||||
@@ -134,12 +134,8 @@ int WPXSvInputStreamImpl::seek(long offset, WPX_SEEK_TYPE seekType)
|
||||
sal_Int64 tmpOffset = offset;
|
||||
if (seekType == WPX_SEEK_CUR)
|
||||
tmpOffset += tmpPosition;
|
||||
-#if defined(LIBWPD_STREAM_VERSION_MAJOR) && defined(LIBWPD_STREAM_VERSION_MINOR) && defined(LIBWPD_STREAM_VERSION_REVISION) \
|
||||
- && (LIBWPD_STREAM_VERSION_MAJOR > 0 || (LIBWPD_STREAM_VERSION_MAJOR == 0 && (LIBWPD_STREAM_VERSION_MINOR > 9 \
|
||||
- || (LIBWPD_STREAM_VERSION_MINOR == 9 && LIBWPD_STREAM_VERSION_REVISION >= 5))))
|
||||
if (seekType == WPX_SEEK_END)
|
||||
tmpOffset += mnLength;
|
||||
-#endif
|
||||
|
||||
int retVal = 0;
|
||||
if (tmpOffset < 0)
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -43,7 +43,7 @@ Summary: Free Software Productivity Suite
|
||||
Name: libreoffice
|
||||
Epoch: 1
|
||||
Version: %{libo_version}.4
|
||||
Release: 2%{?libo_prerelease}%{?dist}
|
||||
Release: 3%{?libo_prerelease}%{?dist}
|
||||
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and Artistic and MPLv2.0
|
||||
Group: Applications/Productivity
|
||||
URL: http://www.libreoffice.org/default/
|
||||
@ -257,6 +257,7 @@ Patch19: 0001-WaE-assuming-signed-overflow-does-not-occur-when-ass.patch
|
||||
Patch20: 0001-Resolves-fdo-48835-application-menu-for-LibreOffice.patch
|
||||
Patch21: 0001-move-static-bitmap-into-a-svapp-member.patch
|
||||
Patch22: 0001-resolved-fdo-67094-handle-text-s-in-text-p-and-text-.patch
|
||||
Patch23: 0001-Use-inconditionally-the-libwpd-0.9.5-path.patch
|
||||
|
||||
%define instdir %{_libdir}
|
||||
%define baseinstdir %{instdir}/libreoffice
|
||||
@ -1011,6 +1012,7 @@ mv -f redhat.soc extras/source/palettes/standard.soc
|
||||
%patch20 -p1 -b .fdo-48835-application-menu-for-LibreOffice.patch
|
||||
%patch21 -p1 -b .move-static-bitmap-into-a-svapp-member.patch
|
||||
%patch22 -p1 -b .resolved-fdo-67094-handle-text-s-in-text-p-and-text-.patch
|
||||
%patch23 -p1 -b .Use-inconditionally-the-libwpd-0.9.5-path.patch
|
||||
|
||||
# TODO: check this
|
||||
# these are horribly incomplete--empty translations and copied english
|
||||
@ -2097,6 +2099,9 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jul 29 2013 David Tardon <dtardon@redhat.com> - 1:4.1.0.4-3
|
||||
- make libwpd-based filters work correctly with newest libwpd
|
||||
|
||||
* Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1:4.1.0.4-2
|
||||
- Rebuild for boost 1.54.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user