update rhel patches

This commit is contained in:
David Tardon 2015-12-07 10:07:28 +01:00
parent 24ece0829e
commit 1dae3ba117
3 changed files with 8 additions and 48 deletions

View File

@ -29,7 +29,7 @@ index ed71d8f..32fa8ae 100644
-dnl ===================================================================
dnl Check for system libetonyek
dnl ===================================================================
libo_CHECK_SYSTEM_MODULE([libetonyek],[ETONYEK],[libetonyek-0.1 >= 0.1.2])
libo_CHECK_SYSTEM_MODULE([libetonyek],[ETONYEK],[libetonyek-0.1 >= 0.1.4])
diff --git a/external/Module_external.mk b/external/Module_external.mk
index 6d38fd5..25cb2d9 100644
--- a/external/Module_external.mk
@ -134,17 +134,17 @@ index 3f508c4..7e10b9e 100644
#include "MSWorksImportFilter.hxx"
#include "MWAWImportFilter.hxx"
@@ -64,11 +63,6 @@ static cppu::ImplementationEntry const services[] =
&cppu::createSingleComponentFactory, 0, 0
&cppu::createSingleComponentFactory, nullptr, 0
},
{
- &EBookImportFilter_createInstance, &EBookImportFilter_getImplementationName,
- &EBookImportFilter_getSupportedServiceNames,
- &cppu::createSingleComponentFactory, 0, 0
- &cppu::createSingleComponentFactory, nullptr, 0
- },
- {
&PagesImportFilter_createInstance, &PagesImportFilter_getImplementationName,
&PagesImportFilter_getSupportedServiceNames,
&cppu::createSingleComponentFactory, 0, 0
&cppu::createSingleComponentFactory, nullptr, 0
--
2.4.2

View File

@ -15,13 +15,11 @@ diff --git a/Repository.mk b/Repository.mk
index 3977ac3..14b01ff 100644
--- a/Repository.mk
+++ b/Repository.mk
@@ -193,7 +193,6 @@ $(eval $(call gb_Helper_register_libraries_for_install,OOOLIBS,gnome, \
@@ -193,5 +193,4 @@ $(eval $(call gb_Helper_register_libraries_for_install,OOOLIBS,gnome, \
$(if $(ENABLE_GTK3),vclplug_gtk3) \
$(if $(ENABLE_GCONF),gconfbe1) \
$(if $(ENABLE_SYSTRAY_GTK),qstart_gtk) \
- $(if $(ENABLE_GIO),losessioninstall) \
$(if $(ENABLE_GIO),ucpgio1) \
$(if $(ENABLE_GNOMEVFS),ucpgvfs1) \
))
diff --git a/postprocess/Rdb_services.mk b/postprocess/Rdb_services.mk
old mode 100755
@ -29,14 +27,12 @@ new mode 100644
index b72f4abc..90e4711
--- a/postprocess/Rdb_services.mk
+++ b/postprocess/Rdb_services.mk
@@ -193,7 +193,6 @@ $(eval $(call gb_Rdb_add_components,services,\
shell/source/backends/gconfbe/gconfbe1 \
@@ -193,5 +193,4 @@ $(eval $(call gb_Rdb_add_components,services,\
) \
$(if $(ENABLE_GIO), \
- shell/source/sessioninstall/losessioninstall \
ucb/source/ucp/gio/ucpgio \
) \
$(if $(ENABLE_GNOMEVFS), \
diff --git a/shell/Module_shell.mk b/shell/Module_shell.mk
index 3461381..eb74104 100644
--- a/shell/Module_shell.mk
@ -61,6 +57,6 @@ index 3461381..eb74104 100644
-endif
-endif
-
ifeq ($(ENABLE_GCONF),TRUE)
ifeq ($(ENABLE_KDE4),TRUE)
$(eval $(call gb_Module_add_targets,shell,\
Library_gconfbe \
Library_kde4be \

View File

@ -10,27 +10,6 @@ Change-Id: Iaad3d6ba494a00e7581c5d7a35ec3ec5f57134dc
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 4 +++-
3 files changed, 3 insertions(+), 16 deletions(-)
diff --git a/configure.ac b/configure.ac
index 30f7def..eced7e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10515,16 +10515,6 @@ if test $_os != Android -a $_os != iOS -a \( -z "$enable_pdfimport" -o "$enable_
AC_MSG_RESULT([external])
SYSTEM_POPPLER=TRUE
PKG_CHECK_MODULES( POPPLER, poppler >= 0.8.0 )
- AC_LANG_PUSH([C++])
- save_CXXFLAGS=$CXXFLAGS
- save_CPPFLAGS=$CPPFLAGS
- CXXFLAGS="$CXXFLAGS $POPPLER_CFLAGS"
- CPPFLAGS="$CPPFLAGS $POPPLER_CFLAGS"
- AC_CHECK_HEADER([cpp/poppler-version.h], [],
- [AC_MSG_ERROR([cpp/poppler-version.h not found. Install poppler])], [])
- CXXFLAGS=$save_CXXFLAGS
- CPPFLAGS=$save_CPPFLAGS
- AC_LANG_POP([C++])
libo_MINGW_CHECK_DLL([libpoppler])
POPPLER_CFLAGS=$(printf '%s' "$POPPLER_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
else
diff --git a/sdext/Module_sdext.mk b/sdext/Module_sdext.mk
index f706e9c..94baf45 100644
--- a/sdext/Module_sdext.mk
@ -47,21 +26,6 @@ index f706e9c..94baf45 100644
endif
# vim:set noet sw=4 ts=4:
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
index 067a132..342e4eb 100644
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
@@ -54,7 +54,9 @@
class GfxPath;
class GfxFont;
class PDFDoc;
-#include <cpp/poppler-version.h>
+#define POPPLER_VERSION_MAJOR 0
+#define POPPLER_VERSION_MINOR 12
+#define POPPLER_VERSION_MICRO 4
#define POPPLER_CHECK_VERSION(major,minor,micro) \
(POPPLER_VERSION_MAJOR > (major) || \
(POPPLER_VERSION_MAJOR == (major) && POPPLER_VERSION_MINOR > (minor)) || \
--
1.9.0