Merge branch 'master' into f28
This commit is contained in:
commit
1b77b1fb9e
6
.gitignore
vendored
6
.gitignore
vendored
@ -34,3 +34,9 @@
|
||||
/libreoffice-help-6.0.2.1.tar.xz.asc
|
||||
/libreoffice-translations-6.0.2.1.tar.xz
|
||||
/libreoffice-translations-6.0.2.1.tar.xz.asc
|
||||
/libreoffice-6.0.3.1.tar.xz
|
||||
/libreoffice-6.0.3.1.tar.xz.asc
|
||||
/libreoffice-help-6.0.3.1.tar.xz
|
||||
/libreoffice-help-6.0.3.1.tar.xz.asc
|
||||
/libreoffice-translations-6.0.3.1.tar.xz
|
||||
/libreoffice-translations-6.0.3.1.tar.xz.asc
|
||||
|
@ -1,122 +0,0 @@
|
||||
From e81e8f8807e7dce62e91845a94920c91a69f7af5 Mon Sep 17 00:00:00 2001
|
||||
From: Kohei Yoshida <kohei.yoshida@gmail.com>
|
||||
Date: Wed, 31 Jan 2018 21:27:44 -0500
|
||||
Subject: [PATCH] Update orcus to 0.13.3 and make necessary adjustments.
|
||||
|
||||
This is a collection of the following:
|
||||
|
||||
(cherry picked from commit 20945a9a4de6684010fd5b3603595e6da543807d)
|
||||
(cherry picked from commit a1c36eff089c3cd695bd78090575ca1c7677121e)
|
||||
(cherry picked from commit 45a4e70484e7d90dab07a677914ada2d948b415c)
|
||||
|
||||
with all necessary changes to resolve conflicts & preserve correct
|
||||
handling of font and cell background color imports.
|
||||
|
||||
Change-Id: I08eb3495adf74858bb23a84245a9923ebe2a13e2
|
||||
Reviewed-on: https://gerrit.libreoffice.org/50213
|
||||
Tested-by: Jenkins <ci@libreoffice.org>
|
||||
Reviewed-by: Mike Kaganski <mike.kaganski@collabora.com>
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
download.lst | 4 ++--
|
||||
external/liborcus/UnpackedTarball_liborcus.mk | 1 -
|
||||
sc/source/filter/orcus/interface.cxx | 20 +++++++++++++-------
|
||||
4 files changed, 16 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 289cf2911c93..956b6ceb47f6 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -8960,7 +8960,7 @@ AC_SUBST(ENABLE_FUZZERS)
|
||||
dnl ===================================================================
|
||||
dnl Orcus
|
||||
dnl ===================================================================
|
||||
-libo_CHECK_SYSTEM_MODULE([orcus],[ORCUS],[liborcus-0.13 >= 0.13.0])
|
||||
+libo_CHECK_SYSTEM_MODULE([orcus],[ORCUS],[liborcus-0.13 >= 0.13.3])
|
||||
if test "$with_system_orcus" != "yes"; then
|
||||
if test "$SYSTEM_BOOST" = "TRUE"; then
|
||||
# ===========================================================
|
||||
diff --git a/download.lst b/download.lst
|
||||
index 9c7b589c00b3..89dd6b4fde62 100644
|
||||
--- a/download.lst
|
||||
+++ b/download.lst
|
||||
@@ -190,8 +190,8 @@ export OPENLDAP_SHA256SUM := cdd6cffdebcd95161a73305ec13fc7a78e9707b46ca9f84fb89
|
||||
export OPENLDAP_TARBALL := openldap-2.4.45.tgz
|
||||
export OPENSSL_SHA256SUM := 8c6ff15ec6b319b50788f42c7abc2890c08ba5a1cdcd3810eb9092deada37b0f
|
||||
export OPENSSL_TARBALL := openssl-1.0.2m.tar.gz
|
||||
-export ORCUS_SHA256SUM := d7041ef455bb78db66b4ba7876af1b3d0fa377b9444e3ef72ceaccd2e8400937
|
||||
-export ORCUS_TARBALL := liborcus-0.13.1.tar.gz
|
||||
+export ORCUS_SHA256SUM := 62e76de1fd3101e77118732b860354121b40a87bbb1ebfeb8203477fffac16e9
|
||||
+export ORCUS_TARBALL := liborcus-0.13.3.tar.gz
|
||||
export OWNCLOUD_ANDROID_LIB_SHA256SUM := b18b3e3ef7fae6a79b62f2bb43cc47a5346b6330f6a383dc4be34439aca5e9fb
|
||||
export OWNCLOUD_ANDROID_LIB_TARBALL := owncloud-android-library-0.9.4-no-binary-deps.tar.gz
|
||||
export PAGEMAKER_SHA256SUM := 66adacd705a7d19895e08eac46d1e851332adf2e736c566bef1164e7a442519d
|
||||
diff --git a/external/liborcus/UnpackedTarball_liborcus.mk b/external/liborcus/UnpackedTarball_liborcus.mk
|
||||
index 7fadaa46b1c9..6941760cd71a 100644
|
||||
--- a/external/liborcus/UnpackedTarball_liborcus.mk
|
||||
+++ b/external/liborcus/UnpackedTarball_liborcus.mk
|
||||
@@ -18,7 +18,6 @@ $(eval $(call gb_UnpackedTarball_update_autoconf_configs,liborcus))
|
||||
$(eval $(call gb_UnpackedTarball_add_patches,liborcus,\
|
||||
external/liborcus/0001-workaround-a-linking-problem-on-windows.patch \
|
||||
external/liborcus/rpath.patch.0 \
|
||||
- external/liborcus/silence-assert.patch \
|
||||
external/liborcus/0001-protect-the-self-closing-xml-element-code-against-se.patch \
|
||||
))
|
||||
|
||||
diff --git a/sc/source/filter/orcus/interface.cxx b/sc/source/filter/orcus/interface.cxx
|
||||
index de52b861e5fc..c28954af9f84 100644
|
||||
--- a/sc/source/filter/orcus/interface.cxx
|
||||
+++ b/sc/source/filter/orcus/interface.cxx
|
||||
@@ -839,7 +839,8 @@ void ScOrcusStyles::fill::applyToItemSet(SfxItemSet& rSet) const
|
||||
return;
|
||||
}
|
||||
|
||||
- rSet.Put(SvxBrushItem(maBgColor, ATTR_BACKGROUND));
|
||||
+ if (maPattern.equalsIgnoreAsciiCase("solid"))
|
||||
+ rSet.Put(SvxBrushItem(maFgColor, ATTR_BACKGROUND));
|
||||
}
|
||||
|
||||
ScOrcusStyles::protection::protection():
|
||||
@@ -1175,12 +1176,13 @@ void ScOrcusStyles::set_font_underline_color(orcus::spreadsheet::color_elem_t al
|
||||
maCurrentFont.maUnderlineColor = Color(alpha, red, green, blue);
|
||||
}
|
||||
|
||||
-void ScOrcusStyles::set_font_color(orcus::spreadsheet::color_elem_t alpha,
|
||||
+void ScOrcusStyles::set_font_color(orcus::spreadsheet::color_elem_t /*alpha*/,
|
||||
orcus::spreadsheet::color_elem_t red,
|
||||
orcus::spreadsheet::color_elem_t green,
|
||||
orcus::spreadsheet::color_elem_t blue)
|
||||
{
|
||||
- maCurrentFont.maColor = Color(alpha, red, green, blue);
|
||||
+ // Ignore the alpha value for now.
|
||||
+ maCurrentFont.maColor = Color(red, green, blue);
|
||||
maCurrentFont.mbHasFontAttr = true;
|
||||
}
|
||||
|
||||
@@ -1265,15 +1267,19 @@ void ScOrcusStyles::set_fill_pattern_type(const char* s, size_t n)
|
||||
maCurrentFill.mbHasFillAttr = true;
|
||||
}
|
||||
|
||||
-void ScOrcusStyles::set_fill_fg_color(orcus::spreadsheet::color_elem_t alpha, orcus::spreadsheet::color_elem_t red, orcus::spreadsheet::color_elem_t green, orcus::spreadsheet::color_elem_t blue)
|
||||
+void ScOrcusStyles::set_fill_fg_color(
|
||||
+ orcus::spreadsheet::color_elem_t /*alpha*/, orcus::spreadsheet::color_elem_t red, orcus::spreadsheet::color_elem_t green, orcus::spreadsheet::color_elem_t blue)
|
||||
{
|
||||
- maCurrentFill.maFgColor = Color(alpha, red, green, blue);
|
||||
+ // Ignore the alpha element for now.
|
||||
+ maCurrentFill.maFgColor = Color(red, green, blue);
|
||||
maCurrentFill.mbHasFillAttr = true;
|
||||
}
|
||||
|
||||
-void ScOrcusStyles::set_fill_bg_color(orcus::spreadsheet::color_elem_t alpha, orcus::spreadsheet::color_elem_t red, orcus::spreadsheet::color_elem_t green, orcus::spreadsheet::color_elem_t blue)
|
||||
+void ScOrcusStyles::set_fill_bg_color(
|
||||
+ orcus::spreadsheet::color_elem_t /*alpha*/, orcus::spreadsheet::color_elem_t red, orcus::spreadsheet::color_elem_t green, orcus::spreadsheet::color_elem_t blue)
|
||||
{
|
||||
- maCurrentFill.maBgColor = Color(alpha, red, green, blue);
|
||||
+ // Ignore the alpha element for now.
|
||||
+ maCurrentFill.maBgColor = Color(red, green, blue);
|
||||
maCurrentFill.mbHasFillAttr = true;
|
||||
}
|
||||
|
||||
--
|
||||
2.14.3
|
||||
|
@ -1,70 +0,0 @@
|
||||
From 897c07bda2d116bcc2fa4a64c1eb75a52651c991 Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Sun, 26 Nov 2017 16:04:25 +0100
|
||||
Subject: [PATCH] fix includes in aarch64 bridge
|
||||
|
||||
Change-Id: Ia27f15483c27bc43a3cd3a74432f15fa928ad6da
|
||||
---
|
||||
bridges/source/cpp_uno/gcc3_linux_aarch64/abi.cxx | 2 +-
|
||||
bridges/source/cpp_uno/gcc3_linux_aarch64/callvirtualfunction.cxx | 2 +-
|
||||
bridges/source/cpp_uno/gcc3_linux_aarch64/cpp2uno.cxx | 2 +-
|
||||
bridges/source/cpp_uno/gcc3_linux_aarch64/uno2cpp.cxx | 4 ++--
|
||||
4 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/bridges/source/cpp_uno/gcc3_linux_aarch64/abi.cxx b/bridges/source/cpp_uno/gcc3_linux_aarch64/abi.cxx
|
||||
index fa6ffebfbc17..da22eb436b8f 100644
|
||||
--- a/bridges/source/cpp_uno/gcc3_linux_aarch64/abi.cxx
|
||||
+++ b/bridges/source/cpp_uno/gcc3_linux_aarch64/abi.cxx
|
||||
@@ -38,7 +38,7 @@
|
||||
#include <uno/any2.h>
|
||||
#include <uno/mapping.h>
|
||||
|
||||
-#include <abi.hxx>
|
||||
+#include "abi.hxx"
|
||||
#include <osl/mutex.hxx>
|
||||
#include <unordered_map>
|
||||
|
||||
diff --git a/bridges/source/cpp_uno/gcc3_linux_aarch64/callvirtualfunction.cxx b/bridges/source/cpp_uno/gcc3_linux_aarch64/callvirtualfunction.cxx
|
||||
index 09f7696cfb4a..2f7188ea4f99 100644
|
||||
--- a/bridges/source/cpp_uno/gcc3_linux_aarch64/callvirtualfunction.cxx
|
||||
+++ b/bridges/source/cpp_uno/gcc3_linux_aarch64/callvirtualfunction.cxx
|
||||
@@ -24,7 +24,7 @@
|
||||
#include <sal/types.h>
|
||||
#include <sal/alloca.h>
|
||||
|
||||
-#include <callvirtualfunction.hxx>
|
||||
+#include "callvirtualfunction.hxx"
|
||||
|
||||
void callVirtualFunction(
|
||||
unsigned long function, unsigned long * gpr, unsigned long * fpr,
|
||||
diff --git a/bridges/source/cpp_uno/gcc3_linux_aarch64/cpp2uno.cxx b/bridges/source/cpp_uno/gcc3_linux_aarch64/cpp2uno.cxx
|
||||
index 3d8eea4503e9..d867a04dd299 100644
|
||||
--- a/bridges/source/cpp_uno/gcc3_linux_aarch64/cpp2uno.cxx
|
||||
+++ b/bridges/source/cpp_uno/gcc3_linux_aarch64/cpp2uno.cxx
|
||||
@@ -40,7 +40,7 @@
|
||||
#include <types.hxx>
|
||||
#include <vtablefactory.hxx>
|
||||
|
||||
-#include <abi.hxx>
|
||||
+#include "abi.hxx"
|
||||
|
||||
extern "C" void vtableSlotCall_();
|
||||
|
||||
diff --git a/bridges/source/cpp_uno/gcc3_linux_aarch64/uno2cpp.cxx b/bridges/source/cpp_uno/gcc3_linux_aarch64/uno2cpp.cxx
|
||||
index 4e7d69b0a871..8faccbf3edaf 100644
|
||||
--- a/bridges/source/cpp_uno/gcc3_linux_aarch64/uno2cpp.cxx
|
||||
+++ b/bridges/source/cpp_uno/gcc3_linux_aarch64/uno2cpp.cxx
|
||||
@@ -42,8 +42,8 @@
|
||||
#include <uno/any2.h>
|
||||
#include <uno/data.h>
|
||||
|
||||
-#include <abi.hxx>
|
||||
-#include <callvirtualfunction.hxx>
|
||||
+#include "abi.hxx"
|
||||
+#include "callvirtualfunction.hxx"
|
||||
|
||||
namespace {
|
||||
|
||||
--
|
||||
2.14.3
|
||||
|
@ -1,5 +1,5 @@
|
||||
# download path contains version without the last (fourth) digit
|
||||
%global libo_version 6.0.2
|
||||
%global libo_version 6.0.3
|
||||
# Should contain .alphaX / .betaX, if this is pre-release (actually
|
||||
# pre-RC) version. The pre-release string is part of tarball file names,
|
||||
# so we need a way to define it easily at one place.
|
||||
@ -274,9 +274,8 @@ Patch2: 0001-Resolves-rhbz-1432468-disable-opencl-by-default.patch
|
||||
Patch3: 0001-gtk3-only-for-3.20.patch
|
||||
Patch4: 0001-Related-tdf-105998-except-cut-and-paste-as-bitmap-in.patch
|
||||
Patch5: 0001-request-installation-of-langpack-via-packagekit.patch
|
||||
Patch6: 0001-Update-orcus-to-0.13.3-and-make-necessary-adjustment.patch
|
||||
Patch7: 0001-sdk-lib-dir-missing-from-Linux-installation-sets.patch
|
||||
Patch8: 0001-rhbz-1392145-ensure-titlebar-close-button-matches-ou.patch
|
||||
Patch6: 0001-sdk-lib-dir-missing-from-Linux-installation-sets.patch
|
||||
Patch7: 0001-rhbz-1392145-ensure-titlebar-close-button-matches-ou.patch
|
||||
|
||||
%if 0%{?rhel}
|
||||
# not upstreamed
|
||||
@ -687,8 +686,6 @@ A plug-in for LibreOffice that enables integration into the KDE desktop environm
|
||||
|
||||
%package -n libreofficekit
|
||||
Summary: A library providing access to LibreOffice functionality
|
||||
Requires: %{name}-core%{?_isa} = %{epoch}:%{version}-%{release}
|
||||
Requires: %{name}-filters%{?_isa} = %{epoch}:%{version}-%{release}
|
||||
License: MPLv2.0
|
||||
|
||||
%description -n libreofficekit
|
||||
@ -2330,7 +2327,16 @@ done
|
||||
%{_includedir}/LibreOfficeKit
|
||||
|
||||
%changelog
|
||||
* Fri Mar 16 2018 Caolán McNamara <caolanm@redhat.com> - 1:6.0.2.1-3-UNBUILT
|
||||
* Thu Mar 29 2018 Caolán McNamara <caolanm@redhat.com> - 1:6.0.3.1-3
|
||||
- Related: rhbz#1066844 drop libreofficekit requires
|
||||
|
||||
* Fri Mar 23 2018 Marek Kasik <mkasik@redhat.com> - 1:6.0.3.1-2
|
||||
- Rebuild for poppler-0.63.0
|
||||
|
||||
* Thu Mar 22 2018 David Tardon <dtardon@redhat.com> - 1:6.0.3.1-1
|
||||
- update to 6.0.3 rc1
|
||||
|
||||
* Fri Mar 16 2018 Caolán McNamara <caolanm@redhat.com> - 1:6.0.2.1-3
|
||||
- Resolves: rhbz#1392145 ensure titlebar close button matches 'outside' direction
|
||||
|
||||
* Fri Mar 16 2018 Stephan Bergmann <sbergman@redhat.com> - 1:6.0.2.1-2
|
||||
|
12
sources
12
sources
@ -6,9 +6,9 @@ SHA512 (a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip) = 2d3835f7ac356805025
|
||||
SHA512 (0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz) = b9c02d63e9b47a838dbe67c05b9e9e4983d13b9d74794e1c30c73d341c3bc905c9edec3a72fa339ae8c0e06d97e69ac2ea23bf51336b77af14cab7ae67721a46
|
||||
SHA512 (libreoffice-multiliblauncher.sh) = db532afdf5000bc66f9e02c7d0ab586468466f63f8f0bdb204832581e8277c5c59f688fa096548d642411cb8c46e8de4a744676b4e624c075262cfd6945138cd
|
||||
SHA512 (xmlsec1-1.2.25.tar.gz) = ac61547a1cbf9016d7f75be3dc5249d6bc8a526bc51715e53ede13f056c1c72c57433a6be200c886000a25826c3e473954ded3ae988f25d37ac4ef4d777c66a6
|
||||
SHA512 (libreoffice-6.0.2.1.tar.xz) = cb477391d1d3af544d084820d1bb51edeb553b3792ec31889ac1b2c979c311aeb02f810a2e71f3b7d23990cd9335c2a06fc562913538fc700a4df6630a04e3de
|
||||
SHA512 (libreoffice-6.0.2.1.tar.xz.asc) = 094411b06a8fed7b54599d071f4ba12a9370edfef739e976aca1904375250ddec1a47f4a5200a55926dd9ca97b928b3f25b954f43081eaf8387401c035c543b2
|
||||
SHA512 (libreoffice-help-6.0.2.1.tar.xz) = 1e0b3a22bfa36288538cdb420780fe7c0eca59482606f36aa197dd5c0eed1c81d6214e872a3c1b968306300888e959f2d66deded6f491b2c4585164806b06b27
|
||||
SHA512 (libreoffice-help-6.0.2.1.tar.xz.asc) = 6690baa3521036eac27af2e9b527a715070cee1177ffeb8669dbc30d13c9fa371a27055d3afdf9b0671b535b1166dad5ecb91bf8d1139ea282fe1d52424cdca2
|
||||
SHA512 (libreoffice-translations-6.0.2.1.tar.xz) = cdae06e6a17c6a6e4ed6e0d9665517eaa30b8c674892e017e4ed5e5a15df87d0c38b93a2eec234732169596f5c7adb65951eaedb923a1d4544e8e6bb23b66ac7
|
||||
SHA512 (libreoffice-translations-6.0.2.1.tar.xz.asc) = 1de67e718080733d1261135d63f6569d6cf085f01bff6e8c1aff1b8fbd94905e14c7761063c3482b1694858558a3691818931bbde37c9aaf02b05b16f6abd49d
|
||||
SHA512 (libreoffice-6.0.3.1.tar.xz.asc) = a83e53000a3004b67f7c37e088acd7c96047656cf973d20f4c0d5d4e862ffbbf0746efe8db8e47d678457ee3fcdf9474735536172d5abf9013c5b0e010361008
|
||||
SHA512 (libreoffice-help-6.0.3.1.tar.xz) = 1daad6f9374d0af75b04aa814ae72971aabb29732c9946566c462d51c07c831eeba6ef813eb2409e35b24c4a65dba3dc856e5e9626eb4aa342167377d8f07d18
|
||||
SHA512 (libreoffice-help-6.0.3.1.tar.xz.asc) = a67bc18415e7459048cb7a052f77453ae6570493bac5d7c624b5e1fe71765f9ed968f275d565c53be6b676fc1f05460e38b9e2488a91c6960bb0e186cb24fcce
|
||||
SHA512 (libreoffice-translations-6.0.3.1.tar.xz) = a2689264f1397c9c0bba525a934707b15f09b4f0dad037a39b57d26335eadf25765027b8ccff645ed0ff0c5c19c0e726fcd30d5f24a58b29f3bccf5b6900c098
|
||||
SHA512 (libreoffice-translations-6.0.3.1.tar.xz.asc) = 6a7905adccd5af017c0f1458588973855857161e75eede8d29a7a54988bf08390772db46a2e879edf48aef58695bd1d26f98a9458f6752dca42166b5eacb38e9
|
||||
SHA512 (libreoffice-6.0.3.1.tar.xz) = 690ea719d36013ced81d76754b275a6baa34042bd9ff1d33ab10d5c855b1c49da3f49a8571cbbb35fb8655d7a74e8f789dbc9e227617d4918b7bb53fe7cb0f28
|
||||
|
Loading…
Reference in New Issue
Block a user