Add patch 501 for failing tests on aarc64 and s390x
This commit is contained in:
parent
e25c329969
commit
04a7ee138b
16
kahansum_test_fix_for_aarc64_s390x.patch
Normal file
16
kahansum_test_fix_for_aarc64_s390x.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -U 3 -dHrN a/sc/inc/arraysumfunctor.hxx b/sc/inc/arraysumfunctor.hxx
|
||||
--- a/sc/inc/arraysumfunctor.hxx 2023-09-22 21:07:01.000000000 +0200
|
||||
+++ b/sc/inc/arraysumfunctor.hxx 2023-10-01 09:13:03.523493665 +0200
|
||||
@@ -85,8 +85,12 @@
|
||||
inline KahanSum sumArray(const double* pArray, size_t nSize)
|
||||
{
|
||||
size_t i = 0;
|
||||
+#if 0
|
||||
const double* pCurrent = pArray;
|
||||
KahanSum fSum = executeFast(i, nSize, pCurrent);
|
||||
+#else
|
||||
+ KahanSum fSum = 0.0;
|
||||
+#endif
|
||||
|
||||
// sum rest of the array
|
||||
for (; i < nSize; ++i)
|
@ -58,7 +58,7 @@ Summary: Free Software Productivity Suite
|
||||
Name: libreoffice
|
||||
Epoch: 1
|
||||
Version: %{libo_version}.1
|
||||
Release: 1%{?libo_prerelease}%{?dist}
|
||||
Release: 2%{?libo_prerelease}%{?dist}
|
||||
# default new files are: MPLv2
|
||||
# older files are typically: MPLv2 incorporating work under ASLv2
|
||||
# nlpsolver is: LGPLv3
|
||||
@ -279,6 +279,8 @@ Patch6: limit-tests-giving-dubious-results-to-x86_64.patch
|
||||
# https://lists.freedesktop.org/archives/libreoffice/2023-August/090870.html
|
||||
Patch11: lo-7.6-ppc64le-tests.patch
|
||||
Patch500: 0001-disable-libe-book-support.patch
|
||||
# https://lists.freedesktop.org/archives/libreoffice/2023-September/090948.html
|
||||
Patch501: kahansum_test_fix_for_aarc64_s390x.patch
|
||||
|
||||
%global instdir %{_libdir}
|
||||
%global baseinstdir %{instdir}/libreoffice
|
||||
@ -1016,6 +1018,10 @@ mv -f redhat.soc extras/source/palettes/standard.soc
|
||||
%patch500 -p1
|
||||
%endif
|
||||
|
||||
%ifarch aarch64 s390x
|
||||
%patch501 -p1
|
||||
%endif
|
||||
|
||||
# Temporarily disable failing tests
|
||||
%ifarch ppc64le
|
||||
sed -i -e /CppunitTest_sc_array_functions_test/d sc/Module_sc.mk
|
||||
@ -2258,6 +2264,9 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_includedir}/LibreOfficeKit
|
||||
|
||||
%changelog
|
||||
* Sun Oct 01 2023 Mattia Verga <mattia.verga@proton.me> - 1:7.6.2.1-2
|
||||
- Add patch 501 for failing tests on aarc64 and s390x
|
||||
|
||||
* Sat Sep 30 2023 Mattia Verga <mattia.verga@proton.me> - 1:7.6.2.1-1
|
||||
- 7.6.2.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user