33 lines
1.2 KiB
Diff
33 lines
1.2 KiB
Diff
diff -up libproxy-0.3.1/configure.ac.kde4 libproxy-0.3.1/configure.ac
|
|
--- libproxy-0.3.1/configure.ac.kde4 2009-10-05 20:42:34.000000000 +0200
|
|
+++ libproxy-0.3.1/configure.ac 2010-02-22 00:12:30.690720150 +0100
|
|
@@ -23,8 +23,6 @@ AC_CHECK_FUNCS(pthread_mutex_init)
|
|
AC_SEARCH_LIBS([socket],[socket inet])
|
|
AC_SEARCH_LIBS([dlopen],[dl])
|
|
|
|
-AC_CHECK_LIB([kdecore], [main], have_kdecore=yes, have_kdecore=no)
|
|
-
|
|
### Checks for module dependencies.
|
|
AC_PATH_PROG(GCONFTOOLBIN, gconftool-2)
|
|
PKG_CHECK_MODULES(x11, x11, have_x11=yes, have_x11=no)
|
|
@@ -38,6 +36,8 @@ PKG_CHECK_MODULES(NetworkManager, Networ
|
|
have_networkmanager=yes, have_networkmanager=no)
|
|
PKG_CHECK_MODULES(QtCore, QtCore, have_qtcore=yes, have_qtcore=no)
|
|
|
|
+AC_CHECK_LIB([kdecore], [main], have_kdecore=yes, have_kdecore=yes)
|
|
+
|
|
# Direct
|
|
AC_ARG_WITH([direct],
|
|
[AS_HELP_STRING([--with-direct],
|
|
@@ -96,8 +96,8 @@ AC_ARG_WITH([kde4],
|
|
if test x$with_kde4 = xyes; then
|
|
if test x$have_qtcore = xyes && \
|
|
test x$have_kdecore = xyes; then
|
|
- KDE4_CFLAGS="$QtCore_CFLAGS"
|
|
- KDE4_LIBS="$QtCore_LIBS -lkdecore"
|
|
+ KDE4_CFLAGS="$KDE4_CFLAGS $QtCore_CFLAGS"
|
|
+ KDE4_LIBS="$KDE4_LIBS -lkdecore $QtCore_LIBS"
|
|
AC_SUBST(KDE4_CFLAGS)
|
|
AC_SUBST(KDE4_LIBS)
|
|
else
|