Update to 0.4.18
This commit is contained in:
parent
359cdb1a26
commit
8738c3fe7e
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
||||
/libproxy-0.4.14.tar.xz
|
||||
/0.4.15.tar.gz
|
||||
/libproxy-0.4.17.tar.xz
|
||||
/libproxy-0.4.18.tar.xz
|
||||
|
@ -1,61 +0,0 @@
|
||||
From 04eeeabb42436cb58e9bac2f6c31c0fb87905a72 Mon Sep 17 00:00:00 2001
|
||||
From: David King <amigadave@amigadave.com>
|
||||
Date: Mon, 21 Jun 2021 17:10:43 +0100
|
||||
Subject: [PATCH] python: Support Python 3.10 and above
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
As suggested by Miro Hrončok, change the way that the Python interpreter
|
||||
version is found. Additionally, update the static list of accepted
|
||||
Python 3 versions.
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1898060
|
||||
---
|
||||
bindings/python/python2/CMakeLists.txt | 2 +-
|
||||
bindings/python/python3/CMakeLists.txt | 2 +-
|
||||
cmake/FindPython3Interp.cmake | 2 +-
|
||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/bindings/python/python2/CMakeLists.txt b/bindings/python/python2/CMakeLists.txt
|
||||
index 00df551..f4d2b91 100644
|
||||
--- a/bindings/python/python2/CMakeLists.txt
|
||||
+++ b/bindings/python/python2/CMakeLists.txt
|
||||
@@ -6,7 +6,7 @@ if(PYTHON2INTERP_FOUND)
|
||||
if(NOT PYTHON2_SITEPKG_DIR)
|
||||
execute_process(COMMAND
|
||||
${PYTHON2_EXECUTABLE}
|
||||
- -c "import sys; print (sys.version[0:3])"
|
||||
+ -c "import sys; print('{}.{}'.format(*sys.version_info[0:2]))"
|
||||
OUTPUT_VARIABLE PYTHON2_VERSION
|
||||
OUTPUT_STRIP_TRAILING_WHITESPACE)
|
||||
|
||||
diff --git a/bindings/python/python3/CMakeLists.txt b/bindings/python/python3/CMakeLists.txt
|
||||
index bf87dfc..fc3b24b 100644
|
||||
--- a/bindings/python/python3/CMakeLists.txt
|
||||
+++ b/bindings/python/python3/CMakeLists.txt
|
||||
@@ -6,7 +6,7 @@ if(PYTHON3INTERP_FOUND)
|
||||
if(NOT PYTHON3_SITEPKG_DIR)
|
||||
execute_process(COMMAND
|
||||
${PYTHON3_EXECUTABLE}
|
||||
- -c "import sys; print (sys.version[0:3])"
|
||||
+ -c "import sys; print('{}.{}'.format(*sys.version_info[0:2]))"
|
||||
OUTPUT_VARIABLE PYTHON3_VERSION
|
||||
OUTPUT_STRIP_TRAILING_WHITESPACE)
|
||||
|
||||
diff --git a/cmake/FindPython3Interp.cmake b/cmake/FindPython3Interp.cmake
|
||||
index 74398b2..5b25e5a 100644
|
||||
--- a/cmake/FindPython3Interp.cmake
|
||||
+++ b/cmake/FindPython3Interp.cmake
|
||||
@@ -39,7 +39,7 @@
|
||||
|
||||
unset(_Python3_NAMES)
|
||||
|
||||
-set(_Python3_VERSIONS 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
+set(_Python3_VERSIONS 3.10 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
|
||||
if(Python3Interp_FIND_VERSION)
|
||||
if(Python3Interp_FIND_VERSION_COUNT GREATER 1)
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,25 +0,0 @@
|
||||
From f9cf48ecc25676ef245182821b71362074c9845d Mon Sep 17 00:00:00 2001
|
||||
From: David King <amigadave@amigadave.com>
|
||||
Date: Mon, 20 Jun 2022 11:36:42 +0100
|
||||
Subject: [PATCH] python: Accept Python 3.11
|
||||
|
||||
---
|
||||
cmake/FindPython3Interp.cmake | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/cmake/FindPython3Interp.cmake b/cmake/FindPython3Interp.cmake
|
||||
index cc82c47..d2f5d74 100644
|
||||
--- a/cmake/FindPython3Interp.cmake
|
||||
+++ b/cmake/FindPython3Interp.cmake
|
||||
@@ -56,7 +56,7 @@
|
||||
|
||||
unset(_Python3_NAMES)
|
||||
|
||||
-set(_Python3_VERSIONS 3.10 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
+set(_Python3_VERSIONS 3.11 3.10 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
|
||||
if(Python3Interp_FIND_VERSION)
|
||||
if(Python3Interp_FIND_VERSION_COUNT GREATER 1)
|
||||
--
|
||||
2.36.1
|
||||
|
@ -3,19 +3,15 @@
|
||||
%{!?_with_bootstrap: %global bootstrap 0}
|
||||
|
||||
Name: libproxy
|
||||
Version: 0.4.17
|
||||
Release: 6%{?dist}
|
||||
Version: 0.4.18
|
||||
Release: 1%{?dist}
|
||||
Summary: A library handling all the details of proxy configuration
|
||||
|
||||
License: LGPLv2+
|
||||
URL: https://libproxy.github.io/libproxy/
|
||||
Source0: https://github.com/libproxy/%{name}/releases/download/%{name}-%{version}.tar.xz
|
||||
Source0: https://github.com/libproxy/%{name}/releases/download/%{version}/%{name}-%{version}.tar.xz
|
||||
# Taken from the Debian package.
|
||||
Source1: proxy.1
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1898060
|
||||
Patch0: libproxy-0.4.17-fix-python-version-check.patch
|
||||
# https://github.com/libproxy/libproxy/pull/178
|
||||
Patch1: libproxy-0.4.17-python-311.patch
|
||||
|
||||
BuildRequires: cmake >= 2.6.0
|
||||
BuildRequires: gcc-c++
|
||||
@ -212,6 +208,9 @@ install -Dpm 0644 %{SOURCE1} %{buildroot}/%{_mandir}/man1/proxy.1
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jun 21 2022 David King <amigadave@amigadave.com> - 0.4.18-1
|
||||
- Update to 0.4.18
|
||||
|
||||
* Mon Jun 20 2022 David King <amigadave@amigadave.com> - 0.4.17-6
|
||||
- Accept Python 3.11 (#2098739)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libproxy-0.4.17.tar.xz) = 900bd7e44d968f6adf856d34dbc9d6558217143cae7a4eb6cb64766a26bee53f26e08f7feba3d5ad2b6d4db7409a35155c1dc34e1b9be42515b00b09d8c362b7
|
||||
SHA512 (libproxy-0.4.18.tar.xz) = 0c6b138bc8da9abcf21e091b876527cfff0703800995363e5a46c29a2a9caa2946c45b299abed6129b314461123949dae387456a0cddcbb0b29a84b9b55f499c
|
||||
|
Loading…
Reference in New Issue
Block a user