Add missing patches
This commit is contained in:
parent
98bc27bca2
commit
ccb9eb72b3
282
libpreludedb-5.1.0-Add-pkg-config-file.patch
Normal file
282
libpreludedb-5.1.0-Add-pkg-config-file.patch
Normal file
@ -0,0 +1,282 @@
|
||||
Description: Add pkg-config file
|
||||
Author: Thomas Andrejak <thomas.andrejak@gmail.com>
|
||||
Last-Update: Mon, 14 Aug 2017
|
||||
|
||||
---
|
||||
configure.ac | 1 +
|
||||
m4/pkg.m4 | 199 +++++++++++++++++++++++++++++++++++++++++++++++++
|
||||
src/Makefile.am | 5 +-
|
||||
src/libpreludedb.pc.in | 13 ++++
|
||||
4 files changed, 217 insertions(+), 1 deletion(-)
|
||||
create mode 100644 m4/pkg.m4
|
||||
create mode 100644 src/libpreludedb.pc.in
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 9c7e026..f589aa1 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -333,6 +333,12 @@
|
||||
AC_SUBST(sql_plugin_dir)
|
||||
AC_SUBST(format_plugin_dir)
|
||||
AC_SUBST(format_schema_dir)
|
||||
+
|
||||
+AC_SUBST(CFLAGS)
|
||||
+AC_SUBST(CPPFLAGS)
|
||||
+AC_SUBST(LDFLAGS)
|
||||
+AC_SUBST(LIBPRELUDEDB_LIBS)
|
||||
+AC_SUBST(LIBPRELUDEDB_CFLAGS)
|
||||
AC_SUBST(LIBPRELUDEDB_VERSION)
|
||||
AC_SUBST(LIBPRELUDEDB_MAJOR_VERSION)
|
||||
AC_SUBST(LIBPRELUDEDB_MINOR_VERSION)
|
||||
@@ -350,6 +350,7 @@ libmissing/Makefile
|
||||
libmissing/tests/Makefile
|
||||
|
||||
src/Makefile
|
||||
+src/libpreludedb.pc
|
||||
src/include/Makefile
|
||||
src/include/preludedb-version.h
|
||||
|
||||
diff --git a/m4/pkg.m4 b/m4/pkg.m4
|
||||
new file mode 100644
|
||||
index 0000000..f26f84c
|
||||
--- /dev/null
|
||||
+++ b/m4/pkg.m4
|
||||
@@ -0,0 +1,199 @@
|
||||
+# pkg.m4 - Macros to locate and utilise pkg-config. -*- Autoconf -*-
|
||||
+# serial 1 (pkg-config-0.24)
|
||||
+#
|
||||
+# Copyright © 2004 Scott James Remnant <scott@netsplit.com>.
|
||||
+#
|
||||
+# This program is free software; you can redistribute it and/or modify
|
||||
+# it under the terms of the GNU General Public License as published by
|
||||
+# the Free Software Foundation; either version 2 of the License, or
|
||||
+# (at your option) any later version.
|
||||
+#
|
||||
+# This program is distributed in the hope that it will be useful, but
|
||||
+# WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||
+# General Public License for more details.
|
||||
+#
|
||||
+# You should have received a copy of the GNU General Public License
|
||||
+# along with this program; if not, write to the Free Software
|
||||
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
+#
|
||||
+# As a special exception to the GNU General Public License, if you
|
||||
+# distribute this file as part of a program that contains a
|
||||
+# configuration script generated by Autoconf, you may include it under
|
||||
+# the same distribution terms that you use for the rest of that program.
|
||||
+
|
||||
+# PKG_PROG_PKG_CONFIG([MIN-VERSION])
|
||||
+# ----------------------------------
|
||||
+AC_DEFUN([PKG_PROG_PKG_CONFIG],
|
||||
+[m4_pattern_forbid([^_?PKG_[A-Z_]+$])
|
||||
+m4_pattern_allow([^PKG_CONFIG(_(PATH|LIBDIR|SYSROOT_DIR|ALLOW_SYSTEM_(CFLAGS|LIBS)))?$])
|
||||
+m4_pattern_allow([^PKG_CONFIG_(DISABLE_UNINSTALLED|TOP_BUILD_DIR|DEBUG_SPEW)$])
|
||||
+AC_ARG_VAR([PKG_CONFIG], [path to pkg-config utility])
|
||||
+AC_ARG_VAR([PKG_CONFIG_PATH], [directories to add to pkg-config's search path])
|
||||
+AC_ARG_VAR([PKG_CONFIG_LIBDIR], [path overriding pkg-config's built-in search path])
|
||||
+
|
||||
+if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
|
||||
+ AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
|
||||
+fi
|
||||
+if test -n "$PKG_CONFIG"; then
|
||||
+ _pkg_min_version=m4_default([$1], [0.9.0])
|
||||
+ AC_MSG_CHECKING([pkg-config is at least version $_pkg_min_version])
|
||||
+ if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
|
||||
+ AC_MSG_RESULT([yes])
|
||||
+ else
|
||||
+ AC_MSG_RESULT([no])
|
||||
+ PKG_CONFIG=""
|
||||
+ fi
|
||||
+fi[]dnl
|
||||
+])# PKG_PROG_PKG_CONFIG
|
||||
+
|
||||
+# PKG_CHECK_EXISTS(MODULES, [ACTION-IF-FOUND], [ACTION-IF-NOT-FOUND])
|
||||
+#
|
||||
+# Check to see whether a particular set of modules exists. Similar
|
||||
+# to PKG_CHECK_MODULES(), but does not set variables or print errors.
|
||||
+#
|
||||
+# Please remember that m4 expands AC_REQUIRE([PKG_PROG_PKG_CONFIG])
|
||||
+# only at the first occurence in configure.ac, so if the first place
|
||||
+# it's called might be skipped (such as if it is within an "if", you
|
||||
+# have to call PKG_CHECK_EXISTS manually
|
||||
+# --------------------------------------------------------------
|
||||
+AC_DEFUN([PKG_CHECK_EXISTS],
|
||||
+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
|
||||
+if test -n "$PKG_CONFIG" && \
|
||||
+ AC_RUN_LOG([$PKG_CONFIG --exists --print-errors "$1"]); then
|
||||
+ m4_default([$2], [:])
|
||||
+m4_ifvaln([$3], [else
|
||||
+ $3])dnl
|
||||
+fi])
|
||||
+
|
||||
+# _PKG_CONFIG([VARIABLE], [COMMAND], [MODULES])
|
||||
+# ---------------------------------------------
|
||||
+m4_define([_PKG_CONFIG],
|
||||
+[if test -n "$$1"; then
|
||||
+ pkg_cv_[]$1="$$1"
|
||||
+ elif test -n "$PKG_CONFIG"; then
|
||||
+ PKG_CHECK_EXISTS([$3],
|
||||
+ [pkg_cv_[]$1=`$PKG_CONFIG --[]$2 "$3" 2>/dev/null`
|
||||
+ test "x$?" != "x0" && pkg_failed=yes ],
|
||||
+ [pkg_failed=yes])
|
||||
+ else
|
||||
+ pkg_failed=untried
|
||||
+fi[]dnl
|
||||
+])# _PKG_CONFIG
|
||||
+
|
||||
+# _PKG_SHORT_ERRORS_SUPPORTED
|
||||
+# -----------------------------
|
||||
+AC_DEFUN([_PKG_SHORT_ERRORS_SUPPORTED],
|
||||
+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])
|
||||
+if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
|
||||
+ _pkg_short_errors_supported=yes
|
||||
+else
|
||||
+ _pkg_short_errors_supported=no
|
||||
+fi[]dnl
|
||||
+])# _PKG_SHORT_ERRORS_SUPPORTED
|
||||
+
|
||||
+
|
||||
+# PKG_CHECK_MODULES(VARIABLE-PREFIX, MODULES, [ACTION-IF-FOUND],
|
||||
+# [ACTION-IF-NOT-FOUND])
|
||||
+#
|
||||
+#
|
||||
+# Note that if there is a possibility the first call to
|
||||
+# PKG_CHECK_MODULES might not happen, you should be sure to include an
|
||||
+# explicit call to PKG_PROG_PKG_CONFIG in your configure.ac
|
||||
+#
|
||||
+#
|
||||
+# --------------------------------------------------------------
|
||||
+AC_DEFUN([PKG_CHECK_MODULES],
|
||||
+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
|
||||
+AC_ARG_VAR([$1][_CFLAGS], [C compiler flags for $1, overriding pkg-config])dnl
|
||||
+AC_ARG_VAR([$1][_LIBS], [linker flags for $1, overriding pkg-config])dnl
|
||||
+
|
||||
+pkg_failed=no
|
||||
+AC_MSG_CHECKING([for $1])
|
||||
+
|
||||
+_PKG_CONFIG([$1][_CFLAGS], [cflags], [$2])
|
||||
+_PKG_CONFIG([$1][_LIBS], [libs], [$2])
|
||||
+
|
||||
+m4_define([_PKG_TEXT], [Alternatively, you may set the environment variables $1[]_CFLAGS
|
||||
+and $1[]_LIBS to avoid the need to call pkg-config.
|
||||
+See the pkg-config man page for more details.])
|
||||
+
|
||||
+if test $pkg_failed = yes; then
|
||||
+ AC_MSG_RESULT([no])
|
||||
+ _PKG_SHORT_ERRORS_SUPPORTED
|
||||
+ if test $_pkg_short_errors_supported = yes; then
|
||||
+ $1[]_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "$2" 2>&1`
|
||||
+ else
|
||||
+ $1[]_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "$2" 2>&1`
|
||||
+ fi
|
||||
+ # Put the nasty error message in config.log where it belongs
|
||||
+ echo "$$1[]_PKG_ERRORS" >&AS_MESSAGE_LOG_FD
|
||||
+
|
||||
+ m4_default([$4], [AC_MSG_ERROR(
|
||||
+[Package requirements ($2) were not met:
|
||||
+
|
||||
+$$1_PKG_ERRORS
|
||||
+
|
||||
+Consider adjusting the PKG_CONFIG_PATH environment variable if you
|
||||
+installed software in a non-standard prefix.
|
||||
+
|
||||
+_PKG_TEXT])[]dnl
|
||||
+ ])
|
||||
+elif test $pkg_failed = untried; then
|
||||
+ AC_MSG_RESULT([no])
|
||||
+ m4_default([$4], [AC_MSG_FAILURE(
|
||||
+[The pkg-config script could not be found or is too old. Make sure it
|
||||
+is in your PATH or set the PKG_CONFIG environment variable to the full
|
||||
+path to pkg-config.
|
||||
+
|
||||
+_PKG_TEXT
|
||||
+
|
||||
+To get pkg-config, see <http://pkg-config.freedesktop.org/>.])[]dnl
|
||||
+ ])
|
||||
+else
|
||||
+ $1[]_CFLAGS=$pkg_cv_[]$1[]_CFLAGS
|
||||
+ $1[]_LIBS=$pkg_cv_[]$1[]_LIBS
|
||||
+ AC_MSG_RESULT([yes])
|
||||
+ $3
|
||||
+fi[]dnl
|
||||
+])# PKG_CHECK_MODULES
|
||||
+
|
||||
+
|
||||
+# PKG_INSTALLDIR(DIRECTORY)
|
||||
+# -------------------------
|
||||
+# Substitutes the variable pkgconfigdir as the location where a module
|
||||
+# should install pkg-config .pc files. By default the directory is
|
||||
+# $libdir/pkgconfig, but the default can be changed by passing
|
||||
+# DIRECTORY. The user can override through the --with-pkgconfigdir
|
||||
+# parameter.
|
||||
+AC_DEFUN([PKG_INSTALLDIR],
|
||||
+[m4_pushdef([pkg_default], [m4_default([$1], ['${libdir}/pkgconfig'])])
|
||||
+m4_pushdef([pkg_description],
|
||||
+ [pkg-config installation directory @<:@]pkg_default[@:>@])
|
||||
+AC_ARG_WITH([pkgconfigdir],
|
||||
+ [AS_HELP_STRING([--with-pkgconfigdir], pkg_description)],,
|
||||
+ [with_pkgconfigdir=]pkg_default)
|
||||
+AC_SUBST([pkgconfigdir], [$with_pkgconfigdir])
|
||||
+m4_popdef([pkg_default])
|
||||
+m4_popdef([pkg_description])
|
||||
+]) dnl PKG_INSTALLDIR
|
||||
+
|
||||
+
|
||||
+# PKG_NOARCH_INSTALLDIR(DIRECTORY)
|
||||
+# -------------------------
|
||||
+# Substitutes the variable noarch_pkgconfigdir as the location where a
|
||||
+# module should install arch-independent pkg-config .pc files. By
|
||||
+# default the directory is $datadir/pkgconfig, but the default can be
|
||||
+# changed by passing DIRECTORY. The user can override through the
|
||||
+# --with-noarch-pkgconfigdir parameter.
|
||||
+AC_DEFUN([PKG_NOARCH_INSTALLDIR],
|
||||
+[m4_pushdef([pkg_default], [m4_default([$1], ['${datadir}/pkgconfig'])])
|
||||
+m4_pushdef([pkg_description],
|
||||
+ [pkg-config arch-independent installation directory @<:@]pkg_default[@:>@])
|
||||
+AC_ARG_WITH([noarch-pkgconfigdir],
|
||||
+ [AS_HELP_STRING([--with-noarch-pkgconfigdir], pkg_description)],,
|
||||
+ [with_noarch_pkgconfigdir=]pkg_default)
|
||||
+AC_SUBST([noarch_pkgconfigdir], [$with_noarch_pkgconfigdir])
|
||||
+m4_popdef([pkg_default])
|
||||
+m4_popdef([pkg_description])
|
||||
+]) dnl PKG_NOARCH_INSTALLDIR
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index 7b9accd..80df82c 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -31,8 +31,11 @@ AM_YFLAGS = -d
|
||||
AM_LFLAGS = --header-file=preludedb-path-selection-parser.lex.h
|
||||
LEX_OUTPUT_ROOT = lex._preludedbyy
|
||||
|
||||
+pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfig_DATA = libpreludedb.pc
|
||||
+
|
||||
noinst_HEADERS = preludedb-path-selection-parser.lex.h
|
||||
-DISTCLEANFILES = preludedb-path-selection-parser.lex.h preludedb-path-selection-parser.lex.c preludedb-path-selection-parser.yac.h preludedb-path-selection-parser.yac.c
|
||||
+DISTCLEANFILES = $(pkgconfig_DATA) preludedb-path-selection-parser.lex.h preludedb-path-selection-parser.lex.c preludedb-path-selection-parser.yac.h preludedb-path-selection-parser.yac.c
|
||||
|
||||
|
||||
libpreludedb_la_SOURCES = \
|
||||
diff --git a/src/libpreludedb.pc.in b/src/libpreludedb.pc.in
|
||||
new file mode 100644
|
||||
index 0000000..63eb32f
|
||||
--- /dev/null
|
||||
+++ b/src/libpreludedb.pc.in
|
||||
@@ -0,0 +1,13 @@
|
||||
+prefix=@prefix@
|
||||
+exec_prefix=@exec_prefix@
|
||||
+libdir=@libdir@
|
||||
+includedir=@includedir@
|
||||
+
|
||||
+threadlib=@LIBMULTITHREAD@
|
||||
+
|
||||
+Name: LibPreludeDB
|
||||
+Description: The Prelude DB Library provide API for accessing IDMEF alerts.
|
||||
+Version: @VERSION@
|
||||
+Libs: -L${libdir} -lpreludedb
|
||||
+Libs.private: @LIBPRELUDEDB_LIBS@ @LIBMULTITHREAD@
|
||||
+Cflags: @LIBPRELUDEDB_CFLAGS@
|
||||
--
|
||||
2.13.3
|
||||
|
20
libpreludedb-5.1.0-Fix_libdir_definition.patch
Normal file
20
libpreludedb-5.1.0-Fix_libdir_definition.patch
Normal file
@ -0,0 +1,20 @@
|
||||
Description: Fix libdir definition
|
||||
Author: Thomas Andrejak <thomas.andrejak@gmail.com>
|
||||
Last-Update: 2018-02-10
|
||||
|
||||
--- libpreludedb-3.1.0/libpreludedb-config.in 2018-02-10 20:26:02.511884738 -0500
|
||||
+++ libpreludedb-3.1.0/libpreludedb-config.in 2018-02-10 20:25:57.140005520 -0500
|
||||
@@ -90,7 +90,12 @@
|
||||
|
||||
|
||||
if test $want_libs = yes; then
|
||||
- libdirs=-L@libdir@
|
||||
+ libdirs=""
|
||||
+
|
||||
+ # Set up `libdirs'.
|
||||
+ if test "x@libdir@" != "x/usr/lib"; then
|
||||
+ libdirs="-L@libdir@"
|
||||
+ fi
|
||||
|
||||
if test $thread_set = yes; then
|
||||
thrlibs=@LTLIBMULTITHREAD@
|
20
libpreludedb-5.1.0-fix-test_rwlock1.patch
Normal file
20
libpreludedb-5.1.0-fix-test_rwlock1.patch
Normal file
@ -0,0 +1,20 @@
|
||||
Description: Fix test-rwlock1 when --as-needed is the default.
|
||||
Author: Michael Hudson-Doyle <michael.hudson@ubuntu.com>
|
||||
Forwarded: no
|
||||
Last-Update: 2018-07-25
|
||||
---
|
||||
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
||||
--- a/libmissing/tests/test-rwlock1.c
|
||||
+++ b/libmissing/tests/test-rwlock1.c
|
||||
@@ -54,7 +54,10 @@
|
||||
|
||||
#define SUCCEED() exit (0)
|
||||
#define FAILURE() exit (1)
|
||||
-#define UNEXPECTED(n) (fprintf (stderr, "Unexpected outcome %d\n", n), abort ())
|
||||
+/* The pointless reference to errno below is to ensure that the test binary
|
||||
+ * gets a DT_NEEDED for libpthread even if the link is done with --as-needed
|
||||
+ * (which is the default in Ubuntu) */
|
||||
+#define UNEXPECTED(n) (fprintf (stderr, "Unexpected outcome %d errno %d\n", n, errno), abort ())
|
||||
|
||||
/* The main thread creates the waiting writer and the requesting reader threads
|
||||
in the default way; this guarantees that they have the same priority.
|
15
libpreludedb-5.1.0-fix_thread_create.patch
Normal file
15
libpreludedb-5.1.0-fix_thread_create.patch
Normal file
@ -0,0 +1,15 @@
|
||||
Description: Fix libmissing thread create test
|
||||
Author: Thomas Andrejak <thomas.andrejak@gmail.com>
|
||||
Last-Update: 2019-10-11
|
||||
|
||||
--- a/libmissing/tests/test-thread_create.c 2019-09-17 19:29:40.129501083 -0400
|
||||
+++ b/libmissing/tests/test-thread_create.c 2019-10-11 17:32:48.182372602 -0400
|
||||
@@ -68,7 +68,7 @@
|
||||
else
|
||||
{
|
||||
#if USE_POSIX_THREADS || USE_SOLARIS_THREADS || USE_PTH_THREADS || USE_WINDOWS_THREADS
|
||||
- fputs ("glthread_create failed\n", stderr);
|
||||
+ fprintf (stderr, "glthread_create failed with errno %d\n", errno);
|
||||
return 1;
|
||||
#else
|
||||
fputs ("Skipping test: multithreading not enabled\n", stderr);
|
@ -5,7 +5,7 @@
|
||||
|
||||
Name: libpreludedb
|
||||
Version: 5.1.0
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Framework for easy access to the IDMEF database
|
||||
# Prelude is GPL-2.0+
|
||||
# libmissing is LGPL-2.1+
|
||||
@ -18,6 +18,10 @@ Patch1: libpreludedb-5.1.0-fix_py38.patch
|
||||
Patch2: libpreludedb-5.1.0-fix_gtkdoc_1.32.patch
|
||||
Patch3: libpreludedb-5.1.0-force_preludedb_admin_with_py3.patch
|
||||
Patch4: libpreludedb-5.1.0-update_m4_postgresql.patch
|
||||
Patch5: libpreludedb-5.1.0-Add-pkg-config-file.patch
|
||||
Patch6: libpreludedb-5.1.0-Fix_libdir_definition.patch
|
||||
Patch7: libpreludedb-5.1.0-fix-test_rwlock1.patch
|
||||
Patch8: libpreludedb-5.1.0-fix_thread_create.patch
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: bison
|
||||
@ -205,7 +209,10 @@ chmod +x %{buildroot}%{_datadir}/%{name}/classic/mysql2sqlite.sh
|
||||
%doc ChangeLog README NEWS
|
||||
|
||||
%changelog
|
||||
* Fri Nov 09 2019 Thomas Andrejak <thomas.andrejak@gmail.com> - 5.1.0-1
|
||||
* Sun Nov 10 2019 Thomas Andrejak <thomas.andrejak@gmail.com> - 5.1.0-2
|
||||
- Add missing patches
|
||||
|
||||
* Fri Nov 08 2019 Thomas Andrejak <thomas.andrejak@gmail.com> - 5.1.0-1
|
||||
- Bump version 5.1.0
|
||||
|
||||
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 5.0.0-5
|
||||
|
Loading…
Reference in New Issue
Block a user