removed old patch

This commit is contained in:
Thorsten Scherf 2007-01-05 19:13:30 +00:00
parent 61dffa6922
commit 97bc210d40
1 changed files with 0 additions and 50 deletions

View File

@ -1,50 +0,0 @@
--- libpreludedb-0.9.11/configure.in.lib64 2006-12-21 02:51:35.000000000 +0900
+++ libpreludedb-0.9.11/configure.in 2007-01-02 00:54:27.000000000 +0900
@@ -212,7 +212,10 @@
for dir in $default_path; do
AC_CHECK_FILE($dir/lib/libsqlite3.so, SQLITE3_LIBS="-L$dir -lsqlite3")
if test -z "$SQLITE3_LIBS"; then
- continue
+ AC_CHECK_FILE($dir/lib64/libsqlite3.so, SQLITE3_LIBS="-L$dir -L$dir/lib64 -lsqlite3")
+ if test -z "$SQLITE3_LIBS"; then
+ continue
+ fi
fi
AC_CHECK_FILE($dir/include/sqlite3.h, SQLITE3_CFLAGS="-I$dir")
--- libpreludedb-0.9.11/configure.lib64 2006-12-21 02:53:18.000000000 +0900
+++ libpreludedb-0.9.11/configure 2007-01-02 00:57:35.000000000 +0900
@@ -27318,7 +27318,32 @@
fi
if test -z "$SQLITE3_LIBS"; then
- continue
+ as_ac_File=`echo "ac_cv_file_$dir/lib64/libsqlite3.so" | $as_tr_sh`
+{ echo "$as_me:$LINENO: checking for $dir/lib64/libsqlite3.so" >&5
+echo $ECHO_N "checking for $dir/lib64/libsqlite3.so... $ECHO_C" >&6; }
+if { as_var=$as_ac_File; eval "test \"\${$as_var+set}\" = set"; }; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+else
+ test "$cross_compiling" = yes &&
+ { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+ { (exit 1); exit 1; }; }
+if test -r "$dir/lib64/libsqlite3.so"; then
+ eval "$as_ac_File=yes"
+else
+ eval "$as_ac_File=no"
+fi
+fi
+ac_res=`eval echo '${'$as_ac_File'}'`
+ { echo "$as_me:$LINENO: result: $ac_res" >&5
+echo "${ECHO_T}$ac_res" >&6; }
+if test `eval echo '${'$as_ac_File'}'` = yes; then
+ SQLITE3_LIBS="-L$dir -L$dir/lib64 -lsqlite3"
+fi
+
+ if test -z "$SQLITE3_LIBS"; then
+ continue
+ fi
fi
as_ac_File=`echo "ac_cv_file_$dir/include/sqlite3.h" | $as_tr_sh`