revert upgraded version

This commit is contained in:
Steve Grubb 2009-08-25 15:54:19 +00:00
parent 46b8db5f9e
commit 926546f961
2 changed files with 56 additions and 11 deletions

View File

@ -0,0 +1,52 @@
diff -ur libpreludedb-0.9.15.orig/configure libpreludedb-0.9.15/configure
--- libpreludedb-0.9.15.orig/configure 2008-08-27 12:06:58.000000000 -0400
+++ libpreludedb-0.9.15/configure 2008-08-27 16:47:11.000000000 -0400
@@ -22912,7 +22912,32 @@
fi
if test -z "$SQLITE3_LIBS"; then
- continue
+ as_ac_File=`echo "ac_cv_file_$dir/lib64/libsqlite3.so" | $as_tr_sh`
+{ echo "$as_me:$LINENO: checking for $dir/lib64/libsqlite3.so" >&5
+echo $ECHO_N "checking for $dir/lib64/libsqlite3.so... $ECHO_C" >&6; }
+if { as_var=$as_ac_File; eval "test \"\${$as_var+set}\" = set"; }; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+else
+ test "$cross_compiling" = yes &&
+ { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+ { (exit 1); exit 1; }; }
+if test -r "$dir/lib64/libsqlite3.so"; then
+ eval "$as_ac_File=yes"
+else
+ eval "$as_ac_File=no"
+fi
+fi
+ac_res=`eval echo '${'$as_ac_File'}'`
+ { echo "$as_me:$LINENO: result: $ac_res" >&5
+echo "${ECHO_T}$ac_res" >&6; }
+if test `eval echo '${'$as_ac_File'}'` = yes; then
+ SQLITE3_LIBS="-L$dir -L$dir/lib64 -lsqlite3"
+fi
+
+ if test -z "$SQLITE3_LIBS"; then
+ continue
+ fi
fi
as_ac_File=`echo "ac_cv_file_$dir/include/sqlite3.h" | $as_tr_sh`
diff -ur libpreludedb-0.9.15.orig/configure.in libpreludedb-0.9.15/configure.in
--- libpreludedb-0.9.15.orig/configure.in 2008-08-27 12:06:58.000000000 -0400
+++ libpreludedb-0.9.15/configure.in 2008-08-27 16:47:11.000000000 -0400
@@ -226,7 +226,10 @@
for dir in $default_path; do
AC_CHECK_FILE($dir/lib/libsqlite3.$libext, SQLITE3_LIBS="-L$dir -lsqlite3")
if test -z "$SQLITE3_LIBS"; then
- continue
+ AC_CHECK_FILE($dir/lib64/libsqlite3.$libext, SQLITE3_LIBS="-L$dir -L$dir/lib64 -lsqlite3")
+ if test -z "$SQLITE3_LIBS"; then
+ continue
+ fi
fi
AC_CHECK_FILE($dir/include/sqlite3.h, SQLITE3_CFLAGS="-I$dir")

View File

@ -2,14 +2,15 @@
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
Name: libpreludedb
Version: 0.9.15.2
Release: 3%{?dist}
Version: 0.9.15.1
Release: 4%{?dist}
Summary: Provide the framework for easy access to the Prelude database
Group: System Environment/Libraries
License: GPLv2+
URL: http://prelude-ids.org/
Source0: http://prelude-ids.org/download/releases/%{name}/%{name}-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Patch1: %{name}-x86_64-sqlite3.patch
BuildRequires: libprelude, libprelude-devel, mysql-devel, postgresql-devel, python-devel, sqlite-devel, perl-devel
@ -76,6 +77,7 @@ Perl bindings for libpreludedb.
%prep
%setup -q
%patch1 -p1
%build
@ -163,15 +165,6 @@ rm -rf %{buildroot}
%changelog
* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.9.15.2-3
- rebuilt with new openssl
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.15.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Mon Jul 13 2009 Steve Grubb <sgrubb@redhat.com> 0.9.15.2-1
- new upstream bugfix release
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.15.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild