added x86-build patch
This commit is contained in:
parent
99c24992c3
commit
51a777d455
50
libpreludedb-0.9.11-x86_64-sqlite3.patch
Normal file
50
libpreludedb-0.9.11-x86_64-sqlite3.patch
Normal file
@ -0,0 +1,50 @@
|
||||
--- libpreludedb-0.9.11/configure.in.lib64 2006-12-21 02:51:35.000000000 +0900
|
||||
+++ libpreludedb-0.9.11/configure.in 2007-01-02 00:54:27.000000000 +0900
|
||||
@@ -212,7 +212,10 @@
|
||||
for dir in $default_path; do
|
||||
AC_CHECK_FILE($dir/lib/libsqlite3.so, SQLITE3_LIBS="-L$dir -lsqlite3")
|
||||
if test -z "$SQLITE3_LIBS"; then
|
||||
- continue
|
||||
+ AC_CHECK_FILE($dir/lib64/libsqlite3.so, SQLITE3_LIBS="-L$dir -L$dir/lib64 -lsqlite3")
|
||||
+ if test -z "$SQLITE3_LIBS"; then
|
||||
+ continue
|
||||
+ fi
|
||||
fi
|
||||
|
||||
AC_CHECK_FILE($dir/include/sqlite3.h, SQLITE3_CFLAGS="-I$dir")
|
||||
--- libpreludedb-0.9.11/configure.lib64 2006-12-21 02:53:18.000000000 +0900
|
||||
+++ libpreludedb-0.9.11/configure 2007-01-02 00:57:35.000000000 +0900
|
||||
@@ -27318,7 +27318,32 @@
|
||||
fi
|
||||
|
||||
if test -z "$SQLITE3_LIBS"; then
|
||||
- continue
|
||||
+ as_ac_File=`echo "ac_cv_file_$dir/lib64/libsqlite3.so" | $as_tr_sh`
|
||||
+{ echo "$as_me:$LINENO: checking for $dir/lib64/libsqlite3.so" >&5
|
||||
+echo $ECHO_N "checking for $dir/lib64/libsqlite3.so... $ECHO_C" >&6; }
|
||||
+if { as_var=$as_ac_File; eval "test \"\${$as_var+set}\" = set"; }; then
|
||||
+ echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
+else
|
||||
+ test "$cross_compiling" = yes &&
|
||||
+ { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
+echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
+ { (exit 1); exit 1; }; }
|
||||
+if test -r "$dir/lib64/libsqlite3.so"; then
|
||||
+ eval "$as_ac_File=yes"
|
||||
+else
|
||||
+ eval "$as_ac_File=no"
|
||||
+fi
|
||||
+fi
|
||||
+ac_res=`eval echo '${'$as_ac_File'}'`
|
||||
+ { echo "$as_me:$LINENO: result: $ac_res" >&5
|
||||
+echo "${ECHO_T}$ac_res" >&6; }
|
||||
+if test `eval echo '${'$as_ac_File'}'` = yes; then
|
||||
+ SQLITE3_LIBS="-L$dir -L$dir/lib64 -lsqlite3"
|
||||
+fi
|
||||
+
|
||||
+ if test -z "$SQLITE3_LIBS"; then
|
||||
+ continue
|
||||
+ fi
|
||||
fi
|
||||
|
||||
as_ac_File=`echo "ac_cv_file_$dir/include/sqlite3.h" | $as_tr_sh`
|
@ -4,21 +4,25 @@
|
||||
Name: libpreludedb
|
||||
Version: 0.9.11
|
||||
Release: 4%{?dist}
|
||||
Summary: Provide the framework for easy access to the Prelude database
|
||||
Summary: Provide the framework for easy access to the Prelude database
|
||||
Group: System Environment/Libraries
|
||||
License: GPL
|
||||
URL: http://prelude-ids.org/
|
||||
Source0: http://prelude-ids.org/download/releases/%{name}-%{version}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Patch0: %{name}-%{version}-x86_64-sqlite3.patch
|
||||
|
||||
BuildRequires: libprelude, libprelude-devel, mysql-devel, postgresql-devel, python-devel, sqlite-devel
|
||||
|
||||
%description
|
||||
The PreludeDB Library provides an abstraction layer upon the type and the
|
||||
format of the database used to store IDMEF alerts.
|
||||
format
|
||||
of the database used to store IDMEF alerts.
|
||||
It allows developers to use the Prelude IDMEF database easily and
|
||||
efficiently without worrying about SQL, and to access the database
|
||||
independently of the type/format of the database.
|
||||
efficiently wi
|
||||
thout worrying about SQL,
|
||||
and to access the database independently of the type/format of the
|
||||
database.
|
||||
|
||||
%package devel
|
||||
Summary: Libraries and headers for PreludeDB
|
||||
@ -75,6 +79,7 @@ Perl bindings for libpreludedb.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
|
||||
%build
|
||||
@ -161,7 +166,7 @@ rm -rf %{buildroot}
|
||||
|
||||
%changelog
|
||||
* Mon Jan 01 2007 Thorsten Scherf <tscherf@redhat.com> 0.9.11-4
|
||||
- changed summary
|
||||
- added x86_64-sqlite3.patch to resolve x86_86 build problems
|
||||
|
||||
* Sun Dec 31 2006 Thorsten Scherf <tscherf@redhat.com> 0.9.11-3
|
||||
- resolved macro problem in changelog
|
||||
@ -185,4 +190,5 @@ rm -rf %{buildroot}
|
||||
|
||||
* Tue Oct 24 2006 Thorsten Scherf <tscherf@redhat.com> 0.9.10-1
|
||||
- New fedora build based on release 0.9.10
|
||||
- New fedora build based on release 0.9.10
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user