Initial import (#1386938).

This commit is contained in:
Thomas Andrejak 2016-12-05 22:45:15 +01:00
parent 245366323e
commit b07b343fb9
9 changed files with 631 additions and 1 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
/libprelude-3.1.0.tar.gz

View File

@ -1 +0,0 @@
Upstream has been dead for over a year

View File

@ -0,0 +1,31 @@
--- ./src/idmef-criterion-value.c 2016-12-04 22:36:21.364349964 +0100
+++ ./src/idmef-criterion-value.c 2016-12-04 22:37:40.770573582 +0100
@@ -194,22 +194,22 @@
/*
* Apply mask
*/
- if ( comp.tm_sec < 0 ) lt.tm_sec = -1;
+ if ( comp.tm_sec < 0 ) comp.tm_sec = lt.tm_sec;
else need_full_compare = TRUE;
- if ( comp.tm_min < 0 ) lt.tm_min = -1;
+ if ( comp.tm_min < 0 ) comp.tm_min = lt.tm_min;
else need_full_compare = TRUE;
- if ( comp.tm_mon < 0 ) lt.tm_mon = -1;
+ if ( comp.tm_mon < 0 ) comp.tm_mon = lt.tm_mon;
else need_full_compare = TRUE;
- if ( comp.tm_hour < 0 ) lt.tm_hour = -1;
+ if ( comp.tm_hour < 0 ) comp.tm_hour = lt.tm_hour;
else need_full_compare = TRUE;
- if ( comp.tm_mday < 0 ) lt.tm_mday = -1;
+ if ( comp.tm_mday < 0 ) comp.tm_mday = lt.tm_mday;
else need_full_compare = TRUE;
- if ( comp.tm_year < 0 ) lt.tm_year = -1;
+ if ( comp.tm_year < 0 ) comp.tm_year = lt.tm_year;
else need_full_compare = TRUE;
if ( comp.tm_wday < 0 ) lt.tm_wday = -1;

View File

@ -0,0 +1,246 @@
diff -ru ./src/libprelude-error/err-codes.h ./src/libprelude-error/err-codes.h
--- ./src/libprelude-error/err-codes.h 2016-09-15 08:51:51.964000884 +0200
+++ ./src/libprelude-error/err-codes.h 2016-12-02 07:37:52.786070647 +0100
@@ -15,10 +15,9 @@
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.
- You should have received a copy of the GNU Lesser General Public
- License along with libgpg-error; if not, write to the Free
- Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
- 02111-1307, USA. */
+ You should have received a copy of the GNU General Public License along
+ with this program; if not, write to the Free Software Foundation, Inc.,
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. */
/* The purpose of this complex string table is to produce
diff -ru ./src/libprelude-error/err-codes.h.in ./src/libprelude-error/err-codes.h.in
--- ./src/libprelude-error/err-codes.h.in 2016-09-15 08:49:10.805000884 +0200
+++ ./src/libprelude-error/err-codes.h.in 2016-12-02 07:38:08.252722176 +0100
@@ -14,10 +14,9 @@
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.
- You should have received a copy of the GNU Lesser General Public
- License along with libgpg-error; if not, write to the Free
- Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
- 02111-1307, USA. */
+ You should have received a copy of the GNU General Public License along
+ with this program; if not, write to the Free Software Foundation, Inc.,
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. */
# Everything up to the first line that starts with a number in the
# first column is copied into the output verbatim. Then, empty lines
diff -ru ./src/libprelude-error/errnos.in ./src/libprelude-error/errnos.in
--- ./src/libprelude-error/errnos.in 2016-09-15 08:49:10.806000884 +0200
+++ ./src/libprelude-error/errnos.in 2016-12-02 07:38:23.777372399 +0100
@@ -14,10 +14,9 @@
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.
- You should have received a copy of the GNU Lesser General Public
- License along with libgpg-error; if not, write to the Free
- Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
- 02111-1307, USA. */
+ You should have received a copy of the GNU General Public License along
+ with this program; if not, write to the Free Software Foundation, Inc.,
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. */
# Everything up to the first line that starts with a number in the
# first column is copied into the output verbatim. Then, empty lines
diff -ru ./src/libprelude-error/err-sources.h ./src/libprelude-error/err-sources.h
--- ./src/libprelude-error/err-sources.h 2016-09-15 08:51:51.961000884 +0200
+++ ./src/libprelude-error/err-sources.h 2016-12-02 07:38:32.605173508 +0100
@@ -15,10 +15,9 @@
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.
- You should have received a copy of the GNU Lesser General Public
- License along with libgpg-error; if not, write to the Free
- Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
- 02111-1307, USA. */
+ You should have received a copy of the GNU General Public License along
+ with this program; if not, write to the Free Software Foundation, Inc.,
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. */
/* The purpose of this complex string table is to produce
diff -ru ./src/libprelude-error/err-sources.h.in ./src/libprelude-error/err-sources.h.in
--- ./src/libprelude-error/err-sources.h.in 2016-09-15 08:49:10.806000884 +0200
+++ ./src/libprelude-error/err-sources.h.in 2016-12-02 07:39:14.072239231 +0100
@@ -14,10 +14,9 @@
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.
- You should have received a copy of the GNU Lesser General Public
- License along with libgpg-error; if not, write to the Free
- Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
- 02111-1307, USA. */
+ You should have received a copy of the GNU General Public License along
+ with this program; if not, write to the Free Software Foundation, Inc.,
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. */
# Everything up to the first line that starts with a number in the
# first column is copied into the output verbatim. Then, empty lines
diff -ru ./src/libprelude-error/mkerrcodes1.awk ./src/libprelude-error/mkerrcodes1.awk
--- ./src/libprelude-error/mkerrcodes1.awk 2016-09-15 08:49:10.806000884 +0200
+++ ./src/libprelude-error/mkerrcodes1.awk 2016-12-02 07:40:41.671265585 +0100
@@ -11,9 +11,9 @@
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
# As a special exception, g10 Code GmbH gives unlimited permission to
# copy, distribute and modify the C source files that are the output
diff -ru ./src/libprelude-error/mkerrcodes2.awk ./src/libprelude-error/mkerrcodes2.awk
--- ./src/libprelude-error/mkerrcodes2.awk 2016-09-15 08:49:10.806000884 +0200
+++ ./src/libprelude-error/mkerrcodes2.awk 2016-12-02 07:40:57.327912836 +0100
@@ -11,9 +11,9 @@
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
# As a special exception, g10 Code GmbH gives unlimited permission to
# copy, distribute and modify the C source files that are the output
diff -ru ./src/libprelude-error/mkerrcodes.awk ./src/libprelude-error/mkerrcodes.awk
--- ./src/libprelude-error/mkerrcodes.awk 2016-09-15 08:49:10.806000884 +0200
+++ ./src/libprelude-error/mkerrcodes.awk 2016-12-02 07:41:21.451369320 +0100
@@ -11,9 +11,9 @@
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
# As a special exception, g10 Code GmbH gives unlimited permission to
# copy, distribute and modify the C source files that are the output
diff -ru ./src/libprelude-error/mkerrcodes.c ./src/libprelude-error/mkerrcodes.c
--- ./src/libprelude-error/mkerrcodes.c 2016-09-15 08:49:10.806000884 +0200
+++ ./src/libprelude-error/mkerrcodes.c 2016-12-02 07:42:27.668877410 +0100
@@ -13,10 +13,9 @@
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.
- You should have received a copy of the GNU Lesser General Public
- License along with libgpg-error; if not, write to the Free
- Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
- 02111-1307, USA. */
+ You should have received a copy of the GNU General Public License along
+ with this program; if not, write to the Free Software Foundation, Inc.,
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. */
/* This file must not include config.h, as that is for the host
system, while this file will be run on the build system. */
@@ -40,10 +39,9 @@
" MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU\n"
" Lesser General Public License for more details.\n"
"\n"
-" You should have received a copy of the GNU Lesser General Public\n"
-" License along with libgpg-error; if not, write to the Free\n"
-" Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA\n"
-" 02111-1307, USA. */\n"
+" You should have received a copy of the GNU General Public License along\n"
+" with this program; if not, write to the Free Software Foundation,\n"
+" Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. */\n"
"\n";
int
diff -ru ./src/libprelude-error/mkerrnos.awk ./src/libprelude-error/mkerrnos.awk
--- ./src/libprelude-error/mkerrnos.awk 2016-09-15 08:49:10.806000884 +0200
+++ ./src/libprelude-error/mkerrnos.awk 2016-12-02 07:42:46.332456910 +0100
@@ -11,9 +11,9 @@
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
# As a special exception, g10 Code GmbH gives unlimited permission to
# copy, distribute and modify the C source files that are the output
diff -ru ./src/libprelude-error/mkheader.awk ./src/libprelude-error/mkheader.awk
--- ./src/libprelude-error/mkheader.awk 2016-09-15 08:49:10.806000884 +0200
+++ ./src/libprelude-error/mkheader.awk 2016-12-02 07:42:59.250165869 +0100
@@ -11,9 +11,9 @@
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
# As a special exception, g10 Code GmbH gives unlimited permission to
# copy, distribute and modify the C source files that are the output
diff -ru ./src/libprelude-error/mkstrtable.awk ./src/libprelude-error/mkstrtable.awk
--- ./src/libprelude-error/mkstrtable.awk 2016-09-15 08:49:10.806000884 +0200
+++ ./src/libprelude-error/mkstrtable.awk 2016-12-02 07:43:08.552956273 +0100
@@ -11,9 +11,9 @@
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
# As a special exception, g10 Code GmbH gives unlimited permission to
# copy, distribute and modify the C source files that are the output
diff -ru ./src/libprelude-error/strerror.c ./src/libprelude-error/strerror.c
--- ./src/libprelude-error/strerror.c 2016-09-15 08:49:10.806000884 +0200
+++ ./src/libprelude-error/strerror.c 2016-12-02 07:44:11.256543536 +0100
@@ -13,10 +13,9 @@
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.
- You should have received a copy of the GNU Lesser General Public
- License along with libgpg-error; if not, write to the Free
- Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
- 02111-1307, USA. */
+ You should have received a copy of the GNU General Public License along
+ with this program; if not, write to the Free Software Foundation, Inc.,
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. */
#include "config.h"
diff -ru ./src/libprelude-error/strsource.c ./src/libprelude-error/strsource.c
--- ./src/libprelude-error/strsource.c 2016-09-15 08:49:10.806000884 +0200
+++ ./src/libprelude-error/strsource.c 2016-12-02 07:44:26.455201104 +0100
@@ -13,10 +13,9 @@
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.
- You should have received a copy of the GNU Lesser General Public
- License along with libgpg-error; if not, write to the Free
- Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
- 02111-1307, USA. */
+ You should have received a copy of the GNU General Public License along
+ with this program; if not, write to the Free Software Foundation, Inc.,
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. */
#include "config.h"

View File

@ -0,0 +1,37 @@
--- ./prelude-admin/server.c 2016-11-21 16:52:01.839000884 +0100
+++ ./prelude-admin/server.c 2016-11-26 11:48:52.695000891 +0100
@@ -145,22 +145,10 @@
gnutls_session_t session;
const char *err;
-#if defined LIBGNUTLS_VERSION_MAJOR && LIBGNUTLS_VERSION_MAJOR >= 3
-# define TLS_DH_STR "+ANON-ECDH:+ANON-DH"
-#else
-# define TLS_DH_STR "+ANON-DH"
-#endif
-
-#ifdef GNUTLS_SRP_ENABLED
- const char *pstring = "NORMAL:+SRP:+SRP-DSS:+SRP-RSA:" TLS_DH_STR;
-#else
- const char *pstring = "NORMAL:" TLS_DH_STR;
-#endif
-
gnutls_init(&session, GNUTLS_SERVER);
gnutls_set_default_priority(session);
- ret = gnutls_priority_set_direct(session, pstring, &err);
+ ret = gnutls_priority_set_direct(session, "@SYSTEM", &err);
if (ret < 0) {
fprintf(stderr, "TLS priority syntax error at: %s\n", err);
return NULL;
--- ./src/tls-auth.c 2016-09-15 08:49:10.809000884 +0200
+++ ./src/tls-auth.c 2016-11-30 23:08:58.649439656 +0100
@@ -232,7 +232,7 @@
int ret;
const char *errptr;
- ret = gnutls_priority_init(&tls_priority, (tlsopts) ? tlsopts : "NORMAL", &errptr);
+ ret = gnutls_priority_init(&tls_priority, (tlsopts) ? tlsopts : "@SYSTEM", &errptr);
if ( ret < 0 )
return prelude_error_verbose_make(PRELUDE_ERROR_SOURCE_CLIENT, PRELUDE_ERROR_TLS,
"TLS options '%s': %s", errptr, gnutls_strerror(ret));

View File

@ -0,0 +1,14 @@
diff -up ./bindings/perl/Makefile.PL.in.orig ./bindings/perl/Makefile.PL.in
--- ./bindings/perl/Makefile.PL.in.orig 2016-10-16 17:13:27.006400921 +0300
+++ ./bindings/perl/Makefile.PL.in 2016-10-16 17:14:39.521628420 +0300
@@ -26,8 +26,8 @@ use Cwd "abs_path";
my %attributs = (NAME => 'Prelude',
INC => '-I@top_builddir@ -I@top_builddir@/src/include -I@top_srcdir@/src/include -I@top_builddir@/src/libprelude-error -I@top_srcdir@/bindings/c++/include',
- LIBS => ["-L@top_builddir@/src/.libs -lprelude -L@top_builddir@/bindings/c++/.libs -lpreludecpp", "-L$ENV{LIBDIR} -lprelude @LIBPRELUDE_LIBS@ @LIBADD_DL@ @LTLIBTHREAD@" ],
- LDDLFLAGS => "-L@top_builddir@/src/.libs $Config{lddlflags} @LDFLAGS@,-rpath");
+ LIBS => ["-L@top_builddir@/src/.libs -lprelude -L@top_builddir@/bindings/c++/.libs -lpreludecpp -L$ENV{LIBDIR} -lstdc++ -lm @LIBPRELUDE_LIBS@ @LIBADD_DL@ @LTLIBTHREAD@" ],
+ LDDLFLAGS => "-L@top_builddir@/src/.libs $Config{lddlflags} @LDFLAGS@");
if ( abs_path("@top_srcdir@") ne abs_path("@top_builddir@") ) {
foreach my $filename ( qw/Prelude.cxx Prelude.pm/ ) {

View File

@ -0,0 +1,11 @@
--- ./configure 2016-09-15 08:51:15.490000884 +0200
+++ ./configure.new 2016-10-31 20:01:06.731235733 +0100
@@ -21874,7 +21874,7 @@
if ${am_cv_ruby_rbexecdir+:} false; then :
$as_echo_n "(cached) " >&6
else
- am_cv_ruby_rbexecdir=`$RUBY -rrbconfig -e "drive = File::PATH_SEPARATOR == ';' ? /\A\w:/ : /\A/; prefix = Regexp.new('\\A' + Regexp.quote(RbConfig::CONFIG['prefix'])); \\$prefix = RbConfig::CONFIG['prefix'].sub(drive, ''); \\$sitearchdir = RbConfig::CONFIG['sitearchdir'].sub(prefix, '\\$(prefix)').sub(drive, ''); print \\$sitearchdir;" 2>/dev/null || echo "${RUBY_EXEC_PREFIX}/local/lib/site_ruby/${RUBY_VERSION}/${RUBY_PLATFORM}"`
+ am_cv_ruby_rbexecdir=`$RUBY -rrbconfig -e "drive = File::PATH_SEPARATOR == ';' ? /\A\w:/ : /\A/; prefix = Regexp.new('\\A' + Regexp.quote(RbConfig::CONFIG['prefix'])); \\$prefix = RbConfig::CONFIG['prefix'].sub(drive, ''); \\$sitearchdir = RbConfig::CONFIG['vendorarchdir'].sub(prefix, '\\$(prefix)').sub(drive, ''); print \\$sitearchdir;" 2>/dev/null || echo "${RUBY_EXEC_PREFIX}/local/lib/site_ruby/${RUBY_VERSION}/${RUBY_PLATFORM}"`
fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_ruby_rbexecdir" >&5
$as_echo "$am_cv_ruby_rbexecdir" >&6; }

290
libprelude.spec Normal file
View File

@ -0,0 +1,290 @@
%global major 23
%global cppmajor 8
# Notes about rpmlint
# - crypto-policy-non-compliance-gnutls-{1,2} fixed with patch
# libprelude-3.1.0-gnutls_priority_set_direct.patch
Name: libprelude
Version: 3.1.0
Release: 26%{?dist}
Summary: Secure Connections between all Sensors and the Prelude Manager
# Prelude is GPL-2.0+
# libmissing is LGPL-2.1+
License: GPLv2+
Group: System Environment/Libraries
URL: https://www.prelude-siem.org/
Source0: https://www.prelude-siem.org/pkg/src/3.1.0/%{name}-%{version}.tar.gz
# https://www.prelude-siem.org/issues/859
Patch0: libprelude-3.1.0-linking.patch
# https://www.prelude-siem.org/issues/860
Patch1: libprelude-3.1.0-ruby_vendorarchdir.patch
# https://www.prelude-siem.org/issues/862
Patch2: libprelude-3.1.0-gnutls_priority_set_direct.patch
# https://www.prelude-siem.org/issues/863
Patch3: libprelude-3.1.0-fsf_address.patch
# https://www.prelude-siem.org/issues/865
Patch4: libprelude-3.1.0-fix_timegm.patch
BuildRequires: bison
BuildRequires: chrpath
BuildRequires: flex
BuildRequires: gtk-doc
BuildRequires: swig
BuildRequires: libgcrypt-devel
BuildRequires: libgpg-error-devel
BuildRequires: libtool-ltdl-devel
BuildRequires: perl-devel
BuildRequires: perl-generators
BuildRequires: python2-devel
BuildRequires: python3-devel
BuildRequires: pkgconfig(gnutls)
BuildRequires: pkgconfig(lua) >= 5.2
BuildRequires: pkgconfig(ruby)
BuildRequires: pkgconfig(zlib)
%ifnarch s390
BuildRequires: valgrind
%endif
# Upstream do not use explicit version of gnulib, just checkout
# and update files. In libprelude 3.1.0, the checkout has been done
# on 2016-06-16
Provides: bundled(gnulib) = 20160616
ExcludeArch: ppc64 ppc64le aarch64 armv7hl
%description
Libprelude is a collection of generic functions providing communication
between all Sensors, like IDS (Intrusion Detection System), and the Prelude
Manager. It provides a convenient interface for sending and receiving IDMEF
(Information and Event Message Exchange Format) alerts to Prelude Manager with
transparent SSL, fail-over and replication support, asynchronous events and
timer interfaces, an abstracted configuration API (hooking at the command-line,
the configuration line, or wide configuration, available from the Manager), and
a generic plugin API. It allows you to easily turn your favorite security
program into a Prelude sensor.
%package devel
Summary: Libraries and headers for developing Prelude sensors
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: libtool-ltdl-devel
Provides: %{name}%{?_isa}-devel = %{version}-%{release}
Provides: prelude-devel = %{version}-%{release}
%description devel
Libraries and headers you can use to develop Prelude sensors using the Prelude
Library. Libprelude is a collection of generic functions providing
communication between all Sensors, like IDS (Intrusion Detection System),
and the Prelude Manager. It provides a convenient interface for sending and
receiving IDMEF (Information and Event Message Exchange Format) alerts to
Prelude Manager with transparent SSL, fail-over and replication support,
asynchronous events and timer interfaces, an abstracted configuration API
(hooking at the command-line, the configuration line, or wide configuration,
available from the Manager), and a generic plugin API. It allows you to easily
turn your favorite security program into a Prelude sensor.
%package -n prelude-tools
Summary: Command-line tools for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description -n prelude-tools
Provides a convenient interface for sending alerts to Prelude
Manager.
%package -n python2-prelude
Summary: Python 2 bindings for prelude
Requires: %{name}%{?_isa} = %{version}-%{release}
%{?python_provide:%python_provide python2-prelude}
%description -n python2-prelude
Provides python 2 bindings for prelude.
%package -n python3-prelude
Summary: Python 3 bindings for prelude
Requires: %{name}%{?_isa} = %{version}-%{release}
%{?python_provide:%python_provide python3-prelude}
%description -n python3-prelude
Provides python 3 bindings for prelude.
%package -n perl-prelude
Summary: Perl bindings for prelude
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%description -n perl-prelude
Provides perl bindings for prelude.
%package -n ruby-prelude
Summary: Ruby bindings for prelude
Requires: %{name}%{?_isa} = %{version}-%{release}
%description -n ruby-prelude
Provides ruby bindings for prelude.
%package -n lua-prelude
Summary: Lua bindings for prelude
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: lua
%description -n lua-prelude
Provides Lua bindings for prelude generated by SWIG.
%package doc
Summary: Documentation for prelude
BuildArch: noarch
%description doc
Provides documentation for prelude generated by gtk-doc.
%prep
%autosetup -p1
%build
%configure \
--without-included-ltdl \
--disable-static \
--enable-shared \
--with-swig \
--with-python2 \
--with-python3 \
--with-ruby \
--with-lua \
--with-perl-installdirs=vendor \
--without-included-regex \
--includedir=%{_includedir}/%{name} \
--enable-gtk-doc \
--with-html-dir=%{_docdir}/%{name}-devel
sed -i -e 's! -shared ! -Wl,--as-needed\0!g' libtool
%make_build
%install
%make_install
chrpath -d %{buildroot}%{_libdir}/*.so.*
find %{buildroot} -name '*.la' -delete
find %{buildroot} -name 'perllocal.pod' -delete
find %{buildroot} -name '.packlist' -delete
%check
make distcheck
%post -n %{name} -p /sbin/ldconfig
%postun -n %{name} -p /sbin/ldconfig
%files
%{_libdir}/%{name}.so.%{major}
%{_libdir}/%{name}.so.%{major}.*
%{_libdir}/%{name}cpp.so.%{cppmajor}
%{_libdir}/%{name}cpp.so.%{cppmajor}.*
%license COPYING LICENSE.README HACKING.README
%doc AUTHORS README NEWS
%files devel
%{_datadir}/%{name}
%{_bindir}/%{name}-config
%{_libdir}/%{name}.so
%{_libdir}/%{name}cpp.so
%{_libdir}/pkgconfig/%{name}.pc
%{_includedir}/%{name}
%{_datadir}/aclocal/%{name}.m4
%{_mandir}/man1/%{name}-config.1.gz
%files -n prelude-tools
# Force default attrs because libprelude force others
%defattr(- , root, root, 755)
%{_bindir}/prelude-adduser
%{_bindir}/prelude-admin
%{_mandir}/man1/prelude-admin.1.gz
%dir %{_sysconfdir}/prelude
%dir %{_sysconfdir}/prelude/default
%dir %{_sysconfdir}/prelude/profile
%config(noreplace) %{_sysconfdir}/prelude/default/client.conf
%config(noreplace) %{_sysconfdir}/prelude/default/global.conf
%config(noreplace) %{_sysconfdir}/prelude/default/idmef-client.conf
%config(noreplace) %{_sysconfdir}/prelude/default/tls.conf
%dir %{_var}/spool/prelude
%files -n python2-prelude
%{python2_sitearch}/_prelude.*so
%{python2_sitearch}/prelude-%{version}-py?.?.egg-info
%{python2_sitearch}/prelude.{py,pyc,pyo}
%files -n python3-prelude
%{python3_sitearch}/_prelude.*so
%{python3_sitearch}/__pycache__/prelude.cpython-??.*pyc
%{python3_sitearch}/prelude-%{version}-py?.?.egg-info
%{python3_sitearch}/prelude.py
%files -n perl-prelude
%{perl_vendorarch}/Prelude.pm
%dir %{perl_vendorarch}/auto/Prelude
# Force attrs because libprelude set it to 555
%attr(755, root, root) %{perl_vendorarch}/auto/Prelude/Prelude.so
%files -n ruby-prelude
%{ruby_vendorarchdir}/Prelude.so
%files -n lua-prelude
%{_libdir}/lua/*/prelude.so
%files doc
%{_docdir}/%{name}-devel
%license COPYING LICENSE.README HACKING.README
%doc AUTHORS ChangeLog README NEWS
%changelog
* Wed Oct 19 2016 Thomas Andrejak <thomas.andrejak@gmail.com> - 3.1.0-26
- Bump version
* Sun Mar 10 2013 Steve Grubb <sgrubb@redhat.com> - 1:1.0.0-17
- Rebuild with new gnutls
* Thu Sep 06 2012 Steve Grubb <sgrubb@redhat.com> - 1:1.0.0-16
- Add provides bundled gnulib
* Wed Aug 08 2012 Petr Pisar <ppisar@redhat.com> - 1:1.0.0-15
- Fix building with glibc-2.16.6 (bug #839602)
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.0.0-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Thu Jun 07 2012 Petr Pisar <ppisar@redhat.com> - 1:1.0.0-13
- Perl 5.16 rebuild
* Tue Mar 13 2012 Steve Grubb <sgrubb@redhat.com> - 1:1.0.0-12
- Drop support for ruby
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.0.0-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Tue Jul 19 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.0.0-10
- Perl mass rebuild
* Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> - 1:1.0.0-9
- Fix gcc 4.6 C++ bug (#715983)
* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.0.0-8
- Perl mass rebuild
* Thu Jun 09 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.0.0-7
- Perl 5.14 mass rebuild
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.0.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1:1.0.0-5
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
* Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 1:1.0.0-4
- Mass rebuild with perl-5.12.0
* Sun May 02 2010 Steve Grubb <sgrubb@redhat.com> - 1.0.0-3
- Fix requires statements
* Fri Apr 30 2010 Steve Grubb <sgrubb@redhat.com> - 1.0.0-2
- New upstream release
* Sat Jan 30 2010 Steve Grubb <sgrubb@redhat.com> - 1.0.0rc1-1
- New upstream release

1
sources Normal file
View File

@ -0,0 +1 @@
2e1a5d7cbf98a2d57fbb367a578dbf8c libprelude-3.1.0.tar.gz