Fix gcc 4.6 C++ bug (#715983)

This commit is contained in:
Steve Grubb 2011-06-24 13:44:28 -04:00
parent 5238595129
commit 8537811310
2 changed files with 21 additions and 1 deletions

View File

@ -0,0 +1,12 @@
diff -urp libprelude-1.0.0.orig/bindings/c++/include/prelude.hxx libprelude-1.0.0/bindings/c++/include/prelude.hxx
--- libprelude-1.0.0.orig/bindings/c++/include/prelude.hxx 2011-06-24 12:58:29.000000000 -0400
+++ libprelude-1.0.0/bindings/c++/include/prelude.hxx 2011-06-24 12:59:01.000000000 -0400
@@ -26,6 +26,8 @@
#ifndef _LIBPRELUDE_PRELUDE_HXX
#define _LIBPRELUDE_PRELUDE_HXX
+#include <stddef.h>
+
#include "prelude-client.hxx"
#include "prelude-client-easy.hxx"
#include "prelude-connection.hxx"

View File

@ -6,12 +6,13 @@
Name: libprelude
Epoch: 1
Version: 1.0.0
Release: 8%{?dist}
Release: 9%{?dist}
Summary: The prelude library
Group: System Environment/Libraries
License: GPLv2+
URL: http://prelude-ids.org/
Source0: http://www.prelude-ids.org/download/releases/%{name}/%{name}-%{version}.tar.gz
Patch1: libprelude-1.0.0-gcc46.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: gnutls-devel, python-devel, ruby, ruby-devel, lua-devel
@ -68,6 +69,7 @@ Ruby bindings for libprelude.
%prep
%setup -q
%patch1 -p1
%build
%configure --disable-static \
@ -97,6 +99,9 @@ rm -f %{buildroot}%{ruby_sitearch}/PreludeEasy.la
chmod +w %{buildroot}%{perl_vendorarch}/auto/Prelude/Prelude.so
chrpath -d %{buildroot}%{perl_vendorarch}/auto/Prelude/Prelude.so
chmod -w %{buildroot}%{perl_vendorarch}/auto/Prelude/Prelude.so
chmod +w %{buildroot}%(perl_vendorarch}/auto/PreludeEasy/PreludeEasy.so
chrpath -d %{buildroot}%(perl_vendorarch}/auto/PreludeEasy/PreludeEasy.so
chmod -w %{buildroot}%(perl_vendorarch}/auto/PreludeEasy/PreludeEasy.so
# Fix time stamp for both 32 and 64 bit libraries
touch -r ./configure.in %{buildroot}%{_sysconfdir}/prelude/default/*
@ -142,6 +147,9 @@ rm -rf %{buildroot}
%{ruby_sitearch}/PreludeEasy.so
%changelog
* Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> - 1.0.0-9
- Fix gcc 4.6 C++ bug (#715983)
* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.0.0-8
- Perl mass rebuild