Fix FTBFS with awk 5

Fix FTBFS with Python 3.8 (#1706042)
This commit is contained in:
Thomas Andrejak 2019-07-12 09:45:28 +02:00
parent 3f38511222
commit 8413eb0a67
4 changed files with 3708 additions and 1 deletions

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,112 @@
--- ./src/libprelude-error/Makefile.am 2018-12-23 21:59:17.340000000 +0100
+++ ./src/libprelude-error/Makefile.am 2019-07-11 17:33:18.537430699 +0200
@@ -53,7 +53,7 @@
errnos-sym.h: Makefile mkstrtable.awk errnos.in
LANG="" $(AWK) -f $(srcdir)/mkstrtable.awk -v textidx=2 -v nogettext=1 \
- -v prefix=PRELUDE_ERROR_ -v namespace=errnos_ \
+ -v prefix=PRELUDE_ERROR_ -v pkg_namespace=errnos_ \
$(srcdir)/errnos.in >$@
prelude-error.h: Makefile mkheader.awk err-sources.h.in err-codes.h.in errnos.in prelude-error.h.in
--- ./src/libprelude-error/Makefile.in 2018-12-23 22:01:05.090000000 +0100
+++ ./src/libprelude-error/Makefile.in 2019-07-11 17:33:10.202599542 +0200
@@ -1834,7 +1834,7 @@
errnos-sym.h: Makefile mkstrtable.awk errnos.in
LANG="" $(AWK) -f $(srcdir)/mkstrtable.awk -v textidx=2 -v nogettext=1 \
- -v prefix=PRELUDE_ERROR_ -v namespace=errnos_ \
+ -v prefix=PRELUDE_ERROR_ -v pkg_namespace=errnos_ \
$(srcdir)/errnos.in >$@
prelude-error.h: Makefile mkheader.awk err-sources.h.in err-codes.h.in errnos.in prelude-error.h.in
--- ./src/libprelude-error/mkerrcodes.awk 2018-12-23 21:59:17.340000000 +0100
+++ ./src/libprelude-error/mkerrcodes.awk 2019-07-11 17:34:56.482462208 +0200
@@ -78,7 +78,7 @@
}
!header {
- sub (/\#.+/, "");
+ sub (/#.+/, "");
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
if (/^$/)
--- ./src/libprelude-error/mkerrcodes1.awk 2018-12-23 21:59:17.341000000 +0100
+++ ./src/libprelude-error/mkerrcodes1.awk 2019-07-11 17:35:02.737336699 +0200
@@ -78,7 +78,7 @@
}
!header {
- sub (/\#.+/, "");
+ sub (/#.+/, "");
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
if (/^$/)
--- ./src/libprelude-error/mkerrcodes2.awk 2018-12-23 21:59:17.341000000 +0100
+++ ./src/libprelude-error/mkerrcodes2.awk 2019-07-11 17:35:08.595219159 +0200
@@ -91,7 +91,7 @@
}
!header {
- sub (/\#.+/, "");
+ sub (/#.+/, "");
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
if (/^$/)
--- ./src/libprelude-error/mkerrnos.awk 2019-07-11 17:41:09.385940916 +0200
+++ ./src/libprelude-error/mkerrnos.awk 2019-07-11 17:41:22.455671539 +0200
@@ -80,7 +80,7 @@
}
!header {
- sub (/\#.+/, "");
+ sub (/#.+/, "");
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
if (/^$/)
--- ./src/libprelude-error/mkstrtable.awk 2018-12-23 21:59:17.341000000 +0100
+++ ./src/libprelude-error/mkstrtable.awk 2019-07-11 17:38:41.588950860 +0200
@@ -77,7 +77,7 @@
#
# The variable prefix can be used to prepend a string to each message.
#
-# The variable namespace can be used to prepend a string to each
+# The variable pkg_namespace can be used to prepend a string to each
# variable and macro name.
BEGIN {
@@ -102,7 +102,7 @@
print "/* The purpose of this complex string table is to produce";
print " optimal code with a minimum of relocations. */";
print "";
- print "static const char " namespace "msgstr[] = ";
+ print "static const char " pkg_namespace "msgstr[] = ";
header = 0;
}
else
@@ -110,7 +110,7 @@
}
!header {
- sub (/\#.+/, "");
+ sub (/#.+/, "");
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
if (/^$/)
@@ -150,14 +150,14 @@
else
print " gettext_noop (\"" prefix last_msgstr "\");";
print "";
- print "static const int " namespace "msgidx[] =";
+ print "static const int " pkg_namespace "msgidx[] =";
print " {";
for (i = 0; i < coded_msgs; i++)
print " " pos[i] ",";
print " " pos[coded_msgs];
print " };";
print "";
- print "#define " namespace "msgidxof(code) (0 ? -1 \\";
+ print "#define " pkg_namespace "msgidxof(code) (0 ? -1 \\";
# Gather the ranges.
skip = code[0];

View File

@ -0,0 +1,11 @@
--- ./bindings/python/_prelude.cxx 2019-07-12 07:19:49.365476420 +0200
+++ ./bindings/python/_prelude.cxx 2019-07-12 07:20:02.458213034 +0200
@@ -3132,7 +3132,7 @@
SWIGINTERN void
SwigPyStaticVar_dealloc(PyDescrObject *descr) {
- _PyObject_GC_UNTRACK(descr);
+ PyObject_GC_UnTrack(descr);
Py_XDECREF(PyDescr_TYPE(descr));
Py_XDECREF(PyDescr_NAME(descr));
PyObject_GC_Del(descr);

View File

@ -7,7 +7,7 @@
Name: libprelude
Version: 5.0.0
Release: 3%{?dist}
Release: 4%{?dist}
Summary: Secure Connections between all Sensors and the Prelude Manager
# Prelude is GPL-2.0+
# libmissing is LGPL-2.1+
@ -28,6 +28,9 @@ Patch4: libprelude-5.0.0-fix_pthread_atfork.patch
Patch5: libprelude-5.0.0-fix_prelude_tests_timer.patch
Patch6: libprelude-5.0.0-disable_gnulib_test_lock.patch
Patch7: libprelude-5.0.0-fix-for-swig4.patch
Patch8: libprelude-5.0.0-fix_awk_error.patch
Patch9: libprelude-5.0.0-bump_swig_files_to_swig4.patch
Patch10: libprelude-5.0.0-fix_py38.patch
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: bison
@ -224,6 +227,10 @@ find %{buildroot} -name '.packlist' -delete
%doc AUTHORS ChangeLog README NEWS
%changelog
* Fri Jul 12 2019 Thomas Andrejak <thomas.andrejak@gmail.com> - 5.0.0-4
- Fix FTBFS with awk 5
- Fix FTBFS with Python 3.8 (#1706042)
* Fri May 31 2019 Jitka Plesnikova <jplesnik@redhat.com> - 5.0.0-3
- Perl 5.30 rebuild