Bump version 4.0.0

This commit is contained in:
Thomas Andrejak 2017-09-18 12:12:19 +02:00
parent 362c6b2e97
commit 7357bfc3c3
11 changed files with 113 additions and 106 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/libprelude-3.1.0.tar.gz
/libprelude-4.0.0.tar.gz

View File

@ -1,6 +1,96 @@
--- ./libmissing/tests/Makefile.am 2016-09-15 08:49:10.764000884 +0200
+++ ./libmissing/tests/Makefile.am 2017-05-14 12:03:01.912530446 +0200
@@ -689,15 +689,6 @@
--- ./libmissing/tests/Makefile.in 2017-07-17 12:03:50.381000000 +0200
+++ ./libmissing/tests/Makefile.in 2017-09-17 17:27:31.901783351 +0200
@@ -127,7 +127,7 @@
test-isblank$(EXEEXT) test-langinfo$(EXEEXT) \
test-limits-h$(EXEEXT) test-listen$(EXEEXT) \
test-locale$(EXEEXT) test-localeconv$(EXEEXT) \
- test-localename$(EXEEXT) test-lock$(EXEEXT) test-lseek.sh \
+ test-localename$(EXEEXT) test-lseek.sh \
test-lstat$(EXEEXT) test-malloca$(EXEEXT) test-mbrtowc1.sh \
test-mbrtowc2.sh test-mbrtowc3.sh test-mbrtowc4.sh \
test-mbrtowc5.sh test-mbrtowc-w32-1.sh test-mbrtowc-w32-2.sh \
@@ -191,7 +191,7 @@
test-isblank$(EXEEXT) test-langinfo$(EXEEXT) \
test-limits-h$(EXEEXT) test-listen$(EXEEXT) \
test-locale$(EXEEXT) test-localeconv$(EXEEXT) \
- test-localename$(EXEEXT) test-lock$(EXEEXT) \
+ test-localename$(EXEEXT) \
test-lseek$(EXEEXT) test-lstat$(EXEEXT) test-malloca$(EXEEXT) \
test-mbrtowc$(EXEEXT) test-mbrtowc-w32$(EXEEXT) \
test-mbsinit$(EXEEXT) test-memchr$(EXEEXT) \
@@ -736,9 +736,6 @@
test_localename_OBJECTS = test-localename.$(OBJEXT)
test_localename_DEPENDENCIES = $(am__DEPENDENCIES_2) \
$(am__DEPENDENCIES_1)
-test_lock_SOURCES = test-lock.c
-test_lock_OBJECTS = test-lock.$(OBJEXT)
-test_lock_DEPENDENCIES = $(am__DEPENDENCIES_2)
test_lseek_SOURCES = test-lseek.c
test_lseek_OBJECTS = test-lseek.$(OBJEXT)
test_lseek_LDADD = $(LDADD)
@@ -1128,7 +1125,7 @@
test-gettimeofday.c test-ignore-value.c test-inet_ntop.c \
test-inet_pton.c test-intprops.c test-inttypes.c test-ioctl.c \
test-isblank.c test-langinfo.c test-limits-h.c test-listen.c \
- test-locale.c test-localeconv.c test-localename.c test-lock.c \
+ test-locale.c test-localeconv.c test-localename.c \
test-lseek.c test-lstat.c test-malloca.c test-mbrtowc.c \
test-mbrtowc-w32.c test-mbsinit.c test-memchr.c test-memmem.c \
test-netdb.c test-netinet_in.c test-nl_langinfo.c test-open.c \
@@ -1165,7 +1162,7 @@
test-gettimeofday.c test-ignore-value.c test-inet_ntop.c \
test-inet_pton.c test-intprops.c test-inttypes.c test-ioctl.c \
test-isblank.c test-langinfo.c test-limits-h.c test-listen.c \
- test-locale.c test-localeconv.c test-localename.c test-lock.c \
+ test-locale.c test-localeconv.c test-localename.c \
test-lseek.c test-lstat.c test-malloca.c test-mbrtowc.c \
test-mbrtowc-w32.c test-mbsinit.c test-memchr.c test-memmem.c \
test-netdb.c test-netinet_in.c test-nl_langinfo.c test-open.c \
@@ -2550,7 +2547,7 @@
test-isblank.c signature.h macros.h test-langinfo.c \
test-limits-h.c test-listen.c signature.h macros.h \
test-locale.c test-localeconv.c signature.h macros.h \
- localename.h test-localename.c macros.h test-lock.c \
+ localename.h test-localename.c macros.h \
test-lseek.c test-lseek.sh signature.h macros.h lstat.c \
test-lstat.h test-lstat.c signature.h macros.h malloca.h \
malloca.valgrind test-malloca.c test-mbrtowc1.sh \
@@ -2994,10 +2991,6 @@
@rm -f test-localename$(EXEEXT)
$(AM_V_CCLD)$(LINK) $(test_localename_OBJECTS) $(test_localename_LDADD) $(LIBS)
-test-lock$(EXEEXT): $(test_lock_OBJECTS) $(test_lock_DEPENDENCIES) $(EXTRA_test_lock_DEPENDENCIES)
- @rm -f test-lock$(EXEEXT)
- $(AM_V_CCLD)$(LINK) $(test_lock_OBJECTS) $(test_lock_LDADD) $(LIBS)
-
test-lseek$(EXEEXT): $(test_lseek_OBJECTS) $(test_lseek_DEPENDENCIES) $(EXTRA_test_lseek_DEPENDENCIES)
@rm -f test-lseek$(EXEEXT)
$(AM_V_CCLD)$(LINK) $(test_lseek_OBJECTS) $(test_lseek_LDADD) $(LIBS)
@@ -3359,7 +3352,6 @@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test-locale.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test-localeconv.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test-localename.Po@am__quote@
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test-lock.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test-lseek.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test-lstat.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test-malloca.Po@am__quote@
@@ -4154,13 +4146,6 @@
$(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
--log-file $$b.log --trs-file $$b.trs \
$(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
- "$$tst" $(AM_TESTS_FD_REDIRECT)
-test-lock.log: test-lock$(EXEEXT)
- @p='test-lock$(EXEEXT)'; \
- b='test-lock'; \
- $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
- --log-file $$b.log --trs-file $$b.trs \
- $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
"$$tst" $(AM_TESTS_FD_REDIRECT)
test-lseek.sh.log: test-lseek.sh
@p='test-lseek.sh'; \
--- ./libmissing/tests/Makefile.am 2017-07-17 12:03:05.700000000 +0200
+++ ./libmissing/tests/Makefile.am 2017-09-17 17:25:12.229809581 +0200
@@ -721,15 +721,6 @@
## end gnulib module localename-tests
@ -16,86 +106,3 @@
## begin gnulib module lseek-tests
TESTS += test-lseek.sh
--- ./libmissing/tests/Makefile.in 2016-09-15 08:51:18.969000884 +0200
+++ ./libmissing/tests/Makefile.in 2017-05-14 12:04:03.624207164 +0200
@@ -82,7 +82,7 @@
test-inttypes$(EXEEXT) test-ioctl$(EXEEXT) \
test-langinfo$(EXEEXT) test-listen$(EXEEXT) \
test-locale$(EXEEXT) test-localeconv$(EXEEXT) \
- test-localename$(EXEEXT) test-lock$(EXEEXT) test-lseek.sh \
+ test-localename$(EXEEXT) test-lseek.sh \
test-lstat$(EXEEXT) test-malloca$(EXEEXT) test-mbrtowc1.sh \
test-mbrtowc2.sh test-mbrtowc3.sh test-mbrtowc4.sh \
test-mbrtowc5.sh test-mbrtowc-w32-1.sh test-mbrtowc-w32-2.sh \
@@ -145,7 +145,7 @@
test-inttypes$(EXEEXT) test-ioctl$(EXEEXT) \
test-langinfo$(EXEEXT) test-listen$(EXEEXT) \
test-locale$(EXEEXT) test-localeconv$(EXEEXT) \
- test-localename$(EXEEXT) test-lock$(EXEEXT) \
+ test-localename$(EXEEXT) \
test-lseek$(EXEEXT) test-lstat$(EXEEXT) test-malloca$(EXEEXT) \
test-mbrtowc$(EXEEXT) test-mbrtowc-w32$(EXEEXT) \
test-mbsinit$(EXEEXT) test-memchr$(EXEEXT) \
@@ -668,9 +668,6 @@
test_localename_OBJECTS = test-localename.$(OBJEXT)
test_localename_DEPENDENCIES = $(am__DEPENDENCIES_2) \
$(am__DEPENDENCIES_1)
-test_lock_SOURCES = test-lock.c
-test_lock_OBJECTS = test-lock.$(OBJEXT)
-test_lock_DEPENDENCIES = $(am__DEPENDENCIES_2)
test_lseek_SOURCES = test-lseek.c
test_lseek_OBJECTS = test-lseek.$(OBJEXT)
test_lseek_LDADD = $(LDADD)
@@ -1039,7 +1036,7 @@
test-gettimeofday.c test-ignore-value.c test-inet_ntop.c \
test-inet_pton.c test-intprops.c test-inttypes.c test-ioctl.c \
test-langinfo.c test-listen.c test-locale.c test-localeconv.c \
- test-localename.c test-lock.c test-lseek.c test-lstat.c \
+ test-localename.c test-lseek.c test-lstat.c \
test-malloca.c test-mbrtowc.c test-mbrtowc-w32.c \
test-mbsinit.c test-memchr.c test-memmem.c test-netdb.c \
test-netinet_in.c test-nl_langinfo.c test-open.c \
@@ -1076,7 +1073,7 @@
test-gettimeofday.c test-ignore-value.c test-inet_ntop.c \
test-inet_pton.c test-intprops.c test-inttypes.c test-ioctl.c \
test-langinfo.c test-listen.c test-locale.c test-localeconv.c \
- test-localename.c test-lock.c test-lseek.c test-lstat.c \
+ test-localename.c test-lseek.c test-lstat.c \
test-malloca.c test-mbrtowc.c test-mbrtowc-w32.c \
test-mbsinit.c test-memchr.c test-memmem.c test-netdb.c \
test-netinet_in.c test-nl_langinfo.c test-open.c \
@@ -2222,7 +2219,7 @@
inttypes.in.h test-inttypes.c test-ioctl.c signature.h \
macros.h test-langinfo.c test-listen.c signature.h macros.h \
test-locale.c test-localeconv.c signature.h macros.h \
- localename.h test-localename.c macros.h test-lock.c \
+ localename.h test-localename.c macros.h \
test-lseek.c test-lseek.sh signature.h macros.h lstat.c \
test-lstat.h test-lstat.c signature.h macros.h malloca.h \
malloca.valgrind test-malloca.c test-mbrtowc1.sh \
@@ -2333,7 +2330,6 @@
test_inet_pton_LDADD = $(LDADD) @INET_PTON_LIB@
test_listen_LDADD = $(LDADD) @LIBSOCKET@
test_localename_LDADD = $(LDADD) @INTL_MACOSX_LIBS@ $(LIBTHREAD)
-test_lock_LDADD = $(LDADD) @LIBMULTITHREAD@ @YIELD_LIB@
test_poll_LDADD = $(LDADD) $(LIB_POLL) @LIBSOCKET@ $(INET_PTON_LIB)
test_regex_LDADD = $(LDADD) @LIBINTL@ $(LIBTHREAD) $(LIB_PTHREAD)
test_select_LDADD = $(LDADD) @LIB_SELECT@ @LIBSOCKET@ $(INET_PTON_LIB)
@@ -2595,9 +2591,6 @@
test-localename$(EXEEXT): $(test_localename_OBJECTS) $(test_localename_DEPENDENCIES)
@rm -f test-localename$(EXEEXT)
$(LINK) $(test_localename_OBJECTS) $(test_localename_LDADD) $(LIBS)
-test-lock$(EXEEXT): $(test_lock_OBJECTS) $(test_lock_DEPENDENCIES)
- @rm -f test-lock$(EXEEXT)
- $(LINK) $(test_lock_OBJECTS) $(test_lock_LDADD) $(LIBS)
test-lseek$(EXEEXT): $(test_lseek_OBJECTS) $(test_lseek_DEPENDENCIES)
@rm -f test-lseek$(EXEEXT)
$(LINK) $(test_lseek_OBJECTS) $(test_lseek_LDADD) $(LIBS)
@@ -2888,7 +2881,6 @@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test-locale.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test-localeconv.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test-localename.Po@am__quote@
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test-lock.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test-lseek.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test-lstat.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test-malloca.Po@am__quote@

View File

@ -3,40 +3,37 @@
# Notes about rpmlint
# - crypto-policy-non-compliance-gnutls-{1,2} fixed with patch
# libprelude-3.1.0-gnutls_priority_set_direct.patch
# libprelude-4.0.0-gnutls_priority_set_direct.patch
Name: libprelude
Version: 3.1.0
Release: 34%{?dist}
Version: 4.0.0
Release: 1%{?dist}
Summary: Secure Connections between all Sensors and the Prelude Manager
# Prelude is GPL-2.0+
# libmissing is LGPL-2.1+
License: GPLv2+
Group: System Environment/Libraries
URL: https://www.prelude-siem.org/
Source0: https://www.prelude-siem.org/pkg/src/3.1.0/%{name}-%{version}.tar.gz
Source0: https://www.prelude-siem.org/pkg/src/%{version}/%{name}-%{version}.tar.gz
# https://www.prelude-siem.org/issues/859
Patch0: libprelude-3.1.0-linking.patch
Patch0: libprelude-4.0.0-linking.patch
# https://www.prelude-siem.org/issues/860
Patch1: libprelude-3.1.0-ruby_vendorarchdir.patch
Patch1: libprelude-4.0.0-ruby_vendorarchdir.patch
# https://www.prelude-siem.org/issues/862
Patch2: libprelude-3.1.0-gnutls_priority_set_direct.patch
Patch2: libprelude-4.0.0-gnutls_priority_set_direct.patch
# https://www.prelude-siem.org/issues/863
Patch3: libprelude-3.1.0-fsf_address.patch
Patch3: libprelude-4.0.0-fsf_address.patch
# https://www.prelude-siem.org/issues/865
Patch4: libprelude-3.1.0-fix_timegm.patch
Patch4: libprelude-4.0.0-fix_timegm.patch
# https://www.prelude-siem.org/issues/885
Patch5: libprelude-3.1.0-fix_pthread_atfork.patch
Patch5: libprelude-4.0.0-fix_pthread_atfork.patch
# https://www.prelude-siem.org/issues/887
Patch6: libprelude-3.1.0-fix_prelude_tests_timer.patch
# https://www.prelude-siem.org/issues/886
Patch7: libprelude-3.1.0-disable_gnulib_test_lock.patch
Patch6: libprelude-4.0.0-fix_prelude_tests_timer.patch
BuildRequires: bison
BuildRequires: chrpath
BuildRequires: flex
BuildRequires: gtk-doc
BuildRequires: swig
BuildRequires: libgcrypt-devel
BuildRequires: libgpg-error-devel
BuildRequires: libtool-ltdl-devel
BuildRequires: perl-devel
@ -53,9 +50,9 @@ BuildRequires: valgrind
%endif
# Upstream do not use explicit version of gnulib, just checkout
# and update files. In libprelude 3.1.0, the checkout has been done
# on 2016-06-16
Provides: bundled(gnulib) = 20160616
# and update files. In libprelude 4.0.0, the checkout has been done
# on 2017-01-04
Provides: bundled(gnulib) = 20170104
%description
Libprelude is a collection of generic functions providing communication
@ -172,7 +169,7 @@ find %{buildroot} -name 'perllocal.pod' -delete
find %{buildroot} -name '.packlist' -delete
%check
make distcheck
make check
%post -n %{name} -p /sbin/ldconfig
%postun -n %{name} -p /sbin/ldconfig
@ -239,6 +236,9 @@ make distcheck
%doc AUTHORS ChangeLog README NEWS
%changelog
* Sat Sep 16 2017 Thomas Andrejak <thomas.andrejak@gmail.com> - 4.0.0-1
- Bump version 4.0.0
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.0-34
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild

View File

@ -1 +1 @@
2e1a5d7cbf98a2d57fbb367a578dbf8c libprelude-3.1.0.tar.gz
SHA512 (libprelude-4.0.0.tar.gz) = 5d88e8f211b09cc3e43dbe299e935d8f11575ae3f1894059793966cd14a8e47177ef8963d45305e1a24f9efc4048520329b31681301a21815909bd38606c2ce7