Florian Weimer 2022-11-25 09:48:56 +01:00
parent 844835bb0d
commit 31ab3c50c9
2 changed files with 87 additions and 1 deletions

View File

@ -0,0 +1,82 @@
Add missing include files to avoid implicit function declarations.
diff --git a/configure b/configure
index 3dd46a982bc30af1..0fd5bd685c32f3cd 100755
--- a/configure
+++ b/configure
@@ -22292,6 +22292,7 @@ else
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
#include <stdarg.h>
+ #include <stdlib.h>
void f (int i, ...) {
va_list args1, args2;
va_start (args1, i);
@@ -22325,6 +22326,7 @@ else
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
#include <stdarg.h>
+ #include <stdlib.h>
void f (int i, ...) {
va_list args1, args2;
va_start (args1, i);
@@ -22377,6 +22379,7 @@ else
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
#include <stdarg.h>
+ #include <stdlib.h>
void f (int i, ...) {
va_list args1, args2;
va_start (args1, i);
@@ -48608,6 +48611,9 @@ else
#if HAVE_LANGINFO_CODESET
# include <langinfo.h>
#endif
+#if HAVE_WCTYPE_H
+# include <wctype.h>
+#endif
#include <stdlib.h>
#include <string.h>
struct tm t;
diff --git a/configure.ac b/configure.ac
index eb506e7d2af0afee..e268386180b5e524 100644
--- a/configure.ac
+++ b/configure.ac
@@ -344,6 +344,7 @@ dnl all results in config.log for bug reports.
AC_CACHE_CHECK([for an implementation of va_copy()],prelude_cv_va_copy,[
AC_LINK_IFELSE([AC_LANG_SOURCE([#include <stdarg.h>
+ #include <stdlib.h>
void f (int i, ...) {
va_list args1, args2;
va_start (args1, i);
@@ -361,6 +362,7 @@ AC_CACHE_CHECK([for an implementation of va_copy()],prelude_cv_va_copy,[
])
AC_CACHE_CHECK([for an implementation of __va_copy()],prelude_cv___va_copy,[
AC_LINK_IFELSE([AC_LANG_SOURCE([#include <stdarg.h>
+ #include <stdlib.h>
void f (int i, ...) {
va_list args1, args2;
va_start (args1, i);
@@ -390,6 +392,7 @@ fi
AC_CACHE_CHECK([whether va_lists can be copied by value],prelude_cv_va_val_copy,[
AC_TRY_RUN([#include <stdarg.h>
+ #include <stdlib.h>
void f (int i, ...) {
va_list args1, args2;
va_start (args1, i);
diff --git a/libmissing/m4/locale-tr.m4 b/libmissing/m4/locale-tr.m4
index 2f2cf47892d505a5..c2683e53b8574f6d 100644
--- a/libmissing/m4/locale-tr.m4
+++ b/libmissing/m4/locale-tr.m4
@@ -19,6 +19,9 @@ changequote(,)dnl
#if HAVE_LANGINFO_CODESET
# include <langinfo.h>
#endif
+#if HAVE_WCTYPE_H
+# include <wctype.h>
+#endif
#include <stdlib.h>
#include <string.h>
struct tm t;

View File

@ -7,7 +7,7 @@
Name: libprelude
Version: 5.2.0
Release: 14%{?dist}
Release: 15%{?dist}
Summary: Secure Connections between all Sensors and the Prelude Manager
License: LGPL-2.1+
URL: https://www.prelude-siem.org/
@ -39,6 +39,7 @@ Patch11: libprelude-5.2.0-ruby27.patch
Patch12: libprelude-5.2.0-clean_libprelude-config.patch
# #1973946
Patch13: libprelude-5.2.0-fix-PyIOBase_Type.patch
Patch14: libprelude-configure-c99.patch
BuildRequires: make
BuildRequires: gcc
BuildRequires: gcc-c++
@ -241,6 +242,9 @@ patch -d %{buildroot}%{_includedir}/libprelude/ -p0 < %SOURCE1
%doc AUTHORS ChangeLog README NEWS
%changelog
* Fri Nov 25 2022 Florian Weimer <fweimer@redhat.com> - 5.2.0-15
- Port configure script to C99 (#2148366)
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild