Bump version 5.2.0

This commit is contained in:
Thomas Andrejak 2020-09-17 23:09:58 +02:00
parent d2e9c86625
commit 04cbec5685
17 changed files with 23 additions and 149 deletions

4
.gitignore vendored
View File

@ -1,3 +1 @@
/libprelude-4.1.0.tar.gz
/libprelude-5.0.0.tar.gz
/libprelude-5.1.1.tar.gz
/libprelude-5.2.0.tar.gz

View File

@ -1,112 +0,0 @@
--- ./src/libprelude-error/Makefile.am 2018-12-23 21:59:17.340000000 +0100
+++ ./src/libprelude-error/Makefile.am 2019-07-11 17:33:18.537430699 +0200
@@ -53,7 +53,7 @@
errnos-sym.h: Makefile mkstrtable.awk errnos.in
LANG="" $(AWK) -f $(srcdir)/mkstrtable.awk -v textidx=2 -v nogettext=1 \
- -v prefix=PRELUDE_ERROR_ -v namespace=errnos_ \
+ -v prefix=PRELUDE_ERROR_ -v pkg_namespace=errnos_ \
$(srcdir)/errnos.in >$@
prelude-error.h: Makefile mkheader.awk err-sources.h.in err-codes.h.in errnos.in prelude-error.h.in
--- ./src/libprelude-error/Makefile.in 2018-12-23 22:01:05.090000000 +0100
+++ ./src/libprelude-error/Makefile.in 2019-07-11 17:33:10.202599542 +0200
@@ -1834,7 +1834,7 @@
errnos-sym.h: Makefile mkstrtable.awk errnos.in
LANG="" $(AWK) -f $(srcdir)/mkstrtable.awk -v textidx=2 -v nogettext=1 \
- -v prefix=PRELUDE_ERROR_ -v namespace=errnos_ \
+ -v prefix=PRELUDE_ERROR_ -v pkg_namespace=errnos_ \
$(srcdir)/errnos.in >$@
prelude-error.h: Makefile mkheader.awk err-sources.h.in err-codes.h.in errnos.in prelude-error.h.in
--- ./src/libprelude-error/mkerrcodes.awk 2018-12-23 21:59:17.340000000 +0100
+++ ./src/libprelude-error/mkerrcodes.awk 2019-07-11 17:34:56.482462208 +0200
@@ -78,7 +78,7 @@
}
!header {
- sub (/\#.+/, "");
+ sub (/#.+/, "");
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
if (/^$/)
--- ./src/libprelude-error/mkerrcodes1.awk 2018-12-23 21:59:17.341000000 +0100
+++ ./src/libprelude-error/mkerrcodes1.awk 2019-07-11 17:35:02.737336699 +0200
@@ -78,7 +78,7 @@
}
!header {
- sub (/\#.+/, "");
+ sub (/#.+/, "");
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
if (/^$/)
--- ./src/libprelude-error/mkerrcodes2.awk 2018-12-23 21:59:17.341000000 +0100
+++ ./src/libprelude-error/mkerrcodes2.awk 2019-07-11 17:35:08.595219159 +0200
@@ -91,7 +91,7 @@
}
!header {
- sub (/\#.+/, "");
+ sub (/#.+/, "");
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
if (/^$/)
--- ./src/libprelude-error/mkerrnos.awk 2019-07-11 17:41:09.385940916 +0200
+++ ./src/libprelude-error/mkerrnos.awk 2019-07-11 17:41:22.455671539 +0200
@@ -80,7 +80,7 @@
}
!header {
- sub (/\#.+/, "");
+ sub (/#.+/, "");
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
if (/^$/)
--- ./src/libprelude-error/mkstrtable.awk 2018-12-23 21:59:17.341000000 +0100
+++ ./src/libprelude-error/mkstrtable.awk 2019-07-11 17:38:41.588950860 +0200
@@ -77,7 +77,7 @@
#
# The variable prefix can be used to prepend a string to each message.
#
-# The variable namespace can be used to prepend a string to each
+# The variable pkg_namespace can be used to prepend a string to each
# variable and macro name.
BEGIN {
@@ -102,7 +102,7 @@
print "/* The purpose of this complex string table is to produce";
print " optimal code with a minimum of relocations. */";
print "";
- print "static const char " namespace "msgstr[] = ";
+ print "static const char " pkg_namespace "msgstr[] = ";
header = 0;
}
else
@@ -110,7 +110,7 @@
}
!header {
- sub (/\#.+/, "");
+ sub (/#.+/, "");
sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
if (/^$/)
@@ -150,14 +150,14 @@
else
print " gettext_noop (\"" prefix last_msgstr "\");";
print "";
- print "static const int " namespace "msgidx[] =";
+ print "static const int " pkg_namespace "msgidx[] =";
print " {";
for (i = 0; i < coded_msgs; i++)
print " " pos[i] ",";
print " " pos[coded_msgs];
print " };";
print "";
- print "#define " namespace "msgidxof(code) (0 ? -1 \\";
+ print "#define " pkg_namespace "msgidxof(code) (0 ? -1 \\";
# Gather the ranges.
skip = code[0];

View File

@ -1,11 +0,0 @@
--- ./bindings/python/_prelude.cxx 2019-07-12 07:19:49.365476420 +0200
+++ ./bindings/python/_prelude.cxx 2019-07-12 07:20:02.458213034 +0200
@@ -3132,7 +3132,7 @@
SWIGINTERN void
SwigPyStaticVar_dealloc(PyDescrObject *descr) {
- _PyObject_GC_UNTRACK(descr);
+ PyObject_GC_UnTrack(descr);
Py_XDECREF(PyDescr_TYPE(descr));
Py_XDECREF(PyDescr_NAME(descr));
PyObject_GC_Del(descr);

View File

@ -3,40 +3,36 @@
# Notes about rpmlint
# - crypto-policy-non-compliance-gnutls-{1,2} fixed with patch
# libprelude-5.1.0-gnutls_priority_set_direct.patch
# libprelude-5.2.0-gnutls_priority_set_direct.patch
Name: libprelude
Version: 5.1.1
Release: 7%{?dist}
Version: 5.2.0
Release: 0%{?dist}
Summary: Secure Connections between all Sensors and the Prelude Manager
# Prelude is GPL-2.0+
# libmissing is LGPL-2.1+
License: GPLv2+
License: LGPL-2.1+
URL: https://www.prelude-siem.org/
Source0: https://www.prelude-siem.org/pkg/src/5.1.0/%{name}-%{version}.tar.gz
Source0: https://www.prelude-siem.org/pkg/src/5.2.0/%{name}-%{version}.tar.gz
# https://www.prelude-siem.org/issues/860
Patch0: libprelude-5.1.0-ruby_vendorarchdir.patch
Patch0: libprelude-5.2.0-ruby_vendorarchdir.patch
# https://www.prelude-siem.org/issues/862
Patch1: libprelude-5.1.0-gnutls_priority_set_direct.patch
Patch1: libprelude-5.2.0-gnutls_priority_set_direct.patch
# https://www.prelude-siem.org/issues/863
Patch2: libprelude-5.1.0-fsf_address.patch
Patch2: libprelude-5.2.0-fsf_address.patch
# https://www.prelude-siem.org/issues/865
Patch3: libprelude-5.1.0-fix_timegm.patch
Patch3: libprelude-5.2.0-fix_timegm.patch
# https://www.prelude-siem.org/issues/885
Patch4: libprelude-5.1.0-fix_pthread_atfork.patch
Patch4: libprelude-5.2.0-fix_pthread_atfork.patch
# https://www.prelude-siem.org/issues/887
Patch5: libprelude-5.1.0-fix_prelude_tests_timer.patch
Patch6: libprelude-5.1.0-fix_awk_error.patch
Patch7: libprelude-5.1.0-fix_py38.patch
Patch8: libprelude-5.1.0-fix_gtkdoc_1.32.patch
Patch9: libprelude-5.1.0-linking.patch
Patch10: libprelude-5.1.0-fix_libprelude-error_on_gnu.patch
Patch11: libprelude-5.1.0-disable_test-poll_on_kfreebsd.patch
Patch12: libprelude-5.1.0-fix-test_rwlock1.patch
Patch5: libprelude-5.2.0-fix_prelude_tests_timer.patch
Patch6: libprelude-5.2.0-fix_gtkdoc_1.32.patch
Patch7: libprelude-5.2.0-linking.patch
Patch8: libprelude-5.2.0-fix_libprelude-error_on_gnu.patch
Patch9: libprelude-5.2.0-disable_test-poll_on_kfreebsd.patch
Patch10: libprelude-5.2.0-fix-test_rwlock1.patch
# https://github.com/swig/swig/issues/1689
# https://github.com/swig/swig/pull/1692
# For now, add a minimum patch to support ruby2.7
Patch13: libprelude-5.1.1-ruby27.patch
Patch11: libprelude-5.2.0-ruby27.patch
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: bison
@ -60,7 +56,7 @@ BuildRequires: valgrind
%endif
# Upstream do not use explicit version of gnulib, just checkout
# and update files. In libprelude 5.1.1, the checkout has been done
# and update files. In libprelude 5.2.0, the checkout has been done
# on 2018-09-03
Provides: bundled(gnulib) = 20180903
@ -233,6 +229,9 @@ find %{buildroot} -name '.packlist' -delete
%doc AUTHORS ChangeLog README NEWS
%changelog
* Thu Sep 18 2020 Thomas Andrejak <thomas.andrejak@gmail.com> - 5.2.0-1
- Bump version 5.2.0
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.1.1-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (libprelude-5.1.1.tar.gz) = eddd6e1cf4fc4b2fa79a5132316576cc7205915fa19bf3a2a68cbc4eaf5abf50e5c594384aa1742d620304916da634e113a7c33e4ebca2bcee96e35c9796ed5f
SHA512 (libprelude-5.2.0.tar.gz) = e0dc0d7c06a4c250a5a12c5cddd8aa8db33d94f8afd85b1afdb264717d674e0dc0b4dc8a5336860df74ffe408023cc7a5356e3acc3c96876099659e33ce04dd0