Rebase to PostgreSQL 12beta2 release.

This commit is contained in:
Patrik Novotný 2019-07-18 15:19:30 +02:00
parent 1674298550
commit b39f323932
3 changed files with 18 additions and 17 deletions

View File

@ -1,7 +1,3 @@
The libpq package is supposed to be used for all the PostgreSQL modules
available in RHEL 8, and ABI versioning will guarantee us that modular RPMs will
depend on appropriate libpq ABI version (picked at build-time).
diff --git a/config/Makefile b/config/Makefile
index 67e7998f55..86612a42c3 100644
--- a/config/Makefile
@ -16,7 +12,7 @@ index 67e7998f55..86612a42c3 100644
$(MKDIR_P) '$(DESTDIR)$(pgxsdir)/config'
diff --git a/config/build-exports-gnu-ld b/config/build-exports-gnu-ld
new file mode 100755
index 0000000000..bdcfb40d48
index 0000000000..84c48e3ade
--- /dev/null
+++ b/config/build-exports-gnu-ld
@@ -0,0 +1,41 @@
@ -62,10 +58,10 @@ index 0000000000..bdcfb40d48
+echo " *;"
+close_block
diff --git a/src/Makefile.shlib b/src/Makefile.shlib
index 95b82a6dea..a7065d02a4 100644
index 373d73caef..d5bd5468cd 100644
--- a/src/Makefile.shlib
+++ b/src/Makefile.shlib
@@ -221,7 +221,7 @@ ifeq ($(PORTNAME), linux)
@@ -231,7 +231,7 @@ ifeq ($(PORTNAME), linux)
ifdef soname
LINK.shared += -Wl,-soname,$(soname)
endif
@ -75,15 +71,15 @@ index 95b82a6dea..a7065d02a4 100644
ifneq (,$(exports_file))
LINK.shared += -Wl,--version-script=$(exports_file)
diff --git a/src/interfaces/libpq/exports.txt b/src/interfaces/libpq/exports.txt
index d6a38d0df8..29bebeac7e 100644
index 7c808e5215..3631340b23 100644
--- a/src/interfaces/libpq/exports.txt
+++ b/src/interfaces/libpq/exports.txt
@@ -171,4 +171,4 @@ PQsslAttributeNames 168
@@ -171,7 +171,7 @@ PQsslAttributeNames 168
PQsslAttribute 169
PQsetErrorContextVisibility 170
PQresultVerboseErrorMessage 171
-PQencryptPasswordConn 172
+PQencryptPasswordConn 172 10
--
2.17.0
PQresultMemorySize 173
PQhostaddr 174
PQgssEncInUse 175

View File

@ -1,10 +1,10 @@
%global majorversion 11
%global majorversion 12
%global obsoletes_version %( echo $(( %majorversion + 1 )) )
Summary: PostgreSQL client library
Name: libpq
Version: %majorversion.3
Release: 2%{?dist}
Version: %{majorversion}beta2
Release: 1%{?dist}
License: PostgreSQL
Url: http://www.postgresql.org/
@ -78,6 +78,8 @@ export SYMBOL_VERSION_PREFIX=RHPG_
--datadir=%_datadir/pgsql
%global build_subdirs \\\
src/common \\\
src/port \\\
src/interfaces/libpq \\\
src/bin/pg_config \\\
src/include
@ -128,6 +130,9 @@ find_lang_bins %name-devel.lst pg_config
%changelog
* Wed Jul 03 2019 Patrik Novotný <panovotn@redhat.com> - 12beta2-1
- Rebase to upstream release 12beta2-1
* Fri May 10 2019 Pavel Raiskup <praiskup@redhat.com> - 11.3-2
- obsolete anything < %%majorversion+1

View File

@ -1,2 +1,2 @@
SHA512 (postgresql-11.3.tar.bz2) = 03269bb88f44f3a81d5e3a8ca2fe59f63f784436840f08870b2e539755629cbde8ac288e0bb4472ee93294a88b37b814ddff48444254c1a3f7a10b4bb64f7133
SHA512 (postgresql-11.3.tar.bz2.sha256) = ac1cd1e2c39c11fb48b2326c804f681fafad32bfa81e4954766916ce3879df8a792b2ff6067c11215b4b00b8ea176ead13a2be50e0ae6f8e11bda1ff7d264c07
SHA512 (postgresql-12beta2.tar.bz2) = 64b3ffd7e61ece5572ca72b3168618150214f89d21b113c6f630687372f6f7212bdfa086fa5b22e466a529a0e929c76d34e5b3ed5c04c94299589822fbff4935
SHA512 (postgresql-12beta2.tar.bz2.sha256) = 97ed725bf0529c1bfbf4840b0498c63e10eddfc77d5c5a071bc05685c809f535ef310ad0ee6949042f59feb3e01a3fd6f1cc672e4b08078eae37ceb1d3df3cfb