1.7.3 GA
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
parent
d823dba59c
commit
4ea7352d6a
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
/orc-1.6.6.tar.gz
|
||||
/orc-1.7.3.tar.gz
|
||||
|
336
0001-cmake.patch
336
0001-cmake.patch
@ -2,9 +2,8 @@
|
||||
+++ orc-rel-release-1.6.6/c++/src/orcConfig.cmake 2021-09-02 08:11:53.797563660 -0400
|
||||
@@ -0,0 +1 @@
|
||||
+include("${CMAKE_CURRENT_LIST_DIR}/orcTargets.cmake")
|
||||
--- orc-rel-release-1.6.6/c++/src/CMakeLists.txt.orig 2020-12-03 15:46:53.000000000 -0500
|
||||
+++ orc-rel-release-1.6.6/c++/src/CMakeLists.txt 2021-09-15 14:47:07.195633659 -0400
|
||||
@@ -227,7 +227,13 @@
|
||||
+++ orc-1.7.3/c++/src/CMakeLists.txt 2022-02-10 14:55:16.260729962 -0500
|
||||
@@ -236,15 +236,54 @@
|
||||
add_definitions(-DBUILD_LIBHDFSPP)
|
||||
endif(BUILD_LIBHDFSPP)
|
||||
|
||||
@ -18,8 +17,16 @@
|
||||
+)
|
||||
|
||||
target_link_libraries (orc
|
||||
protobuf
|
||||
@@ -238,4 +244,38 @@
|
||||
- orc::protobuf
|
||||
- orc::zlib
|
||||
- orc::snappy
|
||||
- orc::lz4
|
||||
- orc::zstd
|
||||
+ protobuf
|
||||
+ z
|
||||
+ snappy
|
||||
+ lz4
|
||||
+ zstd
|
||||
${LIBHDFSPP_LIBRARIES}
|
||||
)
|
||||
|
||||
@ -58,294 +65,37 @@
|
||||
+ DESTINATION ${ConfigPackageLocation}
|
||||
+ )
|
||||
+
|
||||
+
|
||||
--- orc-rel-release-1.6.6/cmake_modules/ThirdpartyToolchain.cmake.orig 2020-12-03 15:46:53.000000000 -0500
|
||||
+++ orc-rel-release-1.6.6/cmake_modules/ThirdpartyToolchain.cmake 2021-09-15 14:21:07.299584448 -0400
|
||||
@@ -79,8 +79,8 @@
|
||||
endif ()
|
||||
--- orc-1.7.3/cmake_modules/ThirdpartyToolchain.cmake.orig 2022-02-10 14:22:42.421782851 -0500
|
||||
+++ orc-1.7.3/cmake_modules/ThirdpartyToolchain.cmake 2022-02-10 15:31:26.865802496 -0500
|
||||
@@ -10,19 +10,19 @@
|
||||
# See the License for the specific language governing permissions and
|
||||
# limitations under the License.
|
||||
|
||||
include_directories (SYSTEM ${SNAPPY_INCLUDE_DIR})
|
||||
-add_library (snappy STATIC IMPORTED)
|
||||
-set_target_properties (snappy PROPERTIES IMPORTED_LOCATION ${SNAPPY_STATIC_LIB})
|
||||
+add_library (snappy SHARED IMPORTED)
|
||||
+set_target_properties (snappy PROPERTIES IMPORTED_LOCATION ${SNAPPY_SHARED_LIB})
|
||||
-set(LZ4_VERSION "1.9.3")
|
||||
-set(SNAPPY_VERSION "1.1.7")
|
||||
-set(ZLIB_VERSION "1.2.11")
|
||||
-set(GTEST_VERSION "1.8.0")
|
||||
-set(PROTOBUF_VERSION "3.5.1")
|
||||
-set(ZSTD_VERSION "1.5.2")
|
||||
+#set(LZ4_VERSION "1.9.3")
|
||||
+#set(SNAPPY_VERSION "1.1.7")
|
||||
+#set(ZLIB_VERSION "1.2.11")
|
||||
+#set(GTEST_VERSION "1.8.0")
|
||||
+#set(PROTOBUF_VERSION "3.5.1")
|
||||
+#set(ZSTD_VERSION "1.5.2")
|
||||
|
||||
if (SNAPPY_VENDORED)
|
||||
add_dependencies (snappy snappy_ep)
|
||||
@@ -121,8 +121,8 @@
|
||||
endif ()
|
||||
-option(ORC_PREFER_STATIC_PROTOBUF "Prefer static protobuf library, if available" ON)
|
||||
-option(ORC_PREFER_STATIC_SNAPPY "Prefer static snappy library, if available" ON)
|
||||
-option(ORC_PREFER_STATIC_LZ4 "Prefer static lz4 library, if available" ON)
|
||||
-option(ORC_PREFER_STATIC_ZSTD "Prefer static zstd library, if available" ON)
|
||||
-option(ORC_PREFER_STATIC_ZLIB "Prefer static zlib library, if available" ON)
|
||||
-option(ORC_PREFER_STATIC_GMOCK "Prefer static gmock library, if available" ON)
|
||||
+option(ORC_PREFER_STATIC_PROTOBUF "Prefer static protobuf library, if available" OFF)
|
||||
+option(ORC_PREFER_STATIC_SNAPPY "Prefer static snappy library, if available" OFF)
|
||||
+option(ORC_PREFER_STATIC_LZ4 "Prefer static lz4 library, if available" OFF)
|
||||
+option(ORC_PREFER_STATIC_ZSTD "Prefer static zstd library, if available" OFF)
|
||||
+option(ORC_PREFER_STATIC_ZLIB "Prefer static zlib library, if available" OFF)
|
||||
+option(ORC_PREFER_STATIC_GMOCK "Prefer static gmock library, if available" OFF)
|
||||
|
||||
include_directories (SYSTEM ${ZLIB_INCLUDE_DIR})
|
||||
-add_library (zlib STATIC IMPORTED)
|
||||
-set_target_properties (zlib PROPERTIES IMPORTED_LOCATION ${ZLIB_STATIC_LIB})
|
||||
+add_library (zlib SHARED IMPORTED)
|
||||
+set_target_properties (zlib PROPERTIES IMPORTED_LOCATION ${ZLIB_SHARED_LIB})
|
||||
|
||||
if (ZLIB_VENDORED)
|
||||
add_dependencies (zlib zlib_ep)
|
||||
@@ -170,8 +170,8 @@
|
||||
endif ()
|
||||
|
||||
include_directories (SYSTEM ${ZSTD_INCLUDE_DIR})
|
||||
-add_library (zstd STATIC IMPORTED)
|
||||
-set_target_properties (zstd PROPERTIES IMPORTED_LOCATION ${ZSTD_STATIC_LIB})
|
||||
+add_library (zstd SHARED IMPORTED)
|
||||
+set_target_properties (zstd PROPERTIES IMPORTED_LOCATION ${ZSTD_SHARED_LIB})
|
||||
|
||||
if (ZSTD_VENDORED)
|
||||
add_dependencies (zstd zstd_ep)
|
||||
@@ -212,8 +212,8 @@
|
||||
endif ()
|
||||
|
||||
include_directories (SYSTEM ${LZ4_INCLUDE_DIR})
|
||||
-add_library (lz4 STATIC IMPORTED)
|
||||
-set_target_properties (lz4 PROPERTIES IMPORTED_LOCATION ${LZ4_STATIC_LIB})
|
||||
+add_library (lz4 SHARED IMPORTED)
|
||||
+set_target_properties (lz4 PROPERTIES IMPORTED_LOCATION ${LZ4_SHARED_LIB})
|
||||
|
||||
if (LZ4_VENDORED)
|
||||
add_dependencies (lz4 lz4_ep)
|
||||
@@ -327,11 +327,11 @@
|
||||
|
||||
include_directories (SYSTEM ${PROTOBUF_INCLUDE_DIR})
|
||||
|
||||
-add_library (protobuf STATIC IMPORTED)
|
||||
-set_target_properties (protobuf PROPERTIES IMPORTED_LOCATION ${PROTOBUF_STATIC_LIB})
|
||||
+add_library (protobuf SHARED IMPORTED)
|
||||
+set_target_properties (protobuf PROPERTIES IMPORTED_LOCATION ${PROTOBUF_SHARED_LIB})
|
||||
|
||||
-add_library (protoc STATIC IMPORTED)
|
||||
-set_target_properties (protoc PROPERTIES IMPORTED_LOCATION ${PROTOC_STATIC_LIB})
|
||||
+add_library (protoc SHARED IMPORTED)
|
||||
+set_target_properties (protoc PROPERTIES IMPORTED_LOCATION ${PROTOC_SHARED_LIB})
|
||||
|
||||
if (PROTOBUF_VENDORED)
|
||||
add_dependencies (protoc protobuf_ep)
|
||||
--- orc-rel-release-1.6.6/cmake_modules/FindZSTD.cmake.orig 2020-12-03 15:46:53.000000000 -0500
|
||||
+++ orc-rel-release-1.6.6/cmake_modules/FindZSTD.cmake 2021-09-15 14:10:51.272792107 -0400
|
||||
@@ -14,7 +14,7 @@
|
||||
|
||||
# ZSTD_INCLUDE_DIR: directory containing headers
|
||||
# ZSTD_LIBS: directory containing zstd libraries
|
||||
-# ZSTD_STATIC_LIB: path to libzstd.a
|
||||
+# ZSTD_SHARED_LIB: path to libzstd.a
|
||||
# ZSTD_FOUND: whether zstd has been found
|
||||
|
||||
if( NOT "${ZSTD_HOME}" STREQUAL "")
|
||||
@@ -23,16 +23,16 @@
|
||||
|
||||
message (STATUS "ZSTD_HOME: ${ZSTD_HOME}")
|
||||
|
||||
-if (NOT ZSTD_STATIC_LIB_NAME)
|
||||
- set (ZSTD_STATIC_LIB_NAME ${CMAKE_STATIC_LIBRARY_PREFIX}zstd)
|
||||
-endif()
|
||||
-
|
||||
find_path (ZSTD_INCLUDE_DIR zstd.h HINTS
|
||||
${_zstd_path}
|
||||
NO_DEFAULT_PATH
|
||||
PATH_SUFFIXES "include")
|
||||
|
||||
-find_library (ZSTD_LIBRARIES NAMES ${ZSTD_STATIC_LIB_NAME} HINTS
|
||||
+if (NOT ZSTD_SHARED_LIB_NAME)
|
||||
+ set (ZSTD_SHARED_LIB_NAME zstd)
|
||||
+endif()
|
||||
+
|
||||
+find_library (ZSTD_LIBRARIES NAMES ${ZSTD_SHARED_LIB_NAME} HINTS
|
||||
${_zstd_path}
|
||||
PATH_SUFFIXES "lib")
|
||||
|
||||
@@ -41,14 +41,14 @@
|
||||
get_filename_component (ZSTD_LIBS ${ZSTD_LIBRARIES} PATH)
|
||||
set (ZSTD_HEADER_NAME zstd.h)
|
||||
set (ZSTD_HEADER ${ZSTD_INCLUDE_DIR}/${ZSTD_HEADER_NAME})
|
||||
- set (ZSTD_STATIC_LIB ${ZSTD_LIBS}/${ZSTD_STATIC_LIB_NAME}${CMAKE_STATIC_LIBRARY_SUFFIX})
|
||||
+ set (ZSTD_SHARED_LIB ${ZSTD_LIBS}/${CMAKE_SHARED_LIBRARY_PREFIX}${ZSTD_SHARED_LIB_NAME}${CMAKE_SHARED_LIBRARY_SUFFIX})
|
||||
else ()
|
||||
set (ZSTD_FOUND FALSE)
|
||||
endif ()
|
||||
|
||||
if (ZSTD_FOUND)
|
||||
message (STATUS "Found the zstd header: ${ZSTD_HEADER}")
|
||||
- message (STATUS "Found the zstd library: ${ZSTD_STATIC_LIB}")
|
||||
+ message (STATUS "Found the zstd library: ${ZSTD_SHARED_LIB}")
|
||||
else()
|
||||
if (_ZSTD_path)
|
||||
set (ZSTD_ERR_MSG "Could not find zstd. Looked in ${_zstd_path}.")
|
||||
@@ -65,7 +65,7 @@
|
||||
|
||||
mark_as_advanced (
|
||||
ZSTD_INCLUDE_DIR
|
||||
- ZSTD_STATIC_LIB
|
||||
+ ZSTD_SHARED_LIB
|
||||
ZSTD_LIBS
|
||||
ZSTD_LIBRARIES
|
||||
)
|
||||
--- orc-rel-release-1.6.6/cmake_modules/FindSnappy.cmake.orig 2020-12-03 15:46:53.000000000 -0500
|
||||
+++ orc-rel-release-1.6.6/cmake_modules/FindSnappy.cmake 2021-09-15 13:50:06.714446184 -0400
|
||||
@@ -14,7 +14,7 @@
|
||||
|
||||
# SNAPPY_INCLUDE_DIR: directory containing headers
|
||||
# SNAPPY_LIBS: directory containing snappy libraries
|
||||
-# SNAPPY_STATIC_LIB: path to libsnappy.a
|
||||
+# SNAPPY_SHARED_LIB: path to libsnappy.a
|
||||
# SNAPPY_FOUND: whether snappy has been found
|
||||
|
||||
if( NOT "${SNAPPY_HOME}" STREQUAL "")
|
||||
@@ -38,14 +38,14 @@
|
||||
set (SNAPPY_HEADER_NAME snappy.h)
|
||||
set (SNAPPY_HEADER ${SNAPPY_INCLUDE_DIR}/${SNAPPY_HEADER_NAME})
|
||||
set (SNAPPY_LIB_NAME snappy)
|
||||
- set (SNAPPY_STATIC_LIB ${SNAPPY_LIBS}/${CMAKE_STATIC_LIBRARY_PREFIX}${SNAPPY_LIB_NAME}${CMAKE_STATIC_LIBRARY_SUFFIX})
|
||||
+ set (SNAPPY_SHARED_LIB ${SNAPPY_LIBS}/${CMAKE_SHARED_LIBRARY_PREFIX}${SNAPPY_LIB_NAME}${CMAKE_SHARED_LIBRARY_SUFFIX})
|
||||
else ()
|
||||
set (SNAPPY_FOUND FALSE)
|
||||
endif ()
|
||||
|
||||
if (SNAPPY_FOUND)
|
||||
message (STATUS "Found the Snappy header: ${SNAPPY_HEADER}")
|
||||
- message (STATUS "Found the Snappy library: ${SNAPPY_STATIC_LIB}")
|
||||
+ message (STATUS "Found the Snappy library: ${SNAPPY_SHARED_LIB}")
|
||||
else()
|
||||
if (_snappy_path)
|
||||
set (SNAPPY_ERR_MSG "Could not find Snappy. Looked in ${_snappy_path}.")
|
||||
@@ -62,7 +62,7 @@
|
||||
|
||||
mark_as_advanced (
|
||||
SNAPPY_INCLUDE_DIR
|
||||
- SNAPPY_STATIC_LIB
|
||||
+ SNAPPY_SHARED_LIB
|
||||
SNAPPY_LIBS
|
||||
SNAPPY_LIBRARIES
|
||||
)
|
||||
--- orc-rel-release-1.6.6/cmake_modules/FindLZ4.cmake.orig 2021-09-15 13:52:14.544322930 -0400
|
||||
+++ orc-rel-release-1.6.6/cmake_modules/FindLZ4.cmake 2021-09-15 13:52:31.791036461 -0400
|
||||
@@ -14,7 +14,7 @@
|
||||
|
||||
# LZ4_INCLUDE_DIR: directory containing headers
|
||||
# LZ4_LIBS: directory containing LZ4 libraries
|
||||
-# LZ4_STATIC_LIB: path to lz4.a
|
||||
+# LZ4_SHARED_LIB: path to lz4.a
|
||||
# LZ4_FOUND: whether LZ4 has been found
|
||||
|
||||
if( NOT "${LZ4_HOME}" STREQUAL "")
|
||||
@@ -38,14 +38,14 @@
|
||||
set (LZ4_HEADER_NAME lz4.h)
|
||||
set (LZ4_HEADER ${LZ4_INCLUDE_DIR}/${LZ4_HEADER_NAME})
|
||||
set (LZ4_LIB_NAME lz4)
|
||||
- set (LZ4_STATIC_LIB ${LZ4_LIBS}/${CMAKE_STATIC_LIBRARY_PREFIX}${LZ4_LIB_NAME}${CMAKE_STATIC_LIBRARY_SUFFIX})
|
||||
+ set (LZ4_SHARED_LIB ${LZ4_LIBS}/${CMAKE_SHARED_LIBRARY_PREFIX}${LZ4_LIB_NAME}${CMAKE_SHARED_LIBRARY_SUFFIX})
|
||||
else ()
|
||||
set (LZ4_FOUND FALSE)
|
||||
endif ()
|
||||
|
||||
if (LZ4_FOUND)
|
||||
message (STATUS "Found the LZ4 header: ${LZ4_HEADER}")
|
||||
- message (STATUS "Found the LZ4 library: ${LZ4_STATIC_LIB}")
|
||||
+ message (STATUS "Found the LZ4 library: ${LZ4_SHARED_LIB}")
|
||||
else()
|
||||
if (_lz4_path)
|
||||
set (LZ4_ERR_MSG "Could not find LZ4. Looked in ${_lz4_path}.")
|
||||
@@ -62,7 +62,7 @@
|
||||
|
||||
mark_as_advanced (
|
||||
LZ4_INCLUDE_DIR
|
||||
- LZ4_STATIC_LIB
|
||||
+ LZ4_SHARED_LIB
|
||||
LZ4_LIBS
|
||||
LZ4_LIBRARIES
|
||||
)
|
||||
--- orc-rel-release-1.6.6/cmake_modules/FindProtobuf.cmake.orig 2021-09-15 14:15:19.726344469 -0400
|
||||
+++ orc-rel-release-1.6.6/cmake_modules/FindProtobuf.cmake 2021-09-15 14:16:22.330307272 -0400
|
||||
@@ -15,8 +15,8 @@
|
||||
# PROTOBUF_FOUND is set if Protobuf is found
|
||||
# PROTOBUF_INCLUDE_DIR: directory containing headers
|
||||
# PROTOBUF_LIBS: directory containing Protobuf libraries
|
||||
-# PROTOBUF_STATIC_LIB: location of protobuf.a
|
||||
-# PROTOC_STATIC_LIB: location of protoc.a
|
||||
+# PROTOBUF_SHARED_LIB: location of protobuf.a
|
||||
+# PROTOC_SHARED_LIB: location of protoc.a
|
||||
# PROTOBUF_EXECUTABLE: location of protoc
|
||||
|
||||
|
||||
@@ -54,16 +54,16 @@
|
||||
get_filename_component (PROTOBUF_LIBS ${PROTOBUF_LIBRARY} PATH)
|
||||
set (PROTOBUF_LIB_NAME protobuf)
|
||||
set (PROTOC_LIB_NAME protoc)
|
||||
- set (PROTOBUF_STATIC_LIB ${PROTOBUF_LIBS}/${CMAKE_STATIC_LIBRARY_PREFIX}${PROTOBUF_LIB_NAME}${CMAKE_STATIC_LIBRARY_SUFFIX})
|
||||
- set (PROTOC_STATIC_LIB ${PROTOBUF_LIBS}/${CMAKE_STATIC_LIBRARY_PREFIX}${PROTOC_LIB_NAME}${CMAKE_STATIC_LIBRARY_SUFFIX})
|
||||
+ set (PROTOBUF_SHARED_LIB ${PROTOBUF_LIBS}/${CMAKE_SHARED_LIBRARY_PREFIX}${PROTOBUF_LIB_NAME}${CMAKE_SHARED_LIBRARY_SUFFIX})
|
||||
+ set (PROTOC_SHARED_LIB ${PROTOBUF_LIBS}/${CMAKE_SHARED_LIBRARY_PREFIX}${PROTOC_LIB_NAME}${CMAKE_SHARED_LIBRARY_SUFFIX})
|
||||
else ()
|
||||
set (PROTOBUF_FOUND FALSE)
|
||||
endif ()
|
||||
|
||||
if (PROTOBUF_FOUND)
|
||||
message (STATUS "Found the Protobuf headers: ${PROTOBUF_INCLUDE_DIR}")
|
||||
- message (STATUS "Found the Protobuf library: ${PROTOBUF_STATIC_LIB}")
|
||||
- message (STATUS "Found the Protoc library: ${PROTOC_STATIC_LIB}")
|
||||
+ message (STATUS "Found the Protobuf library: ${PROTOBUF_SHARED_LIB}")
|
||||
+ message (STATUS "Found the Protoc library: ${PROTOC_SHARED_LIB}")
|
||||
message (STATUS "Found the Protoc executable: ${PROTOBUF_EXECUTABLE}")
|
||||
else()
|
||||
if (_protobuf_path)
|
||||
@@ -82,6 +82,6 @@
|
||||
mark_as_advanced (
|
||||
PROTOBUF_INCLUDE_DIR
|
||||
PROTOBUF_LIBS
|
||||
- PROTOBUF_STATIC_LIB
|
||||
- PROTOC_STATIC_LIB
|
||||
+ PROTOBUF_SHARED_LIB
|
||||
+ PROTOC_SHARED_LIB
|
||||
)
|
||||
--- orc-rel-release-1.6.6/cmake_modules/FindZLIB.cmake.orig 2021-09-15 14:20:04.485626684 -0400
|
||||
+++ orc-rel-release-1.6.6/cmake_modules/FindZLIB.cmake 2021-09-15 14:20:33.448146843 -0400
|
||||
@@ -14,7 +14,7 @@
|
||||
|
||||
# ZLIB_INCLUDE_DIR: directory containing headers
|
||||
# ZLIB_LIBS: directory containing ZLIB libraries
|
||||
-# ZLIB_STATIC_LIB: path to zlib.a
|
||||
+# ZLIB_SHARED_LIB: path to zlib.a
|
||||
# ZLIB_FOUND: whether ZLIB has been found
|
||||
|
||||
if( NOT "${ZLIB_HOME}" STREQUAL "")
|
||||
@@ -28,11 +28,11 @@
|
||||
NO_DEFAULT_PATH
|
||||
PATH_SUFFIXES "include")
|
||||
|
||||
-if (NOT ZLIB_STATIC_LIB_NAME)
|
||||
- set (ZLIB_STATIC_LIB_NAME z)
|
||||
+if (NOT ZLIB_SHARED_LIB_NAME)
|
||||
+ set (ZLIB_SHARED_LIB_NAME z)
|
||||
endif()
|
||||
|
||||
-find_library (ZLIB_LIBRARIES NAMES ${ZLIB_STATIC_LIB_NAME} HINTS
|
||||
+find_library (ZLIB_LIBRARIES NAMES ${ZLIB_SHARED_LIB_NAME} HINTS
|
||||
${_zlib_path}
|
||||
PATH_SUFFIXES "lib")
|
||||
|
||||
@@ -41,14 +41,14 @@
|
||||
get_filename_component (ZLIB_LIBS ${ZLIB_LIBRARIES} PATH )
|
||||
set (ZLIB_HEADER_NAME zlib.h)
|
||||
set (ZLIB_HEADER ${ZLIB_INCLUDE_DIR}/${ZLIB_HEADER_NAME})
|
||||
- set (ZLIB_STATIC_LIB ${ZLIB_LIBS}/${CMAKE_STATIC_LIBRARY_PREFIX}${ZLIB_STATIC_LIB_NAME}${CMAKE_STATIC_LIBRARY_SUFFIX})
|
||||
+ set (ZLIB_SHARED_LIB ${ZLIB_LIBS}/${CMAKE_SHARED_LIBRARY_PREFIX}${ZLIB_SHARED_LIB_NAME}${CMAKE_SHARED_LIBRARY_SUFFIX})
|
||||
else ()
|
||||
set (ZLIB_FOUND FALSE)
|
||||
endif ()
|
||||
|
||||
if (ZLIB_FOUND)
|
||||
message (STATUS "Found the ZLIB header: ${ZLIB_HEADER}")
|
||||
- message (STATUS "Found the ZLIB library: ${ZLIB_STATIC_LIB}")
|
||||
+ message (STATUS "Found the ZLIB library: ${ZLIB_SHARED_LIB}")
|
||||
else()
|
||||
if (_zlib_path)
|
||||
set (ZLIB_ERR_MSG "Could not find ZLIB. Looked in ${_zlib_path}.")
|
||||
@@ -65,7 +65,7 @@
|
||||
|
||||
mark_as_advanced (
|
||||
ZLIB_INCLUDE_DIR
|
||||
- ZLIB_STATIC_LIB
|
||||
+ ZLIB_SHARED_LIB
|
||||
ZLIB_LIBS
|
||||
ZLIB_LIBRARIES
|
||||
)
|
||||
# zstd requires us to add the threads
|
||||
FIND_PACKAGE(Threads REQUIRED)
|
||||
|
11
liborc.spec
11
liborc.spec
@ -1,6 +1,6 @@
|
||||
Summary: Library for producing small, fast columnar storage for Hadoop workloads
|
||||
Name: liborc
|
||||
Version: 1.6.6
|
||||
Version: 1.7.3
|
||||
Release: 1%{?dist}
|
||||
License: ASL 2.0
|
||||
URL: http://orc.apache.org/
|
||||
@ -73,8 +73,8 @@ Contains header files for developing applications that use the %{name}
|
||||
library.
|
||||
|
||||
%prep
|
||||
%setup -qn orc-1.6.6
|
||||
%patch1 -p1 -b .orig
|
||||
%setup -qn orc-%{version}
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%cmake . \
|
||||
@ -117,11 +117,16 @@ mv %{buildroot}%{_docdir}/orc/LICENSE %{buildroot}/%{_defaultlicensedir}/%{name}
|
||||
%files devel
|
||||
%dir %{_includedir}/orc
|
||||
%{_includedir}/orc/*.hh
|
||||
%dir %{_includedir}/orc/sargs
|
||||
%{_includedir}/orc/sargs/*.hh
|
||||
%{_libdir}/liborc.so
|
||||
%dir %{_libdir}/cmake/orc
|
||||
%{_libdir}/cmake/orc/orc*.cmake
|
||||
|
||||
%changelog
|
||||
* Thu Feb 10 2022 Kaleb S. KEITHLEY <kkeithle [at] redhat.com> - 1.7.3-1
|
||||
- 1.7.3 GA
|
||||
|
||||
* Fri Aug 27 2021 Kaleb S. KEITHLEY <kkeithle [at] redhat.com> - 1.6.6-1
|
||||
- New upstream release.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (orc-1.6.6.tar.gz) = c08099d1464d87dd9d53ff7ce4ccedd4a32ce34efe0cdec7f269d98d30252139503f154529d2ca4acbf63a8adc4120aad5ef1a4b446025f22d69938989eac6ec
|
||||
SHA512 (orc-1.7.3.tar.gz) = c3757f2e8d8a49a82a1b794bc8c4e0a5c211e418bd8e49dda814e34ea2fb96f216ab4a7a76b4553bd1074c38875dc2aa3a8ef6e0949674db6a55aff3da9bae13
|
||||
|
Loading…
Reference in New Issue
Block a user