6.0.0-rc1 Release
This commit is contained in:
parent
cbd2f98be9
commit
7e17865630
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
/openmp-5.0.0.src.tar.xz
|
||||
/openmp-5.0.1.src.tar.xz
|
||||
/openmp-6.0.0rc1.src.tar.xz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 6a50c3deceaf66e3d2be93871abef03e22ee4a7c Mon Sep 17 00:00:00 2001
|
||||
From e167844878416cd7e7ab9eee58f1ce56650b56f1 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Tue, 16 May 2017 11:52:19 -0400
|
||||
Subject: [PATCH] CMake: Make LIBOMP_HEADERS_INSTALL_PATH a cache variable when
|
||||
@ -6,22 +6,22 @@ Subject: [PATCH] CMake: Make LIBOMP_HEADERS_INSTALL_PATH a cache variable when
|
||||
|
||||
This way it can be overriden on the command line.
|
||||
---
|
||||
runtime/src/CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
runtime/src/CMakeLists.txt | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/runtime/src/CMakeLists.txt b/runtime/src/CMakeLists.txt
|
||||
index b0aa487..04ebdc3 100644
|
||||
index 8545fe2..9312721 100644
|
||||
--- a/runtime/src/CMakeLists.txt
|
||||
+++ b/runtime/src/CMakeLists.txt
|
||||
@@ -283,7 +283,7 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
|
||||
@@ -282,7 +282,7 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
|
||||
# We want to install libomp in DESTDIR/CMAKE_INSTALL_PREFIX/lib
|
||||
# We want to install headers in DESTDIR/CMAKE_INSTALL_PREFIX/include
|
||||
if(${LIBOMP_STANDALONE_BUILD})
|
||||
if(${OPENMP_STANDALONE_BUILD})
|
||||
- set(LIBOMP_HEADERS_INSTALL_PATH include)
|
||||
+ set(LIBOMP_HEADERS_INSTALL_PATH include CACHE PATH "Install path for OpenMP headers")
|
||||
else()
|
||||
string(REGEX MATCH "[0-9]+\\.[0-9]+(\\.[0-9]+)?" CLANG_VERSION ${PACKAGE_VERSION})
|
||||
set(LIBOMP_HEADERS_INSTALL_PATH lib${LIBOMP_LIBDIR_SUFFIX}/clang/${CLANG_VERSION}/include)
|
||||
set(LIBOMP_HEADERS_INSTALL_PATH lib${OPENMP_LIBDIR_SUFFIX}/clang/${CLANG_VERSION}/include)
|
||||
--
|
||||
1.8.3.1
|
||||
|
||||
|
21
libomp.spec
21
libomp.spec
@ -1,11 +1,13 @@
|
||||
%global rc_ver 1
|
||||
|
||||
Name: libomp
|
||||
Version: 5.0.1
|
||||
Release: 1%{?dist}
|
||||
Version: 6.0.0
|
||||
Release: 0.1.rc%{rc_ver}%{?dist}
|
||||
Summary: OpenMP runtime for clang
|
||||
|
||||
License: NCSA
|
||||
URL: http://openmp.llvm.org
|
||||
Source0: http://llvm.org/releases/%{version}/openmp-%{version}.src.tar.xz
|
||||
Source0: http://llvm.org/releases/%{version}/openmp-%{version}%{?rc_ver:rc%{rc_ver}}.src.tar.xz
|
||||
|
||||
Patch0: 0001-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-a-cache-varia.patch
|
||||
|
||||
@ -31,7 +33,7 @@ Requires: clang-devel%{?isa} = %{version}
|
||||
OpenMP header files.
|
||||
|
||||
%prep
|
||||
%autosetup -n openmp-%{version}.src -p1
|
||||
%autosetup -n openmp-%{version}%{?rc_ver:rc%{rc_ver}}.src -p1
|
||||
|
||||
%build
|
||||
mkdir -p _build
|
||||
@ -41,9 +43,9 @@ cd _build
|
||||
-DLIBOMP_INSTALL_ALIASES=OFF \
|
||||
-DLIBOMP_HEADERS_INSTALL_PATH:PATH=%{_libdir}/clang/%{version}/include \
|
||||
%if 0%{?__isa_bits} == 64
|
||||
-DLIBOMP_LIBDIR_SUFFIX=64 \
|
||||
-DOPENMP_LIBDIR_SUFFIX=64 \
|
||||
%else
|
||||
-DLIBOMP_LIBDIR_SUFFIX= \
|
||||
-DOPENMP_LIBDIR_SUFFIX= \
|
||||
%endif
|
||||
|
||||
%make_build
|
||||
@ -55,11 +57,18 @@ cd _build
|
||||
|
||||
%files
|
||||
%{_libdir}/libomp.so
|
||||
%{_libdir}/libomptarget.so
|
||||
|
||||
%files devel
|
||||
%{_libdir}/clang/%{version}/include/omp.h
|
||||
%ifnarch %{arm}
|
||||
%{_libdir}/clang/%{version}/include/ompt.h
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Jan 25 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-0.1.rc1
|
||||
- 6.0.0-rc1 Release
|
||||
|
||||
* Thu Dec 21 2017 Tom Stellard <tstellar@redhat.com> - 5.0.1-1
|
||||
- 5.0.1 Release.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (openmp-5.0.1.src.tar.xz) = 4493b918fd83ef26e2b3f3429d1b00d722328e4c9697ac7625a390834f6e88ada8e5b02ce0ecb4771129207b1b81a9d171f4599ab9388762a3c6db0afc499ff4
|
||||
SHA512 (openmp-6.0.0rc1.src.tar.xz) = b1978bf8c89336e71e22fae3302858fd399a1f73632512e7f20cc14dae2dc1d42f2e1963c2d81d44b57ed0ae523c6453fd9af794686b4c361f002ba6297ea6a4
|
||||
|
Loading…
Reference in New Issue
Block a user