Cleanup, rename and normalize patch serie

This commit is contained in:
serge-sans-paille 2021-02-25 15:24:50 +01:00
parent 00a14ab0dd
commit 66b1a24c79
2 changed files with 12 additions and 14 deletions

View File

@ -1,25 +1,23 @@
From 156a23f5d91c35edd888091b3d6416b755fa134d Mon Sep 17 00:00:00 2001
From f2c9c1c9cda831a4305e2dc8899d630ed727353a Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Tue, 16 May 2017 11:52:19 -0400
Subject: [PATCH] CMake: Make LIBOMP_HEADERS_INSTALL_PATH a cache variable when
bulding standalone
Subject: [PATCH] [PATCH][openmp] CMake: Make LIBOMP_HEADERS_INSTALL_PATH a
cache variable when bulding standalone
This way it can be overriden on the command line.
---
runtime/src/CMakeLists.txt | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
openmp/runtime/src/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/runtime/src/CMakeLists.txt b/runtime/src/CMakeLists.txt
index f9e63f4..2bf6796 100644
--- a/runtime/src/CMakeLists.txt
+++ b/runtime/src/CMakeLists.txt
@@ -282,8 +282,8 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
# Install rules
diff --git a/openmp/runtime/src/CMakeLists.txt b/openmp/runtime/src/CMakeLists.txt
index 822f9ca..583a3c3 100644
--- a/openmp/runtime/src/CMakeLists.txt
+++ b/openmp/runtime/src/CMakeLists.txt
@@ -305,7 +305,7 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
# We want to install libomp in DESTDIR/CMAKE_INSTALL_PREFIX/lib
# We want to install headers in DESTDIR/CMAKE_INSTALL_PREFIX/include
-if(${OPENMP_STANDALONE_BUILD})
if(${OPENMP_STANDALONE_BUILD})
- set(LIBOMP_HEADERS_INSTALL_PATH include)
+if(${OPENMP_STANDALONE_BUILD})
+ set(LIBOMP_HEADERS_INSTALL_PATH include CACHE PATH "Install path for OpenMP headers")
else()
string(REGEX MATCH "[0-9]+\\.[0-9]+(\\.[0-9]+)?" CLANG_VERSION ${PACKAGE_VERSION})

View File

@ -22,7 +22,7 @@ Source2: tstellar-gpg-key.asc
Source3: run-lit-tests
Source4: lit.fedora.cfg.py
Patch0: 0001-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-a-cache-varia.patch
Patch0: 0001-PATCH-openmp-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-.patch
BuildRequires: gcc
BuildRequires: gcc-c++