libntirpc/0001-libnsl2.patch
Kaleb S. KEITHLEY b363fda0fb libntirpc 1.6.0 GA
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
2018-01-17 11:19:58 -05:00

50 lines
1.5 KiB
Diff

--- ntirpc-1.6.0/CMakeLists.txt.orig 2018-01-17 08:30:42.506183812 -0500
+++ ntirpc-1.6.0/CMakeLists.txt 2018-01-17 11:08:33.232183812 -0500
@@ -153,14 +153,14 @@
# Find misc system libs
find_library(LIBRT rt) # extended Pthreads functions
-find_library(LIBNSL nsl) # sockets
+find_package(NSL) # sockets
set(SYSTEM_LIBRARIES
${LIBTIRPC_LIBRARIES}
${KRB5_LIBRARIES}
${SYSTEM_LIBRARIES}
${LIBRT}
- ${LIBNSL}
+ ${NSL_LIBRARY}
)
set(LIBNTIRPC_MAP "${PROJECT_BINARY_DIR}/src/libntirpc.map")
--- /dev/null 2018-01-12 15:32:04.693000000 -0500
+++ ntirpc-1.6.0/cmake/modules/FindNSL.cmake 2018-01-17 11:09:30.624183812 -0500
@@ -0,0 +1,27 @@
+# - Find NSL
+#
+# This module defines the following variables:
+# NSL_FOUND = Was NSL found or not?
+#
+# On can set NSL_PATH_HINT before using find_package(NSL) and the
+# module with use the PATH as a hint to find NSL.
+#
+# The hint can be given on the command line too:
+# cmake -DNSL_PATH_HINT=/DATA/ERIC/NSL /path/to/source
+
+#find_path(NSL_INCLUDE_DIR
+ #NAMES yp.h
+ #PATHS ${NSL_HINT_PATH}
+ #PATH_SUFFIXES nsl/rpcsvc
+ #DOC "The NSL include headers")
+
+find_library(NSL_LIBRARY nsl PATH_SUFFIXES nsl)
+
+# handle the QUIETLY and REQUIRED arguments and set PRELUDE_FOUND to TRUE if
+# all listed variables are TRUE
+include(FindPackageHandleStandardArgs)
+#FIND_PACKAGE_HANDLE_STANDARD_ARGS(NSL REQUIRED_VARS NSL_INCLUDE_DIR NSL_LIBRARY)
+FIND_PACKAGE_HANDLE_STANDARD_ARGS(NSL REQUIRED_VARS NSL_LIBRARY)
+
+mark_as_advanced(NSL_INCLUDE_DIR)
+mark_as_advanced(NSL_LIBRARY)