Initial commit

This commit is contained in:
Kaleb S. KEITHLEY 2015-03-31 07:39:14 -04:00
parent 269f236a79
commit 6e2c902977
4 changed files with 109 additions and 0 deletions

2
.gitignore vendored
View File

@ -0,0 +1,2 @@
*.tar.gz
*.rpm

View File

@ -0,0 +1,20 @@
--- ntirpc-1.2.1/src/CMakeLists.txt.orig 2015-03-24 15:48:23.498000000 -0400
+++ ntirpc-1.2.1/src/CMakeLists.txt 2015-03-24 15:48:49.158000000 -0400
@@ -112,7 +112,7 @@
endif(USE_NFS_MSK)
# declares the library
-add_library(ntirpc STATIC
+add_library(ntirpc
${ntirpc_common_SRCS}
${ntirpc_des_SRCS}
${ntirpc_gss_SRCS}
@@ -124,7 +124,7 @@
target_link_libraries(ntirpc ${CMAKE_THREAD_LIBS_INIT})
# fixme!
-set_target_properties(ntirpc PROPERTIES VERSION 4.2.0 SOVERSION 4)
+set_target_properties(ntirpc PROPERTIES VERSION 1.2.1 SOVERSION 1)
install(TARGETS ntirpc DESTINATION bin)
########### install files ###############

86
libntirpc.spec Normal file
View File

@ -0,0 +1,86 @@
%global _hardened_build 1
Name: libntirpc
Version: 1.2.1
Release: 1%{?dev_version:%{dev_version}}%{?dist}
Summary: New Transport Independent RPC Library
Group: System Environment/Libraries
License: BSD
Url: https://github.com/nfs-ganesha/ntirpc
Source0: https://github.com/nfs-ganesha/ntirpc/archive/v%{version}/ntirpc-%{version}.tar.gz
Patch1: libntirpc-1.2.1-src-CMakeList.txt.patch
# Bundling exception through Fedora 23
# https://fedorahosted.org/fpc/ticket/363
# Provides: bundled(libntirpc)
%if ( 0%{?rhel} && 0%{?rhel} < 7 )
BuildRequires: cmake28
%else
BuildRequires: cmake
%endif
BuildRequires: jemalloc-devel
BuildRequires: krb5-devel
%description
This package contains a new implementation of the original libtirpc,
transport-independent RPC (TI-RPC) library for NFS-Ganesha. It has
the following features not found in libtirpc:
1. Bi-directional operation
2. Full-duplex operation on the TCP (vc) transport
3. Thread-safe operating modes
3.1 new locking primitives and lock callouts (interface change)
3.2 stateless send/recv on the TCP transport (interface change)
4. Flexible server integration support
5. Event channels (remove static arrays of xprt handles, new EPOLL/KEVENT
integration)
%package devel
Summary: Development headers for %{name}
Requires: %{name}%{?_isa} = %{version}
%description devel
Development headers and auxiliary files for developing with %{name}.
%prep
%setup -q -n ntirpc-%{version}
%patch1 -p1
%build
%if ( 0%{?rhel} && 0%{?rhel} < 7 )
%global cmake %cmake28
%endif
mv CMakeLists.txt.standalone CMakeLists.txt
%cmake ./ -DCMAKE_INSTALL_PREFIX=
make %{?_smp_mflags}
%install
## make install is broken in various ways
## make install DESTDIR=%%{buildroot}
mkdir -p %{buildroot}%{_libdir}/pkgconfig
install -p -m 0755 src/%{name}.so.%{version} %{buildroot}%{_libdir}/
ln -s %{name}.so.%{version} %{buildroot}%{_libdir}/%{name}.so.1
ln -s %{name}.so.%{version} %{buildroot}%{_libdir}/%{name}.so
mkdir -p %{buildroot}%{_includedir}/ntirpc
cp -a ntirpc %{buildroot}%{_includedir}/
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%{_libdir}/libntirpc.so.*
%{!?_licensedir:%global license %%doc}
%license COPYING
%doc NEWS README
%files devel
%{_libdir}/libntirpc.so
%{_includedir}/ntirpc/
%changelog
* Mon Mar 23 2015 Kaleb S. KEITHLEY <kkeithle at redhat.com> 1.2.1-1
- Initial commit

View File

@ -0,0 +1 @@
e46e22bf9b312a7e92684a177f1f46d7 ntirpc-1.2.1.tar.gz