libntirpc 1.3.0 GA

This commit is contained in:
Kaleb S. KEITHLEY 2015-09-09 13:11:10 -04:00
parent 33cb12ff13
commit 55e6e17b8f
3 changed files with 80 additions and 8 deletions

View File

@ -0,0 +1,71 @@
--- ntirpc-1.3.0/CMakeLists.txt.standalone.orig 2015-09-09 12:31:57.130344661 -0400
+++ ntirpc-1.3.0/CMakeLists.txt.standalone 2015-09-09 12:42:32.016344661 -0400
@@ -33,6 +33,8 @@
option (USE_GSS "enable RPCSEC_GSS support" ON)
+option (USE_NFS_RDMA "enable NFS_RDMA support" ON)
+
option(TIRPC_EPOLL "platform supports EPOLL or emulation" ON)
# MSPAC support -lwbclient link flag
@@ -148,6 +150,11 @@
"platform has EPOLL or emulation"
FORCE)
+set(USE_NFS_RDMA ${USE_NFS_RDMA}
+ CACHE BOOL
+ "platform has RDMA"
+ FORCE)
+
# grist files
configure_file(
"${PROJECT_SOURCE_DIR}/config-h.in.cmake"
--- ntirpc-1.3.0/src/CMakeLists.txt.orig 2015-09-08 21:28:58.178344661 -0400
+++ ntirpc-1.3.0/src/CMakeLists.txt 2015-09-09 12:35:52.867344661 -0400
@@ -6,10 +6,11 @@
)
# ok on Linux and FreeBSD w/GCC and clang compilers
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
+# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
+set(CMAKE_C_FLAGS "-fPIC -isystem ${PROJECT_SOURCE_DIR}/ntirpc ${CMAKE_C_FLAGS}")
include_directories(
- ${PROJECT_SOURCE_DIR}/tirpc
+ ${PROJECT_SOURCE_DIR}/ntirpc
)
########### next target ###############
@@ -110,8 +111,13 @@
svc_rdma.c
xdr_rdma.c
)
+ add_definitions(-DUSE_RPC_RDMA)
endif(USE_NFS_RDMA)
+if(TIRPC_EPOLL)
+ add_definitions(-DTIRPC_EPOLL)
+endif(TIRPC_EPOLL)
+
# declares the library
add_library(ntirpc SHARED
${ntirpc_common_SRCS}
@@ -126,11 +132,16 @@
# set library version and symbol namespace(s) from gen'd map file
set_target_properties(ntirpc PROPERTIES LINK_FLAGS
- "-Wl,--version-script=${LIBNTIRPC_MAP}"
+ "-Wl,--version-script=${PROJECT_SOURCE_DIR}/src/libntirpc.map"
VERSION ${NTIRPC_VERSION}
SOVERSION "${NTIRPC_MAJOR_VERSION}.${NTIRPC_MINOR_VERSION}"
)
+configure_file(
+ "${PROJECT_SOURCE_DIR}/src/libntirpc.map.in.cmake"
+ "${PROJECT_SOURCE_DIR}/src/libntirpc.map"
+)
+
install(TARGETS ntirpc DESTINATION ${LIB_INSTALL_DIR})
########### install files ###############

View File

@ -2,19 +2,15 @@
%global _hardened_build 1
Name: libntirpc
Version: 1.2.1
Release: 3%{?dev_version:%{dev_version}}%{?dist}
Version: 1.3.0
Release: 1%{?dev_version:%{dev_version}}%{?dist}
Summary: New Transport Independent RPC Library
Group: System Environment/Libraries
License: BSD
Url: https://github.com/nfs-ganesha/ntirpc
Source0: https://github.com/nfs-ganesha/ntirpc/archive/v%{version}/ntirpc-%{version}.tar.gz
Patch1: libntirpc-1.2.1-src-CMakeList.txt.patch
# Bundling exception through Fedora 23
# https://fedorahosted.org/fpc/ticket/363
# Provides: bundled(libntirpc)
Patch1: libntirpc-1.3.0-src-CMakeList.txt.patch
BuildRequires: cmake
BuildRequires: jemalloc-devel
@ -59,6 +55,7 @@ ln -s %{name}.so.%{version} %{buildroot}%{_libdir}/%{name}.so.1
ln -s %{name}.so.%{version} %{buildroot}%{_libdir}/%{name}.so
mkdir -p %{buildroot}%{_includedir}/ntirpc
cp -a ntirpc %{buildroot}%{_includedir}/
install -p -m 644 libntirpc.pc %{buildroot}%{_libdir}/pkgconfig/
%post -p /sbin/ldconfig
@ -73,8 +70,12 @@ cp -a ntirpc %{buildroot}%{_includedir}/
%files devel
%{_libdir}/libntirpc.so
%{_includedir}/ntirpc/
%{_libdir}/pkgconfig/libntirpc.pc
%changelog
* Wed Sep 9 2015 Kaleb S. KEITHLEY <kkeithle at redhat.com> 1.3.0-1
- libntirpc 1.3.0 GA
* Thu Jul 16 2015 Kaleb S. KEITHLEY <kkeithle at redhat.com> 1.2.1-3
- RHEL 6 finally has new enough cmake
- use -isystem ... to ensure correct <rpc/rpc*.h> are used

View File

@ -1 +1 @@
e46e22bf9b312a7e92684a177f1f46d7 ntirpc-1.2.1.tar.gz
9f4e3589f7e500444e02cc7722f9e613 ntirpc-1.3.0.tar.gz