Update to 1.8.38 release

This commit is contained in:
Lubomir Rintel 2022-04-07 09:55:45 +02:00
parent 0afac135ea
commit b335c79f3e
5 changed files with 9 additions and 2820 deletions

1
.gitignore vendored
View File

@ -3,3 +3,4 @@
/libnma-1.8.30.tar.xz
/libnma-1.8.32.tar.xz
/libnma-1.8.34.tar.xz
/libnma-1.8.38.tar.xz

File diff suppressed because it is too large Load Diff

View File

@ -1,56 +0,0 @@
From 40b591aaa0fcbc2bf37f89909477d59a102a5fa4 Mon Sep 17 00:00:00 2001
From: Adam Williamson <awilliam@redhat.com>
Date: Fri, 18 Mar 2022 15:56:12 -0700
Subject: [PATCH] meson: build separate UI sources for GTK3 and GTK4 libraries
We can't just do one or the other, each build of the library
needs the correct respective UI resources.
Signed-off-by: Adam Williamson <awilliam@redhat.com>
---
src/meson.build | 2 +-
src/ui/meson.build | 18 ++++++++++--------
2 files changed, 11 insertions(+), 9 deletions(-)
diff --git a/src/meson.build b/src/meson.build
index 6e1a15e4..efe3fb03 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -103,7 +103,7 @@ libnma_dep = declare_dependency(
if enable_libnma_gtk4
libnma_gtk4 = shared_library(
'nma-gtk4',
- sources: gir_sources + ui_sources,
+ sources: gir_sources + ui_sources4,
version: libversion,
include_directories: incs,
dependencies: [ deps, gtk4_dep ],
diff --git a/src/ui/meson.build b/src/ui/meson.build
index 2f8eec99..60dbaeef 100644
--- a/src/ui/meson.build
+++ b/src/ui/meson.build
@@ -1,11 +1,13 @@
-if enable_libnma_gtk4
- ui_dir = 'gtk4'
-else
- ui_dir = 'gtk3'
-endif
-
ui_sources = gnome.compile_resources(
'nma-resources',
- join_paths(ui_dir, 'nma.gresource.xml'),
- source_dir: ui_dir
+ join_paths('gtk3', 'nma.gresource.xml'),
+ source_dir: 'gtk3'
)
+
+if enable_libnma_gtk4
+ ui_sources4 = gnome.compile_resources(
+ 'nma-resources4',
+ join_paths('gtk4', 'nma.gresource.xml'),
+ source_dir: 'gtk4'
+ )
+endif
--
2.35.1

View File

@ -5,12 +5,6 @@
%global mbp_version 0.20090602
%global old_libnma_version 1.8.27
%global rpm_version 1.8.34
%global real_version 1.8.34
%global release_version 2
%global real_version_major %(printf '%s' '%{real_version}' | sed -n 's/^\\([1-9][0-9]*\\.[1-9][0-9]*\\)\\.[1-9][0-9]*$/\\1/p')
%if 0%{?fedora} >= 34 || 0%{?rhel} >= 10
%bcond_without libnma_gtk4
%else
@ -19,23 +13,14 @@
Name: libnma
Summary: NetworkManager GUI library
Version: %{rpm_version}
Release: %{release_version}%{?dist}
Version: 1.8.38
Release: 1%{?dist}
# The entire source code is GPLv2+ except some files in shared/ which are LGPLv2+
License: GPLv2+ and LGPLv2+
URL: https://gitlab.gnome.org/GNOME/libnma/
Source0: https://download.gnome.org/sources/libnma/%{real_version_major}/%{name}-%{real_version}.tar.xz
Source0: https://download.gnome.org/sources/libnma/1.8/%{name}-%{version}.tar.xz
Patch1: 0001-nm-applet-no-notifications.patch
# Include working UI resources for GTK4 so UI elements in GNOME
# Control Center provided by this package work
# https://bugzilla.redhat.com/show_bug.cgi?id=2060868
# https://gitlab.gnome.org/GNOME/libnma/-/merge_requests/26
# Rebased and squashed
Patch2: 0001-Ship-and-compile-both-GTK3-and-GTK4-UI-files.patch
# Fixup to build GTK3 and GTK4 ui sources separately for each lib
# https://gitlab.gnome.org/GNOME/libnma/-/merge_requests/26#note_1411364
Patch3: 0001-meson-build-separate-UI-sources-for-GTK3-and-GTK4-li.patch
Requires: mobile-broadband-provider-info >= %{mbp_version}
@ -102,7 +87,7 @@ files to be used for integrating GUI tools with NetworkManager.
%prep
%autosetup -p1 -n "%{name}-%{real_version}"
%autosetup -p1
%build
@ -158,6 +143,9 @@ files to be used for integrating GUI tools with NetworkManager.
%changelog
* Thu Apr 07 2022 Lubomir Rintel <lkundrak@v3.sk> - 1.8.38-1
- Update to 1.8.38 release
* Fri Mar 18 2022 Adam Williamson <awilliam@redhat.com> - 1.8.34-2
- Backport MR #26 to fix UI files in GTK4 (#2060868)

View File

@ -1 +1 @@
SHA512 (libnma-1.8.34.tar.xz) = aca1e24a852072e65d1fba910613981373bb7bb7869b2e44abc9e41c527d234273f034215d62889a265aa3327ad2cce0cea7368b025df97dab12bff098310aaf
SHA512 (libnma-1.8.38.tar.xz) = 0421c598ccb6e3659f182b596eec76ffd695e51c11fd11b8325c2d08cb259536d7e74c11bbaac3ccb841016a0bc69a87f1c682b934a9eb569a74116e677eba63