Update to git d76a061

This commit is contained in:
Sandro Mani 2020-04-14 14:51:42 +02:00
parent fd6e01e0e2
commit b692219b44
6 changed files with 58 additions and 87 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
/libLAS-1.8.0.tar.bz2
/libLAS-1.8.1.tar.bz2
/libLAS-d76a061.tar.gz

View File

@ -1,30 +0,0 @@
--- libLAS-1.8.0/CMakeLists.txt
+++ libLAS-1.8.0/CMakeLists.txt
@@ -140,27 +140,6 @@
set(CMAKE_INCLUDE_PATH c:/osgeo4w64/include;$ENV{CMAKE_INCLUDE_PATH})
set(CMAKE_LIBRARY_PATH c:/osgeo4w64/lib;$ENV{CMAKE_LIBRARY_PATH})
-else()
-
- # Recommended C++ compilation flags
- # -Weffc++
- #
- # Remove -pedandic which causes errors from boost (comma at end of
- # enum) 2012-09-05. Remove -Wcast-qual -Wfloat-equal
- # -Wredundant-decls to suppress the multitude of warning messages.
- set(LIBLAS_COMMON_CXX_FLAGS
- " -Wextra -Wall -Wno-unused-parameter -Wno-unused-variable -Wpointer-arith -Wcast-align -Wcast-qual -Wfloat-equal -Wredundant-decls -Wno-long-long")
-
- if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
-
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${LIBLAS_COMMON_CXX_FLAGS}")
- if (CMAKE_COMPILER_IS_GNUCXX)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++98 -ansi")
- endif()
-
- elseif("${CMAKE_CXX_COMPILER_ID}" MATCHES "Clang" OR "${CMAKE_CXX_COMPILER}" MATCHES "clang")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${LIBLAS_COMMON_CXX_FLAGS}")
- endif()
endif(WIN32)
if (APPLE)

View File

@ -1,15 +0,0 @@
--- a/src/gt_citation.cpp 2018-08-03 12:16:16.007831564 +0100
+++ b/src/gt_citation.cpp 2018-08-03 12:16:45.224830335 +0100
@@ -387,10 +387,10 @@
osCitation += primemName;
bRewriteGeogCitation = TRUE;
- double primemValue = poSRS->GetPrimeMeridian(NULL);
+ double primemValue = poSRS->GetPrimeMeridian();
if(angUnitName && !EQUAL(angUnitName, "Degree"))
{
- double aUnit = poSRS->GetAngularUnits(NULL);
+ double aUnit = poSRS->GetAngularUnits();
primemValue *= aUnit;
}
GTIFKeySet( psGTIF, GeogPrimeMeridianLongGeoKey, TYPE_DOUBLE, 1,

View File

@ -1,26 +1,31 @@
Name: liblas
Version: 1.8.1
Release: 4%{?dist}
Summary: Library for reading and writing the very common LAS LiDAR format
%global commit d76a061f33a69a36ab116cd939c5d444b301efd8
%global shortcommit %(c=%{commit}; echo ${c:0:7})
Name: liblas
Version: 1.8.1
Release: 5%{?shortcommit:.git%shortcommit}%{?dist}
Summary: Library for reading and writing the very common LAS LiDAR format
License: BSD and Boost
URL: https://www.liblas.org
%if 0%{?commit:1}
Source0: https://github.com/libLAS/libLAS/archive/%{commit}/libLAS-%{shortcommit}.tar.gz
%else
Source0: https://download.osgeo.org/%{name}/libLAS-%{version}.tar.bz2
%endif
License: BSD and Boost
URL: https://www.liblas.org
Source0: https://download.osgeo.org/%{name}/libLAS-%{version}.tar.bz2
# https://github.com/libLAS/libLAS/issues/140 for both:
Patch0001: https://gitweb.gentoo.org/repo/gentoo.git/plain/sci-geosciences/liblas/files/liblas-1.8.1-fix-overload-call.patch
Patch0002: https://gitweb.gentoo.org/repo/gentoo.git/plain/sci-geosciences/liblas/files/liblas-1.8.0_remove-std-c++98.patch
# Fix build against recent gdal3+
# https://github.com/libLAS/libLAS/issues/164
# From https://github.com/OSGeo/gdal/blob/master/gdal/MIGRATION_GUIDE.TXT:
# removal of OSRFixup() and OSRFixupOrdering(): no longer needed since objects constructed are always valid
Patch0003: liblas_gdal3.patch
Patch1: liblas_gdal3.patch
BuildRequires: gcc-c++
BuildRequires: boost-devel >= 1.53
BuildRequires: cmake
BuildRequires: gdal-devel
BuildRequires: laszip-devel
BuildRequires: libgeotiff-devel
BuildRequires: boost-devel >= 1.53
BuildRequires: cmake
BuildRequires: gdal-devel
BuildRequires: laszip-devel
BuildRequires: libgeotiff-devel
%description
libLAS is a C/C++ library for reading and writing the very common LAS LiDAR
@ -47,34 +52,32 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
%description tools
libLAS utility applications.
%prep
%autosetup -n libLAS-%{version} -p1
sed -i -e 's#@libdir@#%{_libdir}#' \
-e 's#@Boost_PROGRAM_OPTIONS_LIBRARY_RELEASE@#-lboost_program_options#' \
-e 's#@Boost_THREAD_LIBRARY_RELEASE@#-lboost_thread#' \
-e 's#@GDAL_LIBRARY@#-lgdal#' \
-e 's#@GEOTIFF_LIBRARY@#-lgeotiff#' \
-e 's#@TIFF_LIBRARY@#-ltiff#' \
-e 's#@LASZIP_LIBRARY@#-llaszip#' \
%{_builddir}/libLAS-%{version}/apps/liblas-config.in
%if 0%{?commit:1}
%autosetup -p1 -n libLAS-%{commit}
%else
%autosetup -p1 -n libLAS-%{version}
%endif
%build
%cmake \
-DCMAKE_BUILD_TYPE:STRING="Release" \
-DCMAKE_SKIP_RPATH:BOOL=ON \
-DGEOTIFF_INCLUDE_DIR:PATH="%{_includedir}/libgeotiff" \
-DLIBLAS_LIB_SUBDIR:PATH="%{_lib}" \
-DWITH_GDAL:BOOL=ON \
-DWITH_LASZIP:BOOL=ON \
-DWITH_PKGCONFIG:BOOL=OFF \
-DWITH_TESTS:BOOL=OFF .
make %{?_smp_mflags}
-DCMAKE_SKIP_RPATH:BOOL=ON \
-DLIBLAS_LIB_SUBDIR:PATH="%{_lib}" \
-DWITH_GDAL:BOOL=ON \
-DWITH_LASZIP:BOOL=ON \
-DWITH_TESTS:BOOL=ON .
%make_build
%install
%make_install
%ldconfig_scriptlets
%files
%exclude %{_datadir}/%{name}/
%{_libdir}/*.so.3
@ -82,9 +85,9 @@ make %{?_smp_mflags}
%files devel
%license LICENSE.txt
%{_bindir}/liblas-config
%{_datadir}/cmake/libLAS/
%{_includedir}/%{name}/
%{_libdir}/cmake/libLAS/
%{_libdir}/pkgconfig/liblas.pc
%{_libdir}/*.so
%files tools
@ -92,7 +95,11 @@ make %{?_smp_mflags}
%exclude %{_bindir}/liblas-config
%{_bindir}/*
%changelog
* Tue Apr 14 2020 Sandro Mani <manisandro@gmail.com> - 1.8.1-5.gitd76a061
- Update to latest git
* Tue Mar 03 2020 Sandro Mani <manisandro@gmail.com> - 1.8.1-4
- Rebuild (gdal)

View File

@ -1,7 +1,15 @@
diff -rupN libLAS-1.8.1/src/gt_wkt_srs.cpp libLAS-1.8.1-new/src/gt_wkt_srs.cpp
--- libLAS-1.8.1/src/gt_wkt_srs.cpp 2016-08-22 15:06:34.000000000 +0200
+++ libLAS-1.8.1-new/src/gt_wkt_srs.cpp 2020-03-03 17:40:34.745324349 +0100
@@ -489,7 +489,6 @@ char *GTIFGetOGISDefn( GTIF *hGTIF, GTIF
diff -rupN libLAS-d76a061f33a69a36ab116cd939c5d444b301efd8/src/gt_wkt_srs.cpp libLAS-d76a061f33a69a36ab116cd939c5d444b301efd8-new/src/gt_wkt_srs.cpp
--- libLAS-d76a061f33a69a36ab116cd939c5d444b301efd8/src/gt_wkt_srs.cpp 2020-04-14 14:31:15.016526319 +0200
+++ libLAS-d76a061f33a69a36ab116cd939c5d444b301efd8-new/src/gt_wkt_srs.cpp 2020-04-14 14:31:28.741504852 +0200
@@ -299,7 +299,6 @@ char *GTIFGetOGISDefn( GTIF *hGTIF, GTIF
oSRS.SetFromUserInput(pszWKT);
oSRS.SetExtension( "PROJCS", "PROJ4",
"+proj=merc +a=6378137 +b=6378137 +lat_ts=0.0 +lon_0=0.0 +x_0=0.0 +y_0=0 +k=1.0 +units=m +nadgrids=@null +wktext +no_defs" );
- oSRS.FixupOrdering();
CPLFree(pszWKT);
pszWKT = NULL;
oSRS.exportToWkt(&pszWKT);
@@ -505,7 +504,6 @@ char *GTIFGetOGISDefn( GTIF *hGTIF, GTIF
{
char *pszWKT;
oSRS.morphFromESRI();
@ -9,7 +17,7 @@ diff -rupN libLAS-1.8.1/src/gt_wkt_srs.cpp libLAS-1.8.1-new/src/gt_wkt_srs.cpp
if( oSRS.exportToWkt( &pszWKT ) == OGRERR_NONE )
return pszWKT;
}
@@ -1090,8 +1089,6 @@ char *GTIFGetOGISDefn( GTIF *hGTIF, GTIF
@@ -1107,8 +1105,6 @@ char *GTIFGetOGISDefn( GTIF *hGTIF, GTIF
/* ==================================================================== */
char *pszWKT;

View File

@ -1 +1 @@
SHA512 (libLAS-1.8.1.tar.bz2) = 1cb39c557af0006c54f1100d0d409977fcc1886abd155c1b144d806c47f8675a9f2125d3a9aca16bae65d2aabba84d5e5e322b42085e7db312f3d53f92342acf
SHA512 (libLAS-d76a061.tar.gz) = 2cd6dff82f6e2ea60c604eb20a1403f4e8f377fd9074394b8877e88283c059471ffaf9c8e57534fc56821c4c68b2aed11e616a5966be58e2f8053b868c235a1f