Add liblas_pkgconfig.patch

This commit is contained in:
Sandro Mani 2020-05-06 13:43:26 +02:00
parent 61288b97fe
commit 78a43a89ed
2 changed files with 19 additions and 1 deletions

View File

@ -3,7 +3,7 @@
Name: liblas
Version: 1.8.1
Release: 6%{?shortcommit:.git%shortcommit}%{?dist}
Release: 7%{?shortcommit:.git%shortcommit}%{?dist}
Summary: Library for reading and writing the very common LAS LiDAR format
License: BSD and Boost
@ -36,6 +36,9 @@ Patch4: liblas_CVE-2018-20536.patch
# https://github.com/libLAS/libLAS/issues/181
Patch5: liblas_CVE-2018-20540.patch
# Fix incorrect libgeotiff pkgconfig require resulting in broken dependencies
Patch6: liblas_pkgconfig.patch
BuildRequires: gcc-c++
BuildRequires: boost-devel >= 1.53
BuildRequires: cmake
@ -115,6 +118,9 @@ libLAS utility applications.
%changelog
* Wed May 06 2020 Sandro Mani <manisandro@gmail.com> - 1.8.1-7.gitd76a061
- Add liblas_pkgconfig.patch
* Tue Apr 14 2020 Sandro Mani <manisandro@gmail.com> - 1.8.1-6.gitd76a061
- Add patches for CVE-2018-20539, CVE-2018-20537, CVE-2018-20536, CVE-2018-20540

12
liblas_pkgconfig.patch Normal file
View File

@ -0,0 +1,12 @@
diff -rupN libLAS-d76a061f33a69a36ab116cd939c5d444b301efd8/apps/CMakeLists.txt libLAS-d76a061f33a69a36ab116cd939c5d444b301efd8-new/apps/CMakeLists.txt
--- libLAS-d76a061f33a69a36ab116cd939c5d444b301efd8/apps/CMakeLists.txt 2020-04-05 18:40:29.000000000 +0200
+++ libLAS-d76a061f33a69a36ab116cd939c5d444b301efd8-new/apps/CMakeLists.txt 2020-05-06 13:26:27.039406880 +0200
@@ -205,7 +205,7 @@ if(UNIX)
set(PKGCFG_REQUIRES "${PKGCFG_REQUIRES} libxml-2.0")
endif()
if(GEOTIFF_FOUND)
- set(PKGCFG_REQUIRES "${PKGCFG_REQUIRES} geotiff")
+ set(PKGCFG_REQUIRES "${PKGCFG_REQUIRES} libgeotiff")
endif()
# if(WITH_GDAL)
# set(PKGCFG_INC_DIR "${PKGCFG_INC_DIR} ${GDAL_INCLUDE_DIR}")