Pull in Gentoo patches to fix build with GDAL 2.3.

This commit is contained in:
Elliott Sales de Andrade 2019-02-04 03:01:50 -05:00
parent 123b91eec2
commit 0044a71040
3 changed files with 49 additions and 1 deletions

View File

@ -0,0 +1,30 @@
--- libLAS-1.8.0/CMakeLists.txt
+++ libLAS-1.8.0/CMakeLists.txt
@@ -140,27 +140,6 @@
set(CMAKE_INCLUDE_PATH c:/osgeo4w64/include;$ENV{CMAKE_INCLUDE_PATH})
set(CMAKE_LIBRARY_PATH c:/osgeo4w64/lib;$ENV{CMAKE_LIBRARY_PATH})
-else()
-
- # Recommended C++ compilation flags
- # -Weffc++
- #
- # Remove -pedandic which causes errors from boost (comma at end of
- # enum) 2012-09-05. Remove -Wcast-qual -Wfloat-equal
- # -Wredundant-decls to suppress the multitude of warning messages.
- set(LIBLAS_COMMON_CXX_FLAGS
- " -Wextra -Wall -Wno-unused-parameter -Wno-unused-variable -Wpointer-arith -Wcast-align -Wcast-qual -Wfloat-equal -Wredundant-decls -Wno-long-long")
-
- if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
-
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${LIBLAS_COMMON_CXX_FLAGS}")
- if (CMAKE_COMPILER_IS_GNUCXX)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++98 -ansi")
- endif()
-
- elseif("${CMAKE_CXX_COMPILER_ID}" MATCHES "Clang" OR "${CMAKE_CXX_COMPILER}" MATCHES "clang")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${LIBLAS_COMMON_CXX_FLAGS}")
- endif()
endif(WIN32)
if (APPLE)

View File

@ -0,0 +1,15 @@
--- a/src/gt_citation.cpp 2018-08-03 12:16:16.007831564 +0100
+++ b/src/gt_citation.cpp 2018-08-03 12:16:45.224830335 +0100
@@ -387,10 +387,10 @@
osCitation += primemName;
bRewriteGeogCitation = TRUE;
- double primemValue = poSRS->GetPrimeMeridian(NULL);
+ double primemValue = poSRS->GetPrimeMeridian();
if(angUnitName && !EQUAL(angUnitName, "Degree"))
{
- double aUnit = poSRS->GetAngularUnits(NULL);
+ double aUnit = poSRS->GetAngularUnits();
primemValue *= aUnit;
}
GTIFKeySet( psGTIF, GeogPrimeMeridianLongGeoKey, TYPE_DOUBLE, 1,

View File

@ -6,6 +6,9 @@ Summary: Library for reading and writing the very common LAS LiDAR format
License: BSD and Boost
URL: https://www.liblas.org
Source0: https://download.osgeo.org/%{name}/libLAS-%{version}.tar.bz2
# https://github.com/libLAS/libLAS/issues/140 for both:
Patch0001: https://gitweb.gentoo.org/repo/gentoo.git/plain/sci-geosciences/liblas/files/liblas-1.8.1-fix-overload-call.patch
Patch0002: https://gitweb.gentoo.org/repo/gentoo.git/plain/sci-geosciences/liblas/files/liblas-1.8.0_remove-std-c++98.patch
BuildRequires: gcc-c++
BuildRequires: boost-devel >= 1.53
@ -40,7 +43,7 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
libLAS utility applications.
%prep
%setup -q -n libLAS-%{version}
%autosetup -n libLAS-%{version} -p1
sed -i -e 's#@libdir@#%{_libdir}#' \
-e 's#@Boost_PROGRAM_OPTIONS_LIBRARY_RELEASE@#-lboost_program_options#' \
-e 's#@Boost_THREAD_LIBRARY_RELEASE@#-lboost_thread#' \