0.7.0-3
- drop BR: gcc-c++ - s/qt-devel/qt4-devel/ s/kdelibs-devel/kdelibs4-devel/ - fix build against boost-1.50
This commit is contained in:
parent
971f08be49
commit
d138b638e7
24
libkolabxml-0.7.0-boost.patch
Normal file
24
libkolabxml-0.7.0-boost.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -up libkolabxml-0.7.0/CMakeLists.txt.boost libkolabxml-0.7.0/CMakeLists.txt
|
||||
--- libkolabxml-0.7.0/CMakeLists.txt.boost 2012-07-19 05:23:24.000000000 -0500
|
||||
+++ libkolabxml-0.7.0/CMakeLists.txt 2012-08-12 19:02:38.719584118 -0500
|
||||
@@ -82,7 +82,7 @@ set(CMAKECONFIG_INSTALL_DIR ${LIB_INSTAL
|
||||
configure_file(libkolabxml-version.h.cmake "${CMAKE_BINARY_DIR}/libkolabxml-version.h" @ONLY)
|
||||
|
||||
set(Boost_USE_MULTITHREADED ON)
|
||||
-find_package(Boost REQUIRED COMPONENTS thread)
|
||||
+find_package(Boost REQUIRED COMPONENTS thread system)
|
||||
if (Boost_FOUND)
|
||||
message("Found boost in ${Boost_INCLUDE_DIRS}")
|
||||
endif (Boost_FOUND)
|
||||
diff -up libkolabxml-0.7.0/tests/CMakeLists.txt.boost libkolabxml-0.7.0/tests/CMakeLists.txt
|
||||
--- libkolabxml-0.7.0/tests/CMakeLists.txt.boost 2012-07-19 05:23:24.000000000 -0500
|
||||
+++ libkolabxml-0.7.0/tests/CMakeLists.txt 2012-08-12 19:03:06.654234896 -0500
|
||||
@@ -13,7 +13,7 @@ if (QT4_FOUND)
|
||||
|
||||
QT4_AUTOMOC(conversiontest.cpp)
|
||||
add_executable(conversiontest conversiontest.cpp ${CMAKE_CURRENT_BINARY_DIR}/${CONVERSIONTEST_MOC})
|
||||
- target_link_libraries(conversiontest ${QT_QTTEST_LIBRARY} ${QT_QTCORE_LIBRARY} kolabxml ${XERCES_C})
|
||||
+ target_link_libraries(conversiontest ${QT_QTTEST_LIBRARY} ${QT_QTCORE_LIBRARY} kolabxml ${XERCES_C} ${Boost_LIBRARIES})
|
||||
|
||||
QT4_AUTOMOC(parsingtest.cpp)
|
||||
add_executable(parsingtest parsingtest.cpp ${CMAKE_CURRENT_BINARY_DIR}/${CONVERSIONTEST_MOC})
|
@ -13,7 +13,7 @@
|
||||
|
||||
Name: libkolabxml
|
||||
Version: 0.7.0
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: Kolab XML format collection parser library
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -26,6 +26,11 @@ Patch1: libkolabxml-0.7.0-fix-build-without-fpermissive.patch
|
||||
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
## upstreamable patches
|
||||
# not sure about this, the api conversion test uses seems *all* about boost_threads, but
|
||||
# then ends up with a symbol from boost_system -- rex
|
||||
Patch50: libkolabxml-0.7.0-boost.patch
|
||||
|
||||
%if 0%{?rhel} < 6 && 0%{?fedora} < 15
|
||||
BuildRequires: boost141-devel
|
||||
%else
|
||||
@ -33,15 +38,14 @@ BuildRequires: boost-devel
|
||||
%endif
|
||||
BuildRequires: cmake >= 2.6
|
||||
BuildRequires: e2fsprogs-devel
|
||||
BuildRequires: gcc-c++
|
||||
%if 0%{?rhel} > 6 || 0%{?fedora} >= 16
|
||||
BuildRequires: kdelibs-devel
|
||||
BuildRequires: kdelibs4-devel
|
||||
BuildRequires: kdepimlibs-devel
|
||||
%endif
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: php-devel >= 5.3
|
||||
BuildRequires: python-devel
|
||||
BuildRequires: qt-devel >= 3
|
||||
BuildRequires: qt4-devel
|
||||
BuildRequires: swig
|
||||
BuildRequires: uuid-devel
|
||||
BuildRequires: xerces-c-devel
|
||||
@ -68,13 +72,13 @@ Requires: cmake >= 2.6
|
||||
Requires: e2fsprogs-devel
|
||||
Requires: gcc-c++
|
||||
%if 0%{?rhel} > 6 || 0%{?fedora} >= 16
|
||||
Requires: kdelibs-devel
|
||||
Requires: kdelibs4-devel
|
||||
Requires: kdepimlibs-devel
|
||||
%endif
|
||||
Requires: libcurl-devel
|
||||
Requires: php-devel >= 5.3
|
||||
Requires: python-devel
|
||||
Requires: qt-devel >= 3
|
||||
Requires: qt4-devel
|
||||
Requires: swig
|
||||
Requires: uuid-devel
|
||||
Requires: xerces-c-devel
|
||||
@ -113,6 +117,7 @@ bindings provided through libkolabxml.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
%patch50 -p1 -b .boost
|
||||
|
||||
%build
|
||||
rm -rf build
|
||||
@ -193,6 +198,11 @@ rm -rf %{buildroot}
|
||||
%{python_sitearch}/_kolabformat.so
|
||||
|
||||
%changelog
|
||||
* Sun Aug 12 2012 Rex Dieter <rdieter@fedoraproject.org> - 0.7.0-3
|
||||
- drop BR: gcc-c++
|
||||
- s/qt-devel/qt4-devel/ s/kdelibs-devel/kdelibs4-devel/
|
||||
- fix build against boost-1.50
|
||||
|
||||
* Wed Jul 25 2012 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.7.0-2
|
||||
- Fix build on ppc64
|
||||
- New upstream version
|
||||
|
Loading…
Reference in New Issue
Block a user