173 lines
5.5 KiB
Diff
173 lines
5.5 KiB
Diff
diff -urN KNI_3.9.2/demo/Makefile KNI_3.9.2.sofixes/demo/Makefile
|
|
--- KNI_3.9.2/demo/Makefile 2007-06-20 08:05:24.000000000 +0200
|
|
+++ KNI_3.9.2.sofixes/demo/Makefile 2009-08-28 22:09:05.000000000 +0200
|
|
@@ -34,11 +34,11 @@
|
|
INCLUDE_DIR = ../include -I./common
|
|
LIBRARY_DIR = ../lib/linux
|
|
|
|
-BASE_LIBRARY = $(LIBRARY_DIR)/libKNIBase.a
|
|
-INVKIN_LIBRARY = $(LIBRARY_DIR)/libKNI_InvKin.a
|
|
-LM_LIBRARY = $(LIBRARY_DIR)/libKNI_LM.a
|
|
+BASE_LIBRARY = $(LIBRARY_DIR)/libKNIBase3.a
|
|
+INVKIN_LIBRARY = $(LIBRARY_DIR)/libKNI_InvKin3.a
|
|
+LM_LIBRARY = $(LIBRARY_DIR)/libKNI_LM3.a
|
|
|
|
-AVAILABLE_LIBRARIES = ./common/keyboard.o ${BASE_LIBRARY} ${INVKIN_LIBRARY} ${LM_LIBRARY}
|
|
+AVAILABLE_LIBRARIES = ./common/keyboard.o
|
|
|
|
.SILENT:
|
|
|
|
@@ -55,7 +55,7 @@
|
|
|
|
$(TARGETS_D): $(CTARGETS_D)
|
|
echo -n "Building: $@"
|
|
- if $(CXX) $(CXXFLAGS) -I$(INCLUDE_DIR) -lpthread -o $(@:.demo=)/$(@:.demo=) $(wildcard $(@:.demo=)/*.cpp) ${AVAILABLE_LIBRARIES} 2>.clog; \
|
|
+ if $(CXX) $(CXXFLAGS) -I$(INCLUDE_DIR) -L../lib/linux -lKNIBase3 -lKNI_InvKin3 -lKNI_LM3 -lpthread -o $(@:.demo=)/$(@:.demo=) $(wildcard $(@:.demo=)/*.cpp) ${AVAILABLE_LIBRARIES} 2>.clog; \
|
|
then echo " [ok]"; \
|
|
cat .clog; \
|
|
else echo " [failed]"; \
|
|
diff -urN KNI_3.9.2/src/Base/Makefile KNI_3.9.2.sofixes/src/Base/Makefile
|
|
--- KNI_3.9.2/src/Base/Makefile 2007-04-26 08:18:24.000000000 +0200
|
|
+++ KNI_3.9.2.sofixes/src/Base/Makefile 2009-08-28 22:08:00.000000000 +0200
|
|
@@ -24,20 +24,22 @@
|
|
|
|
TARGETS = alib solib
|
|
|
|
-LIBNAME = libKNIBase
|
|
+LIBNAME = libKNIBase3
|
|
SOURCES = cdlCOM.cpp cplSerial.cpp cdlSocket.cpp CRC.cpp kmlBase.cpp kmlExt.cpp kmlMotBase.cpp kmlSctBase.cpp kmlFactories.cpp
|
|
|
|
ADDITIONAL_DEPS = ../common/Timer.o
|
|
|
|
LIBNAME_A = $(LIBNAME).a
|
|
LIBNAME_SO = $(LIBNAME).so.$(MAJOR_VERSION).$(MINOR_VERSION)
|
|
-
|
|
-SLCFLAGS=-fPIC
|
|
-SLLDFLAGS=-shared
|
|
+LIBNAME_SO_LN = $(LIBNAME).so
|
|
+LIBNAME_SONAME = $(LIBNAME).so.$(MAJOR_VERSION)
|
|
|
|
INCLUDE_DIR = ../../include
|
|
TARGET_DIR = ../../lib/linux
|
|
|
|
+SLCFLAGS=-fPIC
|
|
+SLLDFLAGS = -shared -L$(TARGET_DIR)
|
|
+
|
|
.SILENT:
|
|
|
|
.SUFFIXES: .cpp.o
|
|
@@ -69,8 +71,9 @@
|
|
|
|
$(TARGET_DIR)/$(LIBNAME_SO): $(SOURCES:.cpp=.o)
|
|
echo -n "Building: $@"
|
|
- if $(CXX) $(CXXFLAGS) $(SLLDFLAGS) -o $@ $(SOURCES:.cpp=.o) $(ADDITITIONAL_DEPS) 2>.slog; \
|
|
+ if $(CXX) $(CXXFLAGS) $(SLLDFLAGS) -o $@ -Wl,-soname,$(LIBNAME_SONAME) $(SOURCES:.cpp=.o) $(ADDITIONAL_DEPS) 2>.slog; \
|
|
then echo " [ok]"; \
|
|
+ ln -s $(LIBNAME_SO) $(TARGET_DIR)/$(LIBNAME_SO_LN); \
|
|
cat .slog; \
|
|
else echo " [failed]"; \
|
|
cat .slog; \
|
|
diff -urN KNI_3.9.2/src/common/Makefile KNI_3.9.2.sofixes/src/common/Makefile
|
|
--- KNI_3.9.2/src/common/Makefile 2007-04-26 08:18:24.000000000 +0200
|
|
+++ KNI_3.9.2.sofixes/src/common/Makefile 2009-08-28 22:08:16.000000000 +0200
|
|
@@ -17,14 +17,14 @@
|
|
#===========================================================================
|
|
|
|
CXX = g++
|
|
-CXXFLAGS += -g -O2 -Wall
|
|
+CXXFLAGS += -g -O2 -Wall -fPIC
|
|
|
|
MAJOR_VERSION = 3.9
|
|
MINOR_VERSION = 0
|
|
|
|
TARGETS = alib
|
|
|
|
-LIBNAME = knicommon
|
|
+LIBNAME = knicommon3
|
|
SOURCES = Timer.cpp
|
|
|
|
LIBNAME_A = $(LIBNAME).a
|
|
diff -urN KNI_3.9.2/src/InvKin/Makefile KNI_3.9.2.sofixes/src/InvKin/Makefile
|
|
--- KNI_3.9.2/src/InvKin/Makefile 2007-04-26 08:18:24.000000000 +0200
|
|
+++ KNI_3.9.2.sofixes/src/InvKin/Makefile 2009-08-28 22:08:25.000000000 +0200
|
|
@@ -24,20 +24,23 @@
|
|
|
|
TARGETS = alib solib
|
|
|
|
-LIBNAME = libKNI_InvKin
|
|
+LIBNAME = libKNI_InvKin3
|
|
SOURCES = ikBase.cpp KatanaKinematics6M90G.cpp KatanaKinematics6M90T.cpp KatanaKinematics6M180.cpp KatanaKinematics5M180.cpp KatanaKinematicsDecisionAlgorithms.cpp
|
|
|
|
ADDITIONAL_DEPS = ../common/Timer.o
|
|
|
|
LIBNAME_A = $(LIBNAME).a
|
|
LIBNAME_SO = $(LIBNAME).so.$(MAJOR_VERSION).$(MINOR_VERSION)
|
|
-
|
|
-SLCFLAGS=-fPIC
|
|
-SLLDFLAGS=-shared
|
|
+LIBNAME_SO_LN = $(LIBNAME).so
|
|
+LIBNAME_SONAME = $(LIBNAME).so.$(MAJOR_VERSION)
|
|
|
|
INCLUDE_DIR = ../../include
|
|
TARGET_DIR = ../../lib/linux
|
|
|
|
+SLCFLAGS=-fPIC
|
|
+SLLDFLAGS=-shared -L$(TARGET_DIR) -lKNIBase3
|
|
+
|
|
+
|
|
.SILENT:
|
|
|
|
.SUFFIXES: .cpp.o
|
|
@@ -69,8 +72,9 @@
|
|
|
|
$(TARGET_DIR)/$(LIBNAME_SO): $(SOURCES:.cpp=.o)
|
|
echo -n "Building: $@"
|
|
- if $(CXX) $(CXXFLAGS) $(SLLDFLAGS) -o $@ $(SOURCES:.cpp=.o) $(ADDITITIONAL_DEPS) 2>.slog; \
|
|
+ if $(CXX) $(CXXFLAGS) $(SLLDFLAGS) -o $@ -Wl,-soname,$(LIBNAME_SONAME) $(SOURCES:.cpp=.o) $(ADDITIONAL_DEPS) 2>.slog; \
|
|
then echo " [ok]"; \
|
|
+ ln -s $(LIBNAME_SO) $(TARGET_DIR)/$(LIBNAME_SO_LN); \
|
|
cat .slog; \
|
|
else echo " [failed]"; \
|
|
cat .slog; \
|
|
diff -urN KNI_3.9.2/src/LM/Makefile KNI_3.9.2.sofixes/src/LM/Makefile
|
|
--- KNI_3.9.2/src/LM/Makefile 2007-04-26 08:18:24.000000000 +0200
|
|
+++ KNI_3.9.2.sofixes/src/LM/Makefile 2009-08-28 22:08:40.000000000 +0200
|
|
@@ -24,20 +24,22 @@
|
|
|
|
TARGETS = alib solib
|
|
|
|
-LIBNAME = libKNI_LM
|
|
+LIBNAME = libKNI_LM3
|
|
SOURCES = lmBase.cpp
|
|
|
|
ADDITIONAL_DEPS = ../common/Timer.o
|
|
|
|
LIBNAME_A = $(LIBNAME).a
|
|
LIBNAME_SO = $(LIBNAME).so.$(MAJOR_VERSION).$(MINOR_VERSION)
|
|
-
|
|
-SLCFLAGS=-fPIC
|
|
-SLLDFLAGS=-shared
|
|
+LIBNAME_SO_LN = $(LIBNAME).so
|
|
+LIBNAME_SONAME = $(LIBNAME).so.$(MAJOR_VERSION)
|
|
|
|
INCLUDE_DIR = ../../include
|
|
TARGET_DIR = ../../lib/linux
|
|
|
|
+SLCFLAGS=-fPIC
|
|
+SLLDFLAGS=-shared -L$(TARGET_DIR) -lKNIBase3 -lKNI_InvKin3
|
|
+
|
|
.SILENT:
|
|
|
|
.SUFFIXES: .cpp.o
|
|
@@ -69,8 +71,9 @@
|
|
|
|
$(TARGET_DIR)/$(LIBNAME_SO): $(SOURCES:.cpp=.o)
|
|
echo -n "Building: $@"
|
|
- if $(CXX) $(CXXFLAGS) $(SLLDFLAGS) -o $@ $(SOURCES:.cpp=.o) $(ADDITITIONAL_DEPS) 2>.slog; \
|
|
+ if $(CXX) $(CXXFLAGS) $(SLLDFLAGS) -o $@ -Wl,-soname,$(LIBNAME_SONAME) $(SOURCES:.cpp=.o) $(ADDITIONAL_DEPS) 2>.slog; \
|
|
then echo " [ok]"; \
|
|
+ ln -s $(LIBNAME_SO) $(TARGET_DIR)/$(LIBNAME_SO_LN); \
|
|
cat .slog; \
|
|
else echo " [failed]"; \
|
|
cat .slog; \
|