Initial import.
This commit is contained in:
parent
534d585c37
commit
2e2ec7cbf5
@ -1 +1,2 @@
|
||||
libkml-0_6_1-2_fc10:HEAD:libkml-0.6.1-2.fc10.src.rpm:1236446111
|
||||
libkml-0_6_1-3_fc11:HEAD:libkml-0.6.1-3.fc11.src.rpm:1239553153
|
||||
|
13
libkml-0.6.1.configure_ac.patch
Normal file
13
libkml-0.6.1.configure_ac.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- libkml-0.6.1.org/configure.ac 2009-04-13 09:24:15.041537747 +0530
|
||||
+++ libkml-0.6.1/configure.ac 2009-04-13 09:25:24.670599502 +0530
|
||||
@@ -72,8 +72,8 @@
|
||||
AC_CHECK_PROG(SWIG, swig, swig)
|
||||
if test "x$SWIG" != x; then
|
||||
SWIG_VERSION=`swig -version 2>&1|grep Version|cut -d" " -f3`
|
||||
- if test $SWIG_VERSION != 1.3.35; then
|
||||
- AC_MSG_WARN([You have SWIG $SWIG_VERSION installed, but libkml requires SWIG 1.3.35. The bindings will not be built.])
|
||||
+ if test $SWIG_VERSION >= 1.3.35; then
|
||||
+ AC_MSG_WARN([You have SWIG have $SWIG_VERSION installed, but libkml requires greater then SWIG 1.3.35. The bindings will not be built.])
|
||||
SWIG=
|
||||
fi
|
||||
fi
|
17
libkml.spec
17
libkml.spec
@ -3,15 +3,15 @@
|
||||
|
||||
Name: libkml
|
||||
Version: 0.6.1
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: A KML library written in C++ with bindings to other languagues
|
||||
|
||||
Group: Development/Libraries
|
||||
License: BSD
|
||||
URL: http://code.google.com/p/%{name}/
|
||||
Source0: http://%{name}.googlecode.com/files/%{name}-%{version}.tar.gz
|
||||
#Patch0: libkml-string.patch
|
||||
Patch1: libkml-third_party_removal.diff
|
||||
Patch0: libkml-third_party_removal.diff
|
||||
Patch1: libkml-0.6.1.configure_ac.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
# requires swig >= 1.3.35
|
||||
@ -40,8 +40,8 @@ developing applications that use %{name}.
|
||||
%prep
|
||||
%setup -q
|
||||
rm -rf third_party
|
||||
%patch1 -p0 -b .third_party
|
||||
#%patch0 -p1 -b .string
|
||||
%patch0 -p0 -b .third_party
|
||||
%patch1 -p1 -b .configure_ac
|
||||
|
||||
%build
|
||||
autoreconf -fi
|
||||
@ -100,8 +100,8 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/libkml/*.so.*
|
||||
%{python_sitearch}/*.so
|
||||
%{python_sitearch}/*.py
|
||||
%{python_sitearch}/*.pyc
|
||||
%{python_sitearch}/*.pyo
|
||||
#%{python_sitearch}/*.pyc
|
||||
#%{python_sitearch}/*.pyo
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
@ -111,6 +111,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/libkml/*.so
|
||||
|
||||
%changelog
|
||||
* Sun Apr 12 2009 Rakesh Pandit <rakesh@fedoraproject.org> 0.6.1-3
|
||||
- libkml-0.6.1.configure_ac.patch patch for swig > 1.3.35
|
||||
|
||||
* Sat Mar 07 2009 Rakesh Pandit <rakesh@fedoraproject.org> 0.6.1-2
|
||||
- updated to 0.6.1
|
||||
- libkml-third_party_removal.diff Removes third part dependency
|
||||
|
Loading…
Reference in New Issue
Block a user