Update to 1.9.3

This commit is contained in:
Mattia Verga 2022-01-06 17:09:20 +01:00
parent 0bbfca4208
commit c3ed2b1cb2
5 changed files with 13 additions and 64 deletions

1
.gitignore vendored
View File

@ -23,3 +23,4 @@ libindi0_0.6.tar.gz
/indi-1.8.5.tar.gz
/indi-1.8.6.tar.gz
/indi-1.9.0.tar.gz
/indi-1.9.3.tar.gz

View File

@ -1,46 +0,0 @@
diff --git a/drivers/agent/agent_imager.cpp b/drivers/agent/agent_imager.cpp
index a95e188..29091f0 100644
--- a/drivers/agent/agent_imager.cpp
+++ b/drivers/agent/agent_imager.cpp
@@ -17,12 +17,12 @@
Boston, MA 02110-1301, USA.
*******************************************************************************/
+#include <memory>
#include "agent_imager.h"
#include "indistandardproperty.h"
#include <cstring>
#include <algorithm>
-#include <memory>
#include "group.h"
diff --git a/drivers/agent/group.cpp b/drivers/agent/group.cpp
index 4597178..b1b5a7d 100644
--- a/drivers/agent/group.cpp
+++ b/drivers/agent/group.cpp
@@ -18,6 +18,7 @@
*******************************************************************************/
#include "group.h"
+#include <memory>
#include "agent_imager.h"
#include <iomanip>
#include <sstream>
diff --git a/examples/tutorial_eight/simple_spectrograph.cpp b/examples/tutorial_eight/simple_spectrograph.cpp
index 8bedef0..3e8ab1d 100644
--- a/examples/tutorial_eight/simple_spectrograph.cpp
+++ b/examples/tutorial_eight/simple_spectrograph.cpp
@@ -20,9 +20,10 @@
refer to the INDI Generic Spectrograph driver template in INDI SVN (under 3rdparty).
*/
+#include <memory>
+
#include "simple_spectrograph.h"
-#include <memory>
/* Macro shortcut to Spectrograph temperature value */
#define currentSpectrographTemperature TemperatureN[0].value

View File

@ -1,7 +0,0 @@
diff -ur libindi-1.7.2/drivers/weather/99-vantage.rules libindi-1.7.2.rules/drivers/weather/99-vantage.rules
--- libindi-1.7.2/drivers/weather/99-vantage.rules 2018-04-22 21:52:30.000000000 +0200
+++ libindi-1.7.2.rules/drivers/weather/99-vantage.rules 2018-06-21 13:21:29.024905884 +0200
@@ -1,2 +1,2 @@
-SUBSYSTEMS=="usb", ATTRS{idVendor}=="10c4", ATTRS{idProduct}=="ea60", GROUP="plugdev", MODE="0666", SYMLINK+="vantage"
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="10c4", ATTRS{idProduct}=="ea60", TAG+="uaccess", SYMLINK+="vantage"

View File

@ -6,12 +6,11 @@
# Define boolean to quickly set option and dependencies for
# unit tests
# FIXME no unit tests are currently found
%global build_tests 0
%global build_tests 1
Name: libindi
Version: 1.9.0
Release: 2%{?dist}
Version: 1.9.3
Release: 1%{?dist}
Summary: Instrument Neutral Distributed Interface
License: LGPLv2+ and GPLv2+
@ -20,9 +19,7 @@ License: LGPLv2+ and GPLv2+
%forgemeta -i
URL: http://www.indilib.org
Source0: %{forgesource}
Patch0: libindi-uaccess.patch
Patch1: %{name}-gcc11.patch
Source0: %{forgesource}
BuildRequires: cmake
BuildRequires: libfli-devel
@ -86,8 +83,7 @@ Static library needed to develop a %{name} application
%prep
%forgesetup
%patch0 -p1
%patch1 -p1
# For Fedora we want to put udev rules in %%{_udevrulesdir}
sed -i 's|/lib/udev/rules.d|%{_udevrulesdir}|g' CMakeLists.txt
chmod -x drivers/telescope/pmc8driver.h
@ -111,7 +107,7 @@ chmod -x drivers/telescope/pmc8driver.cpp
%check
%if 0%{?build_tests}
%ctest
%ctest --test-dir test
%endif
@ -136,6 +132,11 @@ chmod -x drivers/telescope/pmc8driver.cpp
%{_libdir}/*.a
%changelog
* Thu Jan 06 2022 Mattia Verga <mattia.verga@protonmail.com> - 1.9.3-1
- Upgrade to 1.9.3
- Remove unneeded patches
- Fix and enable tests
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - Packaging variables read or set by %forgemeta
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (indi-1.9.0.tar.gz) = 7b02afb24bb2b71a7384c045af6654bb1e19f9b0fe525b31ad0ff3ecc5f1c4b9d53e4f9af225ae3845bd17d44cb7cb2274a72e331498828a2098a9984488b28e
SHA512 (indi-1.9.3.tar.gz) = d0c1b17f75a25e546261cabe644420dca155672d9223eaf48fad7ed5bbc3fcf80784df1ff21c5edded0f80e0c5ef61303892afa597b611dfd3f57a1a113be5f7