Fix missing #includes for gcc-11

This commit is contained in:
Jeff Law 2020-12-04 09:28:50 -07:00
parent b850779ad8
commit 9aafbb6f98
2 changed files with 52 additions and 1 deletions

46
libindi-gcc11.patch Normal file
View File

@ -0,0 +1,46 @@
diff --git a/drivers/agent/agent_imager.cpp b/drivers/agent/agent_imager.cpp
index a95e188..29091f0 100644
--- a/drivers/agent/agent_imager.cpp
+++ b/drivers/agent/agent_imager.cpp
@@ -17,12 +17,12 @@
Boston, MA 02110-1301, USA.
*******************************************************************************/
+#include <memory>
#include "agent_imager.h"
#include "indistandardproperty.h"
#include <cstring>
#include <algorithm>
-#include <memory>
#include "group.h"
diff --git a/drivers/agent/group.cpp b/drivers/agent/group.cpp
index 4597178..b1b5a7d 100644
--- a/drivers/agent/group.cpp
+++ b/drivers/agent/group.cpp
@@ -18,6 +18,7 @@
*******************************************************************************/
#include "group.h"
+#include <memory>
#include "agent_imager.h"
#include <iomanip>
#include <sstream>
diff --git a/examples/tutorial_eight/simple_spectrograph.cpp b/examples/tutorial_eight/simple_spectrograph.cpp
index 8bedef0..3e8ab1d 100644
--- a/examples/tutorial_eight/simple_spectrograph.cpp
+++ b/examples/tutorial_eight/simple_spectrograph.cpp
@@ -20,9 +20,10 @@
refer to the INDI Generic Spectrograph driver template in INDI SVN (under 3rdparty).
*/
+#include <memory>
+
#include "simple_spectrograph.h"
-#include <memory>
/* Macro shortcut to Spectrograph temperature value */
#define currentSpectrographTemperature TemperatureN[0].value

View File

@ -2,7 +2,7 @@
Name: libindi
Version: 1.8.6
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Instrument Neutral Distributed Interface
License: LGPLv2+ and GPLv2+
@ -13,6 +13,7 @@ License: LGPLv2+ and GPLv2+
URL: http://www.indilib.org
Source0: %{forgesource}
Patch0: libindi-uaccess.patch
Patch1: %{name}-gcc11.patch
BuildRequires: cmake
BuildRequires: libfli-devel
@ -63,6 +64,7 @@ Static library needed to develop a %{name} application
%prep
%forgesetup
%patch0 -p1
%patch1 -p1
# For Fedora we want to put udev rules in %{_udevrulesdir}
sed -i 's|/lib/udev/rules.d|%{_udevrulesdir}|g' CMakeLists.txt
chmod -x drivers/telescope/pmc8driver.h
@ -103,6 +105,9 @@ chmod -x drivers/telescope/pmc8driver.cpp
%{_libdir}/*.a
%changelog
* Fri Dec 04 2020 Jeff Law <law@redhat.com> - 1.8.6-2
- Fix missing #includes for gcc-11
* Mon Aug 24 2020 Sergio Pascual <sergiopr@fedoraproject.org> - 1.8.6-1
- New upstream source (1.8.6)