Patch stime in arm (bz#1799588)

This commit is contained in:
Sergio Pascual 2020-03-02 00:43:42 +01:00
parent ae4c9b6b9f
commit 73402fbec5
2 changed files with 44 additions and 1 deletions

View File

@ -0,0 +1,37 @@
From 0cc0e24260c0d71da43550e3e8c962f8d181f2d4 Mon Sep 17 00:00:00 2001
From: Jasem Mutlaq <mutlaqja@ikarustech.com>
Date: Mon, 24 Feb 2020 09:55:08 +0300
Subject: [PATCH] Disable stime on arm Fixes #1090
---
libs/indibase/inditelescope.cpp | 17 -----------------
1 file changed, 17 deletions(-)
diff --git a/libs/indibase/inditelescope.cpp b/libs/indibase/inditelescope.cpp
index 969d9dae7..ba657053c 100644
--- a/libs/indibase/inditelescope.cpp
+++ b/libs/indibase/inditelescope.cpp
@@ -1684,23 +1684,6 @@ bool Telescope::processTimeInfo(const char *utc, const char *offset)
IUSaveText(&TimeT[1], offset);
TimeTP.s = IPS_OK;
IDSetText(&TimeTP, nullptr);
-
- // 2018-04-20 JM: Update system time on ARM architecture.
-#ifdef __arm__
-#ifdef __linux__
- struct tm utm;
- if (strptime(utc, "%Y-%m-%dT%H:%M:%S", &utm))
- {
- time_t raw_time = mktime(&utm);
- time_t now_time;
- time(&now_time);
- // Only sync if difference > 30 seconds
- if (labs(now_time - raw_time) > 30)
- stime(&raw_time);
- }
-#endif
-#endif
-
return true;
}
else

View File

@ -1,6 +1,6 @@
Name: libindi
Version: 1.8.1
Release: 2%{?dist}
Release: 3%{?dist}
Summary: Instrument Neutral Distributed Interface
License: LGPLv2+ and GPLv2+
@ -9,6 +9,8 @@ License: LGPLv2+ and GPLv2+
URL: http://www.indilib.org
Source0: libindi-%{version}.tar.gz
Patch0: libindi-uaccess.patch
# https://github.com/indilib/indi/issues/1090
Patch1: https://github.com/indilib/indi/commit/0cc0e24260c0d71da43550e3e8c962f8d181f2d4.patch
# Generated from git checkout using libindi-generate-tarball.sh
BuildRequires: cmake
@ -60,6 +62,7 @@ Static library needed to develop a %{name} application
%prep
%setup -q -n %{name}-%{version}
%patch0 -p1
%patch1 -p1
# For Fedora we want to put udev rules in %{_udevrulesdir}
sed -i 's|/lib/udev/rules.d|%{_udevrulesdir}|g' CMakeLists.txt
chmod -x drivers/telescope/lx200fs2.h
@ -95,6 +98,9 @@ make install DESTDIR=%{buildroot}
%{_libdir}/*.a
%changelog
* Sun Mar 01 2020 Sergio Pascual <sergiopr@fedoraproject.org> 1.8.1-3
- Patch stime in arm (bz#1799588)
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild