Packaging variables read or set by %forgemeta

forgeurl:          https://github.com/indilib/indi
  forgesource:       https://github.com/indilib/indi/archive/v1.8.5/indi-1.8.5.tar.gz
  forgesetupargs:    -n indi-1.8.5
  archivename:       indi-1.8.5
  archiveext:        tar.gz
  archiveurl:        https://github.com/indilib/indi/archive/v1.8.5/indi-1.8.5.tar.gz
  topdir:            indi-1.8.5
  extractdir:        indi-1.8.5
  repo:              indi
  scm:               git
  version:           1.8.5
  dist:              .fc33
  (snapshot date is either manually supplied or computed once %{_sourcedir}/%{archivename}.%{archiveext} is available)
New upstream source (1.8.5)
This commit is contained in:
Sergio Pascual 2020-07-09 18:28:22 +02:00
parent 4c77fedae7
commit 03a58c9178
5 changed files with 15 additions and 59 deletions

1
.gitignore vendored
View File

@ -20,3 +20,4 @@ libindi0_0.6.tar.gz
/libindi-1.7.4.tar.gz
/libindi-1.7.7.tar.gz
/libindi-1.8.1.tar.gz
/indi-1.8.5.tar.gz

View File

@ -1,37 +0,0 @@
From 0cc0e24260c0d71da43550e3e8c962f8d181f2d4 Mon Sep 17 00:00:00 2001
From: Jasem Mutlaq <mutlaqja@ikarustech.com>
Date: Mon, 24 Feb 2020 09:55:08 +0300
Subject: [PATCH] Disable stime on arm Fixes #1090
---
libs/indibase/inditelescope.cpp | 17 -----------------
1 file changed, 17 deletions(-)
diff --git a/libs/indibase/inditelescope.cpp b/libs/indibase/inditelescope.cpp
index 969d9dae7..ba657053c 100644
--- a/libs/indibase/inditelescope.cpp
+++ b/libs/indibase/inditelescope.cpp
@@ -1684,23 +1684,6 @@ bool Telescope::processTimeInfo(const char *utc, const char *offset)
IUSaveText(&TimeT[1], offset);
TimeTP.s = IPS_OK;
IDSetText(&TimeTP, nullptr);
-
- // 2018-04-20 JM: Update system time on ARM architecture.
-#ifdef __arm__
-#ifdef __linux__
- struct tm utm;
- if (strptime(utc, "%Y-%m-%dT%H:%M:%S", &utm))
- {
- time_t raw_time = mktime(&utm);
- time_t now_time;
- time(&now_time);
- // Only sync if difference > 30 seconds
- if (labs(now_time - raw_time) > 30)
- stime(&raw_time);
- }
-#endif
-#endif
-
return true;
}
else

View File

@ -1,12 +0,0 @@
diff -ur libindi-0.9.8/libs/indibase/alignment/CMakeLists.txt libindi-0.9.8.fix/libs/indibase/alignment/CMakeLists.txt
--- libindi-0.9.8/libs/indibase/alignment/CMakeLists.txt 2014-03-30 17:20:23.000000000 +0200
+++ libindi-0.9.8.fix/libs/indibase/alignment/CMakeLists.txt 2014-04-23 23:58:32.619150626 +0200
@@ -62,7 +62,7 @@
add_library(AlignmentClient ${AlignmentClient_SRCS})
set_target_properties(AlignmentClient PROPERTIES OUTPUT_NAME indiAlignmentClient)
-install(TARGETS AlignmentClient ARCHIVE DESTINATION ${LIB_DESTINATION})
+install(TARGETS AlignmentClient ARCHIVE DESTINATION ${LIB_DESTINATION} LIBRARY DESTINATION ${LIB_DESTINATION})
##################################################
############ LoaderCLient test program ###########

View File

@ -1,17 +1,19 @@
%global forgeurl https://github.com/indilib/indi/
Name: libindi
Version: 1.8.1
Release: 4%{?dist}
Version: 1.8.5
Release: 1%{?dist}
Summary: Instrument Neutral Distributed Interface
License: LGPLv2+ and GPLv2+
# See COPYRIGHT file for a description of the licenses and files covered
%forgemeta -i
URL: http://www.indilib.org
Source0: libindi-%{version}.tar.gz
Source0: %{forgesource}
Patch0: libindi-uaccess.patch
# https://github.com/indilib/indi/issues/1090
Patch1: https://github.com/indilib/indi/commit/0cc0e24260c0d71da43550e3e8c962f8d181f2d4.patch
# Generated from git checkout using libindi-generate-tarball.sh
BuildRequires: cmake
BuildRequires: libfli-devel
@ -60,13 +62,12 @@ Requires: %{name}-libs%{?_isa} = %{version}-%{release}
Static library needed to develop a %{name} application
%prep
%setup -q -n %{name}-%{version}
%forgesetup
%patch0 -p1
%patch1 -p1
# For Fedora we want to put udev rules in %{_udevrulesdir}
sed -i 's|/lib/udev/rules.d|%{_udevrulesdir}|g' CMakeLists.txt
chmod -x drivers/telescope/lx200fs2.h
chmod -x drivers/telescope/lx200fs2.cpp
chmod -x drivers/telescope/pmc8driver.h
chmod -x drivers/telescope/pmc8driver.cpp
%build
# This package tries to mix and match PIE and PIC which is wrong and will
@ -103,6 +104,9 @@ make install DESTDIR=%{buildroot}
%{_libdir}/*.a
%changelog
* Thu Jul 09 2020 Sergio Pascual <sergiopr@fedoraproject.org> 1.8.5-1
- New upstream source (1.8.5)
* Wed Jul 08 2020 Jeff Law <law@redhat.com> 1.8.1-4
- Disable LTO

View File

@ -1 +1 @@
SHA512 (libindi-1.8.1.tar.gz) = adc6d5b88fa37e1104ee87f5c4c06a69f79f46a9fcccc03deb5b9761767ff33b01e8bb927b72aa5c2337655181c9eb484adffb91282aa7e8c820020c98276c2d
SHA512 (indi-1.8.5.tar.gz) = 4c583f7ff0d96d787c7d035e23074f42db3f836ec74a0a7a1595574ae2d32d56234b16abddabacaf9bd5a10cb88c6c37994aafcef86d65a665b2bceae87446f9