50e7fc5f47
- replace %makeinstall with %{__make} DESTDIR=%{buildroot} install - build python bindings, merging python-gpod package from extras - make %setup quiet - patch to fixup building of the python docs, BR libxslt - update license tag
18 lines
930 B
Diff
18 lines
930 B
Diff
--- bindings/python/Makefile.in~ 2007-06-23 01:51:57.000000000 -0400
|
|
+++ bindings/python/Makefile.in 2007-07-11 16:58:38.000000000 -0400
|
|
@@ -752,9 +752,11 @@
|
|
|
|
@HAVE_PYTHON_TRUE@gpod_doc.i: $(srcdir)/gpod_doc.i.in $(srcdir)/gtkdoc-to-swig.xsl
|
|
@HAVE_PYTHON_TRUE@ cat $< > $@
|
|
-@ENABLE_GTK_DOC_TRUE@@HAVE_PYTHON_TRUE@ -for xml in $(top_srcdir)/docs/reference/xml/*.xml; do \
|
|
-@ENABLE_GTK_DOC_TRUE@@HAVE_PYTHON_TRUE@ xsltproc $(srcdir)/gtkdoc-to-swig.xsl $$xml; \
|
|
-@ENABLE_GTK_DOC_TRUE@@HAVE_PYTHON_TRUE@ done >> $@
|
|
+@HAVE_PYTHON_TRUE@ -if test -x "`which xsltproc 2>/dev/null`"; then \
|
|
+@HAVE_PYTHON_TRUE@ for xml in $(top_srcdir)/docs/reference/xml/*.xml; do \
|
|
+@HAVE_PYTHON_TRUE@ xsltproc $(srcdir)/gtkdoc-to-swig.xsl $$xml; \
|
|
+@HAVE_PYTHON_TRUE@ done >> $@; \
|
|
+@HAVE_PYTHON_TRUE@ fi
|
|
|
|
@HAVE_PYTHON_TRUE@gpod_wrap.c: $(SWIG_INTERFACES) $(nodist_gpod_PYTHON)
|
|
@HAVE_PYTHON_TRUE@ $(SWIG) -python $(INCLUDES) -o $@ $<
|