Update libgpod to 0.7.95

This commit is contained in:
Nathaniel McCallum 2010-09-30 10:07:51 -04:00
parent ef274f3d16
commit efb6c39d1c
5 changed files with 7 additions and 120 deletions

1
.gitignore vendored
View File

@ -3,3 +3,4 @@
*.tar.gz
/.build*.log
/libgpod-*/
/libgpod-0.7.95.tar.gz

View File

@ -1,50 +0,0 @@
From d82d8c84ba9f1d0ec90ea3a252e614da01a2df9a Mon Sep 17 00:00:00 2001
From: Chow Loong Jin <hyperair@ubuntu.com>
Date: Sat, 4 Sep 2010 16:51:35 +0200
Subject: [PATCH 1/2] [mono] fix dll name in dllmap
Correct the name of the dllmap from "libgpod" to "gpod", and remove
quotes from .so name
---
bindings/mono/libgpod-sharp/Makefile.am | 2 +-
.../mono/libgpod-sharp/libgpod-sharp.dll.config.in | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/bindings/mono/libgpod-sharp/Makefile.am b/bindings/mono/libgpod-sharp/Makefile.am
index 5663163..b3cd8c4 100644
--- a/bindings/mono/libgpod-sharp/Makefile.am
+++ b/bindings/mono/libgpod-sharp/Makefile.am
@@ -18,7 +18,7 @@ SOURCES = \
Thumbnail.cs \
Track.cs
-dlname := $(shell grep "^dlname=" $(top_builddir)/src/libgpod.la | sed "s/^dlname=\(.*\)/\1/g")
+dlname := $(shell grep "^dlname=" $(top_builddir)/src/libgpod.la | sed "s/^dlname='\(.*\)'/\1/g")
libgpod-sharp.dll.config: $(top_srcdir)/bindings/mono/libgpod-sharp/libgpod-sharp.dll.config.in
sed "s/@DLNAME@/$(dlname)/g" $< >$@
diff --git a/bindings/mono/libgpod-sharp/libgpod-sharp.dll.config.in b/bindings/mono/libgpod-sharp/libgpod-sharp.dll.config.in
index 01ad69a..cfa13ad 100644
--- a/bindings/mono/libgpod-sharp/libgpod-sharp.dll.config.in
+++ b/bindings/mono/libgpod-sharp/libgpod-sharp.dll.config.in
@@ -1,4 +1,4 @@
<configuration>
- <dllmap dll="libgpod" target="@DLNAME@"/>
+ <dllmap dll="gpod" target="@DLNAME@"/>
</configuration>
--
1.7.2.2
diff -up libgpod-0.7.94/bindings/mono/libgpod-sharp/Makefile.in.orig libgpod-0.7.94/bindings/mono/libgpod-sharp/Makefile.in
--- libgpod-0.7.94/bindings/mono/libgpod-sharp/Makefile.in.orig 2010-08-31 17:10:47.000000000 -0400
+++ libgpod-0.7.94/bindings/mono/libgpod-sharp/Makefile.in 2010-09-05 18:45:02.540553999 -0400
@@ -301,7 +301,7 @@ SOURCES = \
Thumbnail.cs \
Track.cs
-dlname := $(shell grep "^dlname=" $(top_builddir)/src/libgpod.la | sed "s/^dlname=\(.*\)/\1/g")
+dlname := $(shell grep "^dlname=" $(top_builddir)/src/libgpod.la | sed "s/^dlname='\(.*\)'/\1/g")
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libgpod-sharp.pc
EXTRAS = \

View File

@ -1,61 +0,0 @@
From ed82695ebbc47de9f66e3cf7e78a71b16b32d58e Mon Sep 17 00:00:00 2001
From: Christophe Fergeau <teuf@gnome.org>
Date: Sat, 4 Sep 2010 17:59:37 +0200
Subject: [PATCH 2/2] Revert "Fix for creation of blank playlist on 80GB ipod video"
This reverts commit 1252bc0e18c396b2cb5e1bd5369f17403ca181aa.
On an iPod Video with 1.2.1 firmware:
- With 1252bc0, no songs, no videos, no playlists at
all (except the On-the-go playlist)
- Before 1252bc0, songs/videos/playlists are visible, but
there is an additional unnamed blank music playlist.
With latest firmware, none of these issues show up. The blank playlist
bug is better than the empty ipod bug, so let's revert to the earlier
behaviour and if someone encounters the blank playlist issue, we just
have to remember to tell him to update his firmware. For the record,
it seems only writing 4 mhsds on an iPod Video with firmware 1.2.1
avoids these 2 issues too.
---
src/itdb_itunesdb.c | 17 ++++++++---------
1 files changed, 8 insertions(+), 9 deletions(-)
diff --git a/src/itdb_itunesdb.c b/src/itdb_itunesdb.c
index e473fb2..5041676 100644
--- a/src/itdb_itunesdb.c
+++ b/src/itdb_itunesdb.c
@@ -5761,15 +5761,6 @@ static gboolean itdb_write_file_internal (Itdb_iTunesDB *itdb,
goto err;
}
- /* write albums (mhsd type 4) */
- if (!write_mhsd_albums (fexp)) {
- g_set_error (&fexp->error,
- ITDB_FILE_ERROR,
- ITDB_FILE_ERROR_ITDB_CORRUPT,
- _("Error writing list of albums (mhsd type 4)"));
- goto err;
- }
-
/* write special podcast version mhsd (mhsd type 3) */
if (!fexp->error && !write_mhsd_playlists (fexp, 3)) {
g_set_error (&fexp->error,
@@ -5787,6 +5778,14 @@ static gboolean itdb_write_file_internal (Itdb_iTunesDB *itdb,
goto err;
}
+ /* write albums (mhsd type 4) */
+ if (!write_mhsd_albums (fexp)) {
+ g_set_error (&fexp->error,
+ ITDB_FILE_ERROR,
+ ITDB_FILE_ERROR_ITDB_CORRUPT,
+ _("Error writing list of albums (mhsd type 4)"));
+ goto err;
+ }
/* write artists (mhsd type 8) */
if (!fexp->error && !write_mhsd_artists (fexp)) {
g_set_error (&fexp->error,
--
1.7.2.2

View File

@ -2,16 +2,12 @@
Summary: Library to access the contents of an iPod
Name: libgpod
Version: 0.7.94
Version: 0.7.95
Release: 1%{?dist}
License: LGPLv2+
Group: System Environment/Libraries
URL: http://www.gtkpod.org/libgpod.html
Source0: http://downloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
# http://gtkpod.git.sourceforge.net/git/gitweb.cgi?p=gtkpod/libgpod;a=commitdiff;h=d82d8c8
Patch0: 0001-mono-fix-dll-name-in-dllmap.patch
# http://gtkpod.git.sourceforge.net/git/gitweb.cgi?p=gtkpod/libgpod;a=commitdiff;h=ed82695
Patch1: 0002-Revert-Fix-for-creation-of-blank-playlist-on-80GB-ip.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: docbook-style-xsl
BuildRequires: glib2-devel
@ -110,8 +106,6 @@ libgpod-sharp.
%prep
%setup -q
%patch0 -p1
%patch1 -p1
# remove execute perms on the python examples as they'll be installed in %%doc
chmod -x bindings/python/examples/*.py
@ -183,8 +177,11 @@ rm -rf %{buildroot}
%defattr(-, root, root, 0755)
%{_libdir}/pkgconfig/%{name}-sharp.pc
%changelog
* Wed Sep 29 2010 Nathaniel McCallum <nathaniel@natemccallum.com> - 0.7.95-1
- Update to 0.7.95
- Drop upstreamed patches
* Sat Sep 04 2010 Todd Zullinger <tmz@pobox.com> - 0.7.94-1
- Update to 0.7.94
- Add mono subpackage (#630181)

View File

@ -1 +1 @@
cc9802ca6356b3ac5e152afb90a121d6 libgpod-0.7.94.tar.gz
8a761f678677a425436107cbd87aecf3 libgpod-0.7.95.tar.gz