Update to 0.7.93

- Drop upstreamed mount-dir location patch
- Fix temp mount dir configure option typo
- Drop duplicate libimobiledevice-devel BR
- Remove pointless %{__$command} macros
This commit is contained in:
Todd Zullinger 2010-06-15 15:45:34 +00:00
parent cb181fe6f4
commit c9c56a2d8b
4 changed files with 23 additions and 108 deletions

View File

@ -1 +1 @@
libgpod-0.7.91.tar.gz
libgpod-0.7.93.tar.gz

View File

@ -1,85 +0,0 @@
From bd44ab460a2f0d531df0b6b34176efaf6a0641ac Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Thu, 4 Mar 2010 14:47:17 +0000
Subject: [PATCH] Make the temporary mount point configurable
Distributions that use SELinux cannot have libgpod's callouts
mount devices as they wish in random location on the disk.
Instead, we'd use a specific directory, so that the SELinux
rules could be amended for that case.
This patch does not change the default location of the temporary
directory.
---
configure.ac | 15 +++++++++++++++
tools/Makefile.am | 9 +++++++++
tools/generic-callout.c | 2 +-
3 files changed, 25 insertions(+), 1 deletions(-)
diff --git a/configure.ac b/configure.ac
index 14d7135..1d03dcb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -203,6 +203,20 @@ AC_ARG_ENABLE(udev,
AM_CONDITIONAL(USE_UDEV, test x"$enable_udev" = xyes)
AC_SUBST([udevdir], [/lib/udev])
+dnl ***********************************************************************
+dnl * for the udev and hal callouts, we need a temporary directory to
+dnl * mount the iPod to write out its extended info file.
+dnl ***********************************************************************
+
+temp_mount_dir="/tmp/"
+AC_ARG_WITH(temp_mount_dir, AC_HELP_STRING([--with-mount-dir=DIR],
+ [Directory where HAL/udev will create a sub-directory to mount iPods]),,
+ with_temp_mount_dir="$temp_mount_dir")
+TMPMOUNTDIR="$with_temp_mount_dir"
+AC_SUBST(TMPMOUNTDIR)
+AH_TEMPLATE([TMPMOUNTDIR], [Directory where HAL/udev will create a sub-directory to mount iPods])
+AC_DEFINE_UNQUOTED(TMPMOUNTDIR, "$with_temp_mount_dir", [Directory where HAL/udev will create a sub-directory to mount iPods])
+
dnl **************************************************
dnl * TagLib is only used by test-rebuild-db
dnl **************************************************
@@ -393,6 +407,7 @@ Configuration for $PACKAGE $VERSION :
Python bindings ..........: $with_python
PyGObject support ........: $have_pygobject
iPhone/iPod Touch support.: $enable_libimobiledevice
+ Temporary mount directory.: $with_temp_mount_dir
Now type 'make' to build $PACKAGE $VERSION,
and then 'make install' for installation.
diff --git a/tools/Makefile.am b/tools/Makefile.am
index e6334cd..2f8553e 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -90,3 +90,12 @@ ipod_time_sync_CFLAGS=$(SGUTILS_CFLAGS) $(LIBGPOD_CFLAGS)
ipod_time_sync_LDADD=$(SGUTILS_LIBS) $(LIBGPOD_LIBS)
endif
+if USE_UDEV
+install-data-hook:
+ $(MKDIR_P) "$(DESTDIR)$(MOUNTDIR)"
+endif
+if HAVE_HAL
+install-data-hook:
+ $(MKDIR_P) "$(DESTDIR)$(MOUNTDIR)"
+endif
+
diff --git a/tools/generic-callout.c b/tools/generic-callout.c
index b45f6da..b8b617e 100644
--- a/tools/generic-callout.c
+++ b/tools/generic-callout.c
@@ -560,7 +560,7 @@ static char *mount_ipod (const char *dev_path, const char *fstype)
char *tmpname;
int result;
- filename = g_build_filename (g_get_tmp_dir (), "ipodXXXXXX", NULL);
+ filename = g_build_filename (TMPMOUNTDIR, "ipodXXXXXX", NULL);
if (filename == NULL) {
return NULL;
}
--
1.6.6.1

View File

@ -2,8 +2,8 @@
Summary: Library to access the contents of an iPod
Name: libgpod
Version: 0.7.91
Release: 3%{?dist}
Version: 0.7.93
Release: 1%{?dist}
License: LGPLv2+
Group: System Environment/Libraries
URL: http://www.gtkpod.org/libgpod.html
@ -25,14 +25,9 @@ BuildRequires: python-devel
BuildRequires: python-mutagen
BuildRequires: sg3_utils-devel
BuildRequires: sqlite-devel
BuildRequires: libimobiledevice-devel
BuildRequires: swig
Requires: udev
# See http://www.redhat.com/archives/fedora-selinux-list/2009-January/msg00005.html
Patch0: 0001-Make-the-temporary-mount-point-configurable.patch
BuildRequires: automake autoconf libtool intltool
%description
Libgpod is a library to access the contents of an iPod. It supports playlists,
smart playlists, playcounts, ratings, podcasts, album artwork, photos, etc.
@ -84,30 +79,27 @@ libgpod library.
%prep
%setup -q
%patch0 -p1 -b .mount-dir
autoreconf -f
# remove execute perms on the python examples as they'll be installed in %doc
%{__chmod} -x bindings/python/examples/*.py
chmod -x bindings/python/examples/*.py
%build
%configure --without-hal --enable-udev --with-mount-dir=%{_localstatedir}/run/libgpod
%{__make} %{?_smp_mflags}
%configure --without-hal --enable-udev --with-temp-mount-dir=%{_localstatedir}/run/%{name}
make %{?_smp_mflags}
%install
%{__rm} -rf %{buildroot}
%{__make} DESTDIR=%{buildroot} install
rm -rf %{buildroot}
make DESTDIR=%{buildroot} install
%find_lang %{name}
# remove Makefiles from the python examples dir
%{__rm} -rf bindings/python/examples/Makefile*
rm -rf bindings/python/examples/Makefile*
%{__mkdir_p} %{buildroot}/%{_localstatedir}/run/libgpod
%clean
%{__rm} -rf %{buildroot}
rm -rf %{buildroot}
%post -p /sbin/ldconfig
@ -119,15 +111,16 @@ autoreconf -f
%doc AUTHORS ChangeLog COPYING NEWS README*
%{_bindir}/*
%{_libdir}/*.so.*
%dir %{_localstatedir}/run/libgpod/
%dir %{_localstatedir}/run/%{name}
/lib/udev/iphone-set-info
/lib/udev/ipod-set-info
/lib/udev/rules.d/libgpod.rules
/lib/udev/rules.d/*.rules
%files devel
%defattr(-, root, root, 0755)
%{_includedir}/gpod-1.0/
%{_libdir}/pkgconfig/libgpod-1.0.pc
%{_libdir}/pkgconfig/%{name}-1.0.pc
%exclude %{_libdir}/*.a
%exclude %{_libdir}/*.la
%{_libdir}/*.so
@ -135,7 +128,7 @@ autoreconf -f
%files doc
%defattr(-, root, root, 0755)
%{_datadir}/gtk-doc/html/libgpod
%{_datadir}/gtk-doc/html/%{name}
%files -n python-gpod
@ -147,6 +140,13 @@ autoreconf -f
%changelog
* Tue Jun 15 2010 Todd Zullinger <tmz@pobox.com> - 0.7.93-1
- Update to 0.7.93
- Drop upstreamed mount-dir location patch
- Fix temp mount dir configure option typo
- Drop duplicate libimobiledevice-devel BR
- Remove pointless %%{__$command} macros
* Tue Apr 13 2010 Dan Horák <dan@danny.cz> - 0.7.91-3
- rebuilt for sg3_utils 1.29

View File

@ -1 +1 @@
172c35369a7013bbf84917b31be758f3 libgpod-0.7.91.tar.gz
7d8ce00d78de50cb2414260512201b46 libgpod-0.7.93.tar.gz