- update to 0.6.0

- apply a few upstream patches that just missed the release
This commit is contained in:
Todd Zullinger 2007-11-21 17:20:57 +00:00
parent 64706c6196
commit ac9f7f0613
7 changed files with 174 additions and 24 deletions

View File

@ -1 +1 @@
libgpod-0.5.2.tar.gz
libgpod-0.6.0.tar.gz

View File

@ -1,17 +0,0 @@
--- bindings/python/Makefile.in~ 2007-06-23 01:51:57.000000000 -0400
+++ bindings/python/Makefile.in 2007-07-11 16:58:38.000000000 -0400
@@ -752,9 +752,11 @@
@HAVE_PYTHON_TRUE@gpod_doc.i: $(srcdir)/gpod_doc.i.in $(srcdir)/gtkdoc-to-swig.xsl
@HAVE_PYTHON_TRUE@ cat $< > $@
-@ENABLE_GTK_DOC_TRUE@@HAVE_PYTHON_TRUE@ -for xml in $(top_srcdir)/docs/reference/xml/*.xml; do \
-@ENABLE_GTK_DOC_TRUE@@HAVE_PYTHON_TRUE@ xsltproc $(srcdir)/gtkdoc-to-swig.xsl $$xml; \
-@ENABLE_GTK_DOC_TRUE@@HAVE_PYTHON_TRUE@ done >> $@
+@HAVE_PYTHON_TRUE@ -if test -x "`which xsltproc 2>/dev/null`"; then \
+@HAVE_PYTHON_TRUE@ for xml in $(top_srcdir)/docs/reference/xml/*.xml; do \
+@HAVE_PYTHON_TRUE@ xsltproc $(srcdir)/gtkdoc-to-swig.xsl $$xml; \
+@HAVE_PYTHON_TRUE@ done >> $@; \
+@HAVE_PYTHON_TRUE@ fi
@HAVE_PYTHON_TRUE@gpod_wrap.c: $(SWIG_INTERFACES) $(nodist_gpod_PYTHON)
@HAVE_PYTHON_TRUE@ $(SWIG) -python $(INCLUDES) -o $@ $<

View File

@ -0,0 +1,34 @@
Index: ChangeLog
===================================================================
--- ChangeLog (revision 1792)
+++ ChangeLog (revision 1793)
@@ -1,3 +1,7 @@
+2007-11-16 Christophe Fergeau <teuf@gnome.org>
+
+ * src/itdb_device.c: fix typoes in iPod Touch model lists
+
2007-11-14 Christophe <teuf@gnome.org>
* src/itdb_itunesdb.c: get rid of local g_mkdir_with_parents copy
Index: src/itdb_device.c
===================================================================
--- src/itdb_device.c (revision 1792)
+++ src/itdb_device.c (revision 1793)
@@ -185,7 +185,7 @@
/* iPod touch G1 */
/* With touch screen */
{"A623", 8, ITDB_IPOD_MODEL_TOUCH_BLACK, ITDB_IPOD_GENERATION_TOUCH_1, 14},
- {"A627", 16, ITDB_IPOD_MODEL_NANO_SILVER, ITDB_IPOD_GENERATION_TOUCH_1, 28},
+ {"A627", 16, ITDB_IPOD_MODEL_TOUCH_BLACK, ITDB_IPOD_GENERATION_TOUCH_1, 28},
/* No known model number -- create a Device/SysInfo file with
@@ -257,7 +257,7 @@
N_("Video (1st Gen.)"),
N_("Video (2nd Gen.)"),
N_("Classic"),
- N_("Touch (Read-Only)"),
+ N_("Touch"),
N_("Unused"),
N_("Unused"),
NULL

View File

@ -0,0 +1,79 @@
Index: ChangeLog
===================================================================
--- ChangeLog (revision 1778)
+++ ChangeLog (revision 1785)
@@ -1,5 +1,21 @@
-====== libgpod 0.6.0 ======
+2007-11-14 Christophe <teuf@gnome.org>
+ * src/itdb_photoalbum.c: use g_list_remove all instead of an
+ inefficient combination of g_list_find + g_list_remove
+
+2007-11-14 Jorg Schuler <jcsjcs at users.sourceforge.net>
+
+ * src/itdb_photoalbum.c (itdb_photodb_photoalbum_remove): make
+ sure same photo isn't freed multiple times if it was added in an
+ album multiple times.
+
+2007-11-13 Christophe Fergeau <teuf@gnome.org>
+
+ * src/itdb_photoalbum.c: fix bug in itdb_photodb_photoalbum_remove,
+ when removing all the photos from the photodatabase, we were
+ erasing elements and iterating over the list at the same time,
+ which resulted in the function not working properly
+
2007-11-10 Christophe Fergeau <teuf@gnome.org>
* Makefile.am: add README.SysInfo to EXTRADIST
Index: src/itdb_photoalbum.c
===================================================================
--- src/itdb_photoalbum.c (revision 1778)
+++ src/itdb_photoalbum.c (revision 1785)
@@ -1,4 +1,4 @@
-/* Time-stamp: <2007-11-03 20:27:36 jcs>
+/*
|
| Copyright (C) 2002-2006 Jorg Schuler <jcsjcs at users sourceforge net>
| Part of the gtkpod project.
@@ -615,10 +615,7 @@
for (it = db->photoalbums; it != NULL; it = it->next)
{
Itdb_PhotoAlbum *_album = it->data;
- while (g_list_find (_album->members, photo))
- {
- _album->members = g_list_remove (_album->members, photo);
- }
+ _album->members = g_list_remove_all (_album->members, photo);
}
/* Remove the photo from the image list */
db->photos = g_list_remove (db->photos, photo);
@@ -678,8 +675,6 @@
Itdb_PhotoAlbum *album,
gboolean remove_pics)
{
- GList *it;
-
g_return_if_fail (db);
g_return_if_fail (album);
@@ -687,11 +682,16 @@
* and remove them from the database */
if (remove_pics)
{
- for (it = album->members; it != NULL; it = it->next )
+ /* we can't iterate over album->members because
+ itdb_photodb_remove_photo() modifies album->members in
+ a not easily predicable way (e.g. @photo may exist in the
+ album several times). Therefore we remove photos until
+ album->members is empty. */
+ while (album->members)
{
- Itdb_Artwork *photo = it->data;
- itdb_photodb_remove_photo (db, NULL, photo);
- }
+ Itdb_Artwork *photo = album->members->data;
+ itdb_photodb_remove_photo (db, NULL, photo);
+ }
}
db->photoalbums = g_list_remove (db->photoalbums, album);
itdb_photodb_photoalbum_free (album);

View File

@ -0,0 +1,40 @@
Index: ChangeLog
===================================================================
--- ChangeLog (revision 1796)
+++ ChangeLog (revision 1797)
@@ -1,3 +1,15 @@
+2007-11-17 Jorg Schuler <jcsjcs at users.sourceforge.net>
+
+ * src/itdb_playlist.c (itdb_splr_eval): track length in rules for
+ smart playlists was treated as seconds, but the iPod treats them
+ as milliseconds. If you told libgpod to create a smart playlist
+ with tracks less than 100 secs in length, but the life update of
+ the iPod would interpret that rule as "tracks less than 100 msec
+ in length", giving a vastly different result. Tested with iPod
+ Nano 1G and iPod nano Video (3G).
+
+ Requires corresponding fix in GUIs using this function.
+
2007-11-16 Christophe Fergeau <teuf@gnome.org>
* src/itdb_device.c: fix typoes in iPod Touch model lists
Index: src/itdb_playlist.c
===================================================================
--- src/itdb_playlist.c (revision 1796)
+++ src/itdb_playlist.c (revision 1797)
@@ -1,5 +1,4 @@
-/* Time-stamp: <2007-02-25 11:52:48 jcs>
-|
+/*
| Copyright (C) 2002-2005 Jorg Schuler <jcsjcs at users sourceforge net>
| Part of the gtkpod project.
|
@@ -424,7 +423,7 @@
handled = TRUE;
break;
case ITDB_SPLFIELD_TIME:
- intcomp = track->tracklen/1000;
+ intcomp = track->tracklen;
handled = TRUE;
break;
case ITDB_SPLFIELD_COMPILATION:

View File

@ -2,21 +2,26 @@
Summary: Library to access the contents of an iPod
Name: libgpod
Version: 0.5.2
Release: 2%{?dist}
Version: 0.6.0
Release: 1%{?dist}
License: LGPLv2+
Group: System Environment/Libraries
URL: http://www.gtkpod.org/libgpod.html
Source0: http://downloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
Patch0: libgpod-0.5.2-python-docs.patch
Patch0: libgpod-0.6.0-photoremove.patch
Patch1: libgpod-0.6.0-ipod-touch-typos.patch
Patch2: libgpod-0.6.0-spl-tracklen.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: glib2-devel
BuildRequires: gtk2-devel
BuildRequires: gettext
BuildRequires: hal-devel
BuildRequires: libxslt
BuildRequires: perl(XML::Parser)
BuildRequires: pygobject2-devel
Buildrequires: python-devel
Buildrequires: python-mutagen
Buildrequires: sg3_utils-devel
Buildrequires: swig
%description
@ -51,7 +56,9 @@ libgpod library.
%prep
%setup -q
%patch0 -p0 -b .pydocs
%patch0 -p0 -b .photoremove
%patch1 -p0 -b .ipod-touch-typos
%patch2 -p0 -b .spl-tracklen
# remove execute perms on the python examples as they'll be installed in %doc
%{__chmod} -x bindings/python/examples/*.py
@ -81,8 +88,11 @@ libgpod library.
%files -f %{name}.lang
%defattr(-, root, root, 0755)
%doc AUTHORS ChangeLog COPYING README
%doc AUTHORS ChangeLog COPYING README*
%{_bindir}/*
%{_libdir}/*.so.*
%{_libdir}/hal/*
%{_datadir}/hal/fdi/policy/20thirdparty/*.fdi
%files devel
@ -103,6 +113,10 @@ libgpod library.
%changelog
* Wed Nov 21 2007 Todd Zullinger <tmz@pobox.com> - 0.6.0-1
- update to 0.6.0
- apply a few upstream patches that just missed the release
* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 0.5.2-2
- Rebuild for build ID

View File

@ -1 +1 @@
e4f8d2a7be9512268267bfbe712fe9be libgpod-0.5.2.tar.gz
b44d8aee3f6610370b6faf61770c5f3c libgpod-0.6.0.tar.gz