- add patch for sg3_utils 1.26 and rebuild

This commit is contained in:
Dan Horák 2008-06-30 17:37:14 +00:00
parent f295049eab
commit 95f9e49a1f
2 changed files with 60 additions and 1 deletions

View File

@ -0,0 +1,54 @@
diff -Nru libgpod-0.6.0.orig/configure libgpod-0.6.0/configure
--- libgpod-0.6.0.orig/configure 2007-11-10 12:16:17.000000000 +0100
+++ libgpod-0.6.0/configure 2008-06-30 19:18:34.000000000 +0200
@@ -20204,13 +20204,13 @@
eval echo $libdir
)`
-{ echo "$as_me:$LINENO: checking for sg_ll_inquiry in -lsgutils" >&5
-echo $ECHO_N "checking for sg_ll_inquiry in -lsgutils... $ECHO_C" >&6; }
+{ echo "$as_me:$LINENO: checking for sg_ll_inquiry in -lsgutils2" >&5
+echo $ECHO_N "checking for sg_ll_inquiry in -lsgutils2... $ECHO_C" >&6; }
if test "${ac_cv_lib_sgutils_sg_ll_inquiry+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lsgutils $LIBS"
+LIBS="-lsgutils2 $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -20266,7 +20266,7 @@
{ echo "$as_me:$LINENO: result: $ac_cv_lib_sgutils_sg_ll_inquiry" >&5
echo "${ECHO_T}$ac_cv_lib_sgutils_sg_ll_inquiry" >&6; }
if test $ac_cv_lib_sgutils_sg_ll_inquiry = yes; then
- SGUTILS_LIBS="-lsgutils"; have_sgutils=yes
+ SGUTILS_LIBS="-lsgutils2"; have_sgutils=yes
else
have_sgutils=no
fi
diff -Nru libgpod-0.6.0.orig/configure.ac libgpod-0.6.0/configure.ac
--- libgpod-0.6.0.orig/configure.ac 2007-11-06 21:03:35.000000000 +0100
+++ libgpod-0.6.0/configure.ac 2008-06-30 19:17:50.000000000 +0200
@@ -78,8 +78,8 @@
dnl **************************************************
dnl * sgutils is necessary to get the xml device file from the ipod
dnl **************************************************
-AC_CHECK_LIB(sgutils, sg_ll_inquiry,
- [SGUTILS_LIBS="-lsgutils"; have_sgutils=yes],
+AC_CHECK_LIB(sgutils2, sg_ll_inquiry,
+ [SGUTILS_LIBS="-lsgutils2"; have_sgutils=yes],
have_sgutils=no)
AC_SUBST(SGUTILS_LIBS)
AM_CONDITIONAL(HAVE_SGUTILS, test x"$have_sgutils" = xyes)
diff -Nru libgpod-0.6.0.orig/tools/ipod-scsi-inquiry.c libgpod-0.6.0/tools/ipod-scsi-inquiry.c
--- libgpod-0.6.0.orig/tools/ipod-scsi-inquiry.c 2007-11-10 10:40:27.000000000 +0100
+++ libgpod-0.6.0/tools/ipod-scsi-inquiry.c 2008-06-30 19:32:36.000000000 +0200
@@ -30,6 +30,7 @@
#include <fcntl.h>
#include <stdio.h>
#include <stdlib.h>
+#include <stdint.h>
#include <string.h>
#include <unistd.h>
#include <scsi/sg_cmds.h>

View File

@ -3,7 +3,7 @@
Summary: Library to access the contents of an iPod
Name: libgpod
Version: 0.6.0
Release: 5%{?dist}
Release: 6%{?dist}
License: LGPLv2+
Group: System Environment/Libraries
URL: http://www.gtkpod.org/libgpod.html
@ -11,6 +11,7 @@ Source0: http://downloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
Patch0: libgpod-0.6.0-photoremove.patch
Patch1: libgpod-0.6.0-ipod-touch-typos.patch
Patch2: libgpod-0.6.0-spl-tracklen.patch
Patch3: libgpod-0.6.0-sg3_utils-1.26.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: docbook-style-xsl
BuildRequires: glib2-devel
@ -74,6 +75,7 @@ libgpod library.
%patch0 -p0 -b .photoremove
%patch1 -p0 -b .ipod-touch-typos
%patch2 -p0 -b .spl-tracklen
%patch3 -p1 -b .sg3_utils
# remove execute perms on the python examples as they'll be installed in %doc
%{__chmod} -x bindings/python/examples/*.py
@ -133,6 +135,9 @@ libgpod library.
%changelog
* Mon Jun 30 2008 Dan Horak <dan[at]danny.cz> - 0.6.0-6
- add patch for sg3_utils 1.26 and rebuild
* Wed May 14 2008 Todd Zullinger <tmz@pobox.com> - 0.6.0-5
- Make libgpod-devel require glib2-devel (#446442)