Update to 0.26.8

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Gnatenko 2018-11-03 17:45:38 +01:00
parent 00396a6776
commit 82f38e3012
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C
4 changed files with 74 additions and 4 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
/libgit2-0.26.6.tar.gz
/libgit2-0.26.7.tar.gz
/libgit2-0.26.8.tar.gz

View File

@ -0,0 +1,64 @@
From dc2e099a5da3cddc0d575b7c3c88af47eb53d8b3 Mon Sep 17 00:00:00 2001
From: Edward Thomson <ethomson@edwardthomson.com>
Date: Thu, 13 Sep 2018 13:27:07 +0100
Subject: [PATCH] tests: don't run buf::oom on 32-bit systems
On a 32-bit Linux systems, the value large enough to make malloc
guarantee a failure is also large enough that valgrind considers it
"fishy". Skip this test on those systems entirely.
(cherry picked from commit 415a8ae9c9b6ac18f0524b6af8e58408b426457d)
---
tests/buf/oom.c | 14 +++++++++-----
1 file changed, 9 insertions(+), 5 deletions(-)
diff --git a/tests/buf/oom.c b/tests/buf/oom.c
index 16a03cc1a..86f5e7239 100644
--- a/tests/buf/oom.c
+++ b/tests/buf/oom.c
@@ -11,12 +11,8 @@
*/
#if defined(GIT_ARCH_64) && defined(__linux__)
# define TOOBIG 0x0fffffffffffffff
-#elif defined(__linux__)
-# define TOOBIG 0x0fffffff
#elif defined(GIT_ARCH_64)
# define TOOBIG 0xffffffffffffff00
-#else
-# define TOOBIG 0xffffff00
#endif
/**
@@ -25,13 +21,18 @@
* will fail. And because the git_buf_grow() wrapper always
* sets mark_oom, the code in git_buf_try_grow() will free
* the internal buffer and set it to git_buf__oom.
- *
+ *
* We initialized the internal buffer to (the static variable)
* git_buf__initbuf. The purpose of this test is to make sure
* that we don't try to free the static buffer.
+ *
+ * Skip this test entirely on 32-bit platforms; a buffer large enough
+ * to guarantee malloc failures is so large that valgrind considers
+ * it likely to be an error.
*/
void test_buf_oom__grow(void)
{
+#ifdef GIT_ARCH_64
git_buf buf = GIT_BUF_INIT;
git_buf_clear(&buf);
@@ -40,6 +41,9 @@ void test_buf_oom__grow(void)
cl_assert(git_buf_oom(&buf));
git_buf_free(&buf);
+#else
+ cl_skip();
+#endif
}
void test_buf_oom__grow_by(void)
--
2.19.1

View File

@ -1,10 +1,12 @@
Name: libgit2
Version: 0.26.7
Version: 0.26.8
Release: 1%{?dist}
Summary: C implementation of the Git core methods as a library with a solid API
License: GPLv2 with exceptions
URL: https://libgit2.org/
Source0: https://github.com/libgit2/libgit2/archive/v%{version}/%{name}-%{version}.tar.gz
# https://github.com/libgit2/libgit2/commit/415a8ae9c9b6ac18f0524b6af8e58408b426457d
Patch0001: 0001-tests-don-t-run-buf-oom-on-32-bit-systems.patch
BuildRequires: gcc
BuildRequires: cmake >= 2.8
@ -37,8 +39,8 @@ developing applications that use %{name}.
# Remove VCS files from examples
find examples -name ".gitignore" -delete -print
# Don't test network
sed -i 's/ionline/xonline/' CMakeLists.txt
# Don't run "online" tests
sed -i '/ADD_TEST(online/s/^/#/' CMakeLists.txt
# Remove bundled libraries
rm -frv deps
@ -70,6 +72,9 @@ rm -frv deps
%{_includedir}/git2/
%changelog
* Sat Nov 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.26.8-1
- Update to 0.26.8
* Sat Oct 06 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.26.7-1
- Update to 0.26.7

View File

@ -1 +1 @@
SHA512 (libgit2-0.26.7.tar.gz) = 5ad0c514b6c1c58031029f4ada278a164cc112f25c36745973df27711f12888000c054816b65889576124e93b71ec9a1c4f4cc0b538f177d93a57bc145fea1e1
SHA512 (libgit2-0.26.8.tar.gz) = efb9229b2882ac36910d75778d7431bec40f3529f2ad2dd6a950d5580ceb0d4dd798242a422ea6cbb880f515df4dfbb7055a65dd5a8106696d3d458851fca56e