Update libxdiff patch.

Thanks to Mathieu Bridon
This commit is contained in:
Ignacio Casal Quinteiro 2013-11-28 11:26:04 +01:00
parent 591f751c3f
commit 198c08ad9e
2 changed files with 9 additions and 9 deletions

View File

@ -1,25 +1,25 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b931dc5..2aa8fde 100644
index 6642290..70b013e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -298,7 +298,7 @@ ELSEIF (AMIGA)
@@ -338,7 +338,7 @@ ELSEIF (AMIGA)
ELSE()
FILE(GLOB SRC_OS src/unix/*.c)
FILE(GLOB SRC_OS src/unix/*.c src/unix/*.h)
ENDIF()
-FILE(GLOB SRC_GIT2 src/*.c src/transports/*.c src/xdiff/*.c)
+FILE(GLOB SRC_GIT2 src/*.c src/transports/*.c)
-FILE(GLOB SRC_GIT2 src/*.c src/*.h src/transports/*.c src/transports/*.h src/xdiff/*.c src/xdiff/*.h)
+FILE(GLOB SRC_GIT2 src/*.c src/*.h src/transports/*.c src/transports/*.h)
# Determine architecture of the machine
IF (CMAKE_SIZEOF_VOID_P EQUAL 8)
@@ -313,6 +313,7 @@ ENDIF()
ADD_LIBRARY(git2 ${SRC_GIT2} ${SRC_OS} ${SRC_ZLIB} ${SRC_HTTP} ${SRC_REGEX} ${SRC_SHA1} ${WIN_RC})
@@ -353,6 +353,7 @@ ENDIF()
ADD_LIBRARY(git2 ${SRC_H} ${SRC_GIT2} ${SRC_OS} ${SRC_ZLIB} ${SRC_HTTP} ${SRC_REGEX} ${SRC_SHA1} ${WIN_RC})
TARGET_LINK_LIBRARIES(git2 ${SSL_LIBRARIES})
TARGET_LINK_LIBRARIES(git2 ${SSH_LIBRARIES})
+TARGET_LINK_LIBRARIES(git2 -lxdiff)
TARGET_OS_LIBRARIES(git2)
# Workaround for Cmake bug #0011240 (see http://public.kitware.com/Bug/view.php?id=11240)
@@ -388,6 +389,7 @@ IF (BUILD_CLAR)
@@ -418,6 +419,7 @@ IF (BUILD_CLAR)
TARGET_LINK_LIBRARIES(libgit2_clar ${SSL_LIBRARIES})
TARGET_LINK_LIBRARIES(libgit2_clar ${SSH_LIBRARIES})

View File

@ -10,7 +10,7 @@ URL: http://libgit2.github.com/
Source0: https://github.com/%{name}/%{name}/archive/%{commit}/%{name}-%{version}.tar.gz
# Use system libxdiff
Patch0: libgit2-0.19.0-system-libxdiff.patch
Patch0: libgit2-0.20.0-system-libxdiff.patch
# Add htonl() and friends declarations on non-x86 arches
Patch1: libgit2-0.19.0-non-x86.patch