Update to 1.7.3

This commit is contained in:
Sandro Mani 2024-05-25 12:21:31 +02:00
parent 918baae862
commit aeabe5cf3c
4 changed files with 31 additions and 25 deletions

1
.gitignore vendored
View File

@ -2,3 +2,4 @@
/libgeotiff-1.6.0.tar.gz
/libgeotiff-1.7.0.tar.gz
/libgeotiff-1.7.1.tar.gz
/libgeotiff-1.7.3.tar.gz

View File

@ -5,8 +5,8 @@
%endif
Name: libgeotiff
Version: 1.7.1
Release: 13%{?dist}
Version: 1.7.3
Release: 1%{?dist}
Summary: GeoTIFF format library
License: MIT
@ -105,12 +105,14 @@ BuildArch: noarch
%build
# Native build
%cmake -DGEOTIFF_BIN_SUBDIR=bin -DGEOTIFF_INCLUDE_SUBDIR=include/%{name} -DGEOTIFF_LIB_SUBDIR=%{_lib}
%cmake -DGEOTIFF_BIN_SUBDIR=bin -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}/%{name}
%cmake_build
%if %{with mingw}
# MinGW build
%mingw_cmake -DGEOTIFF_BIN_SUBDIR=bin -DGEOTIFF_INCLUDE_SUBDIR=include/%{name}
MINGW32_CMAKE_ARGS=-DCMAKE_INSTALL_INCLUDEDIR=%{mingw32_includedir}/%{name} \
MINGW64_CMAKE_ARGS=-DCMAKE_INSTALL_INCLUDEDIR=%{mingw64_includedir}/%{name} \
%mingw_cmake
%mingw_make_build
%endif
@ -132,7 +134,7 @@ includedir=%{_includedir}/%{name}
Name: %{name}
Description: GeoTIFF file format library
Version: %{version}
Version: 1.7.3
Libs: -L\${libdir} -lgeotiff
Cflags: -I\${includedir}
EOF
@ -147,7 +149,7 @@ includedir=%{mingw32_includedir}/%{name}
Name: %{name}
Description: GeoTIFF file format library
Version: %{version}
Version: 1.7.3
Libs: -L\${libdir} -lgeotiff
Cflags: -I\${includedir}
EOF
@ -161,7 +163,7 @@ includedir=%{mingw64_includedir}/%{name}
Name: %{name}
Description: GeoTIFF file format library
Version: %{version}
Version: 1.7.3
Libs: -L\${libdir} -lgeotiff
Cflags: -I\${includedir}
EOF
@ -221,6 +223,9 @@ EOF
%changelog
* Sat May 25 2024 Sandro Mani <manisandro@gmail.com> - 1.7.3-1
- Update to 1.7.3
* Tue Mar 05 2024 Sandro Mani <manisandro@gmail.com> - 1.7.1-13
- Rebuild (proj)

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference libgeotiff-1.7.1/cmake/CMakeLists.txt libgeotiff-1.7.1-new/cmake/CMakeLists.txt
--- libgeotiff-1.7.1/cmake/CMakeLists.txt 2022-02-18 16:07:34.000000000 +0100
+++ libgeotiff-1.7.1-new/cmake/CMakeLists.txt 2022-03-14 23:38:20.294077484 +0100
diff -rupN libgeotiff-1.7.3/cmake/CMakeLists.txt libgeotiff-1.7.3-new/cmake/CMakeLists.txt
--- libgeotiff-1.7.3/cmake/CMakeLists.txt 2022-02-18 16:07:34.000000000 +0100
+++ libgeotiff-1.7.3-new/cmake/CMakeLists.txt 2024-05-25 11:33:17.823041296 +0200
@@ -6,13 +6,8 @@
# ${INSTALL_CMAKE_DIR} and @PROJECT_ROOT_DIR@ is the relative
# path to the root from there. (Note that the whole install tree can
@ -17,23 +17,23 @@ diff -rupN --no-dereference libgeotiff-1.7.1/cmake/CMakeLists.txt libgeotiff-1.7
configure_file (project-config.cmake.in project-config.cmake @ONLY)
configure_file (project-config-version.cmake.in
diff -rupN --no-dereference libgeotiff-1.7.1/CMakeLists.txt libgeotiff-1.7.1-new/CMakeLists.txt
--- libgeotiff-1.7.1/CMakeLists.txt 2022-03-10 09:32:14.000000000 +0100
+++ libgeotiff-1.7.1-new/CMakeLists.txt 2022-03-14 23:38:20.295077481 +0100
@@ -261,9 +261,9 @@ SET(GEOTIFF_LIB_DIR ${GEOTIFF_LIB_SUBDIR
SET(GEOTIFF_INCLUDE_DIR ${GEOTIFF_INCLUDE_SUBDIR})
diff -rupN libgeotiff-1.7.3/CMakeLists.txt libgeotiff-1.7.3-new/CMakeLists.txt
--- libgeotiff-1.7.3/CMakeLists.txt 2024-05-24 15:38:59.000000000 +0200
+++ libgeotiff-1.7.3-new/CMakeLists.txt 2024-05-25 11:35:20.294177785 +0200
@@ -244,9 +244,9 @@ SET(GEOTIFF_MAN_PAGES
# ${PROJECT_BINARY_DIR}/geotiff_version.h
# Install doc files
-INSTALL(FILES
- AUTHORS ChangeLog COPYING INSTALL LICENSE README README_BIN README.WIN
- DESTINATION doc)
+#INSTALL(FILES
+ #AUTHORS ChangeLog COPYING INSTALL LICENSE README README_BIN README.WIN
+ #DESTINATION doc)
- AUTHORS ChangeLog COPYING LICENSE README README_BIN README.WIN
- DESTINATION ${CMAKE_INSTALL_DOCDIR})
+# INSTALL(FILES
+ # AUTHORS ChangeLog COPYING LICENSE README README_BIN README.WIN
+ # DESTINATION ${CMAKE_INSTALL_DOCDIR})
# Install man pages
INSTALL(FILES ${GEOTIFF_MAN_PAGES} DESTINATION share/man/man1)
@@ -329,6 +329,9 @@ endif()
INSTALL(FILES ${GEOTIFF_MAN_PAGES} DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
@@ -312,6 +312,9 @@ endif()
SET_TARGET_PROPERTIES(${GEOTIFF_LIBRARY_TARGET} PROPERTIES
OUTPUT_NAME ${GEOTIFF_LIB_NAME})
@ -41,5 +41,5 @@ diff -rupN --no-dereference libgeotiff-1.7.1/CMakeLists.txt libgeotiff-1.7.1-new
+ SET_TARGET_PROPERTIES(${GEOTIFF_LIBRARY_TARGET} PROPERTIES SUFFIX "-${LINK_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
+ENDIF(MINGW)
set(CONFIG_DEPENDENCIES "")
if(TARGET TIFF::TIFF)
set(CONFIG_PUBLIC_DEPENDENCIES "")
set(CONFIG_PRIVATE_DEPENDENCIES "")

View File

@ -1 +1 @@
SHA512 (libgeotiff-1.7.1.tar.gz) = af119040598f4349124848d9788ea1d0d2019e23fc48eaf4b0445320c51e91afa6c7e25b49738bdaf0aa4467a19104b00838d669da27dee77898c489fe5fe4c1
SHA512 (libgeotiff-1.7.3.tar.gz) = a523d6117c7433fe37b7c0cdcba81698426cd4b084bcb35c7dacc9e87bfda1ab7a4c16a9aa64a69dedb78edc2f85e8032bf8b158411f50909603e04d13821cd3