- add patch to fix typo in python bindings

- drop multilib patch0 fixed upstream
- new upstream release
This commit is contained in:
Lucian Langa 2010-01-04 07:59:08 +00:00
parent fc6a63bdb3
commit e701a6470e
3 changed files with 16 additions and 46 deletions

View File

@ -1,43 +0,0 @@
--- libftdi-0.16/libftdi-config.in 2009-02-06 17:40:10.000000000 +0200
+++ libftdi-0.16-mod/libftdi-config.in 2009-07-31 13:08:08.000000000 +0300
@@ -1,7 +1,7 @@
#!/bin/sh
-prefix=@prefix@
-exec_prefix=@exec_prefix@
+prefix=`pkg-config --variable prefix libftdi`
+exec_prefix=`pkg-config --variable exec_prefix libftdi`
exec_prefix_set=no
usage()
@@ -46,17 +46,14 @@
echo_exec_prefix=yes
;;
--version)
- echo @VERSION@
+ pkg-config --modversion libftdi
exit 0
;;
--cflags)
- if test "@includedir@" != /usr/include ; then
- includes="-I@includedir@"
- fi
- echo_cflags=yes
+ pkg-config --cflags libftdi
;;
--libs)
- echo_libs=yes
+ pkg-config --libs libftdi
;;
*)
usage 1 1>&2
@@ -71,9 +68,3 @@
if test "$echo_exec_prefix" = "yes"; then
echo $exec_prefix
fi
-if test "$echo_cflags" = "yes"; then
- echo $includes
-fi
-if test "$echo_libs" = "yes"; then
- echo -L@libdir@ -lftdi @LIBS@
-fi

View File

@ -0,0 +1,11 @@
diff -Naur libftdi-0.17/bindings/python/setup.py.in libftdi-0.17-mod/bindings/python/setup.py.in
--- libftdi-0.17/bindings/python/setup.py.in 2009-05-29 22:54:41.000000000 +0300
+++ libftdi-0.17-mod/bindings/python/setup.py.in 2010-01-04 09:48:58.000000000 +0200
@@ -12,6 +12,6 @@
py_modules=['ftdi'],
ext_modules=[Extension('_ftdi', ['ftdi_wrap.c'],
include_dirs=['@top_srcdir@/src'],
- library_dirs=['@top_buildir@/src/.libs','lib','/usr/lib'],
+ library_dirs=['@top_builddir@/src/.libs','lib','/usr/lib'],
libraries=['ftdi'])],
)

View File

@ -9,7 +9,7 @@ License: LGPLv2
URL: http://www.intra2net.com/de/produkte/opensource/ftdi/
Source0: http://www.intra2net.com/de/produkte/opensource/ftdi/TGZ/%{name}-%{version}.tar.gz
Source1: no_date_footer.html
Patch0: libftdi-0.16-multilib.patch
Patch0: libftdi-0.17-bind-typo.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libusb-devel, doxygen, boost-devel, python-devel, swig
@ -60,7 +60,7 @@ for building C++ applications with libftdi.
%prep
%setup -q
sed -i -e 's/HTML_FOOTER =/HTML_FOOTER = no_date_footer.html/g' doc/Doxyfile.in
%patch0 -p1 -b .multilib
%patch0 -p1 -b .bindings-typo
%build
@ -139,7 +139,9 @@ exit 0
%postun c++ -p /sbin/ldconfig
%changelog
* Sun Dec 20 2009 Lucian Langa <cooly@gnome.eu.org> - 0.17-1
* Sun Jan 01 2010 Lucian Langa <cooly@gnome.eu.org> - 0.17-1
- add patch to fix typo in python bindings
- drop multilib patch0 fixed upstream
- new upstream release
* Sat Aug 22 2009 Lucian Langa <cooly@gnome.eu.org> - 0.16-7