Update to 1.1, Build against libusb1, Package cleanup, Run make check

This commit is contained in:
Peter Robinson 2014-03-24 15:19:11 +00:00
parent da7a951bde
commit b1e1711b18
6 changed files with 73 additions and 169 deletions

4
.gitignore vendored
View File

@ -1,3 +1 @@
libftdi-0.18.tar.gz
/libftdi-0.19.tar.gz
/libftdi-0.20.tar.gz
/libftdi*.tar.bz2

View File

@ -1,44 +0,0 @@
--- libftdi-0.16/libftdi-config.in 2009-02-06 17:40:10.000000000 +0200
+++ libftdi-0.16-mod/libftdi-config.in 2009-07-31 13:08:08.000000000 +0300
@@ -1,7 +1,7 @@
#!/bin/sh
-prefix=@prefix@
-exec_prefix=@exec_prefix@
+prefix=`pkg-config --variable prefix libftdi`
+exec_prefix=`pkg-config --variable exec_prefix libftdi`
exec_prefix_set=no
usage()
@@ -46,17 +46,14 @@
echo_exec_prefix=yes
;;
--version)
- echo @VERSION@
+ pkg-config --modversion libftdi
exit 0
;;
--cflags)
- if test "@includedir@" != /usr/include ; then
- includes="-I@includedir@"
- fi
- echo_cflags=yes
+ pkg-config --cflags libftdi
;;
--libs)
- echo_libs=yes
+ pkg-config --libs libftdi
;;
*)
usage 1 1>&2
@@ -71,9 +68,3 @@
if test "$echo_exec_prefix" = "yes"; then
echo $exec_prefix
fi
-if test "$echo_cflags" = "yes"; then
- echo $includes
-fi
-if test "$echo_libs" = "yes"; then
- echo -L@libdir@ -lftdi @LIBS@
-fi

View File

@ -1,38 +0,0 @@
diff -Naur libftdi-0.19/configure.in libftdi-0.19-mod/configure.in
--- libftdi-0.19/configure.in 2011-05-20 17:30:40.000000000 +0300
+++ libftdi-0.19-mod/configure.in 2011-06-18 08:38:02.000000000 +0300
@@ -7,30 +7,12 @@
AM_PROG_LIBTOOL
AC_PROG_CXX
-dnl check for libusb-config
-AC_CHECK_TOOL(HAVELIBUSB, libusb-config)
-
-if test ! -z "$HAVELIBUSB"; then
- LIBUSB_CFLAGS=`$HAVELIBUSB --cflags`
- LIBUSB_LIBS=`$HAVELIBUSB --libs`
-
+dnl check for libusb
+PKG_CHECK_MODULES(LIBUSB, libusb,
+[
CFLAGS="$CFLAGS $LIBUSB_CFLAGS"
LIBS="$LIBS $LIBUSB_LIBS"
-else
- AC_MSG_ERROR([*** libusb-config not found. You need a working libusb installation.])
-fi
-
-dnl check for version of libusb
-AC_MSG_CHECKING([if libusb version is >= 0.1.7])
-libusb_version_needed="1007"
-libusb_version=`$HAVELIBUSB --version | sed -e "s/libusb //" | awk 'BEGIN { FS = "."; } { printf "%d", ($''1 * 1000 + $''2) * 1000 + $''3;}'`
-
-if test $libusb_version -lt $libusb_version_needed; then
- AC_MSG_RESULT(no)
- AC_MSG_ERROR([*** libusb is too old ($libusb_version). You need a libusb installation newer or equal to 0.1.7.])
-else
- AC_MSG_RESULT(yes)
-fi
+])
ENABLE_ASYNC_MODE=0
AC_ARG_WITH(async-mode,

View File

@ -1,93 +1,90 @@
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
Name: libftdi
Version: 0.20
Release: 5%{?dist}
Version: 1.1
Release: 1%{?dist}
Summary: Library to program and control the FTDI USB controller
Group: System Environment/Libraries
License: LGPLv2
URL: http://www.intra2net.com/de/produkte/opensource/ftdi/
Source0: http://www.intra2net.com/de/produkte/opensource/ftdi/TGZ/%{name}-%{version}.tar.gz
Source1: no_date_footer.html
Patch0: libftdi-0.17-multilib.patch
# update to recent libusb
Patch1: libftdi-0.19-libusb.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: http://www.intra2net.com/en/developer/%{name}/download/%{name}1-%{version}.tar.bz2
BuildRequires: libusb-devel, doxygen, boost-devel, python-devel, swig
BuildRequires: autoconf, automake, libtool
Requires: pkgconfig, udev
Requires(pre): shadow-utils
%package devel
Summary: Header files and static libraries for libftdi
Group: Development/Libraries
Requires: libftdi = %{version}-%{release}
Requires: libusb-devel
%package python
Summary: Libftdi library Python binding
Group: Development/Libraries
Requires: libftdi = %{version}-%{release}
%package c++
Summary: Libftdi library C++ binding
Group: Development/Libraries
Requires: libftdi = %{version}-%{release}
%package c++-devel
Summary: Libftdi library C++ binding development headers and libraries
Group: Development/Libraries
Requires: libftdi-devel = %{version}-%{release}, libftdi-c++ = %{version}-%{release}
BuildRequires: boost-devel
BuildRequires: cmake
BuildRequires: doxygen
BuildRequires: libconfuse-devel
BuildRequires: libusbx-devel
BuildRequires: python-devel
BuildRequires: swig
Requires: systemd
%description
A library (using libusb) to talk to FTDI's FT2232C,
FT232BM and FT245BM type chips including the popular bitbang mode.
%package devel
Summary: Header files and static libraries for libftdi
Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: pkgconfig
%description devel
Header files and static libraries for libftdi
%package python
Summary: Libftdi library Python binding
Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
%description python
Libftdi Python Language bindings.
%package c++
Summary: Libftdi library C++ binding
Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
%description c++
Libftdi library C++ language binding.
%package c++-devel
Summary: Libftdi library C++ binding development headers and libraries
Group: Development/Libraries
Requires: %{name}-devel = %{version}-%{release}
Requires: %{name}-c++ = %{version}-%{release}
%description c++-devel
Libftdi library C++ binding development headers and libraries
for building C++ applications with libftdi.
%prep
%setup -q
sed -i -e 's/HTML_FOOTER =/HTML_FOOTER = no_date_footer.html/g' doc/Doxyfile.in
%setup -q -n %{name}1-%{version}
#kernel does not provide usb_device anymore
sed -i -e 's/usb_device/usb/g' packages/99-libftdi.rules
%patch0 -p1 -b .multilib
%patch1 -p1 -b .libusb
sed -i -e 's/GROUP="plugdev"/TAG+="uaccess"/g' packages/99-libftdi.rules
%build
autoreconf -if
%configure --enable-python-binding --enable-libftdipp --disable-static
cp %{SOURCE1} %{_builddir}/%{name}-%{version}/doc
export CMAKE_PREFIX_PATH=/usr
%{cmake} .
make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
find %{buildroot} -name \*\.la -print | xargs rm -f
#too generic name
mv doc/man/man3/deprecated.3 doc/man/man3/libftdi-deprecated.3
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
#no man install
install -p -m 644 doc/man/man3/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
install -p -m 644 packages/99-libftdi.rules $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
mkdir -p $RPM_BUILD_ROOT/lib/udev/rules.d/
install -p -m 644 packages/99-libftdi.rules $RPM_BUILD_ROOT/lib/udev/rules.d/69-libftdi.rules
find $RPM_BUILD_ROOT -type f -name "*.la" -delete
find $RPM_BUILD_ROOT -type f -name "*.a" -delete
#no man install
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
install -p -m 644 doc/man/man3/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
# Cleanup examples
rm -f $RPM_BUILD_ROOT/%{_bindir}/simple
@ -100,45 +97,37 @@ rm -f $RPM_BUILD_ROOT/%{_bindir}/find_all_pp
rm -f $RPM_BUILD_ROOT/%{_bindir}/baud_test
rm -f $RPM_BUILD_ROOT/%{_bindir}/serial_read
rm -f $RPM_BUILD_ROOT/%{_bindir}/serial_test
rm -rf $RPM_BUILD_ROOT/%{_libdir}/cmake*
%check
make check
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
%doc AUTHORS ChangeLog COPYING.LIB README
%{_libdir}/libftdi.so.*
%config(noreplace) %{_sysconfdir}/udev/rules.d/99-libftdi.rules
%{_libdir}/libftdi1.so.2*
/lib/udev/rules.d/69-libftdi.rules
%files devel
%defattr(-,root,root,-)
%doc doc/html
%{_bindir}/libftdi-config
%{_libdir}/libftdi.so
%{_includedir}/*.h
%{_libdir}/pkgconfig/libftdi.pc
%doc %{_datadir}/libftdi/examples
%{_bindir}/ftdi_eeprom
%{_bindir}/libftdi1-config
%{_libdir}/libftdi1.so
%{_includedir}/libftdi1
%{_libdir}/pkgconfig/libftdi1.pc
%{_mandir}/man3/*
%files python
%defattr(-, root, root, -)
%doc AUTHORS ChangeLog COPYING.LIB README
%{python_sitearch}/*
%files c++
%defattr(-, root, root, -)
%doc AUTHORS ChangeLog COPYING.LIB README
%{_libdir}/libftdipp.so.*
%{_libdir}/libftdipp1.so.2*
%files c++-devel
%defattr(-, root, root, -)
%doc doc/html
%{_libdir}/libftdipp.so
%{_includedir}/*.hpp
%{_libdir}/pkgconfig/libftdipp.pc
%pre
getent group plugdev >/dev/null || groupadd -r plugdev
exit 0
%{_libdir}/libftdipp1.so
%{_includedir}/libftdi1/*hpp
%{_libdir}/pkgconfig/libftdipp1.pc
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
@ -147,6 +136,12 @@ exit 0
%postun c++ -p /sbin/ldconfig
%changelog
* Mon Mar 24 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.1-1
- Update to 1.1
- Build against libusb1
- Package cleanup
- Run make check
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.20-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
@ -202,7 +197,7 @@ exit 0
* Sat Jan 16 2010 Lucian Langa <cooly@gnome.eu.org> - 0.17-2
- do not package static libfiles (#556068)
* Sun Jan 01 2010 Lucian Langa <cooly@gnome.eu.org> - 0.17-1
* Sun Jan 3 2010 Lucian Langa <cooly@gnome.eu.org> - 0.17-1
- add patch to fix typo in python bindings
- drop multilib patch0 fixed upstream
- new upstream release

View File

@ -1,7 +0,0 @@
<hr size="1"><address style="text-align: right;"><small>
Generated for $projectname by <a href="http://www.doxygen.org/
index.html"><img src="doxygen.png" alt="doxygen" align="middle" border="0"></a>
$doxygenversion</small></address>
</body>
</html>

View File

@ -1 +1 @@
355d4474e3faa81b485d6a604b06951f libftdi-0.20.tar.gz
b79a6356978aa8e69f8eecc3a720ff79 libftdi1-1.1.tar.bz2