32 lines
1.2 KiB
Diff
32 lines
1.2 KiB
Diff
diff -up ./wrappers/python/CMakeLists.txt.cmake30 ./wrappers/python/CMakeLists.txt
|
|
--- ./wrappers/python/CMakeLists.txt.cmake30 2015-01-26 22:01:37.000000000 -0500
|
|
+++ ./wrappers/python/CMakeLists.txt 2015-03-04 10:19:13.007395503 -0500
|
|
@@ -2,14 +2,14 @@
|
|
# Python extension builder
|
|
######################################################################################
|
|
|
|
-include(FindPythonInterp)
|
|
+#include(FindPythonInterp)
|
|
include(FindPythonLibs)
|
|
|
|
find_program(CYTHON_EXECUTABLE cython)
|
|
|
|
# Figure out installation path
|
|
execute_process(COMMAND
|
|
- ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(prefix='${CMAKE_INSTALL_PREFIX}')"
|
|
+ ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)"
|
|
OUTPUT_VARIABLE PYTHON_SITE_PACKAGES OUTPUT_STRIP_TRAILING_WHITESPACE)
|
|
|
|
# Figure out numpy include path
|
|
@@ -33,7 +33,9 @@ include_directories(${PYTHON_INCLUDE_PAT
|
|
|
|
# Install the extension
|
|
install(TARGETS cython_freenect
|
|
- DESTINATION ${PYTHON_SITE_PACKAGES})
|
|
+ ARCHIVE DESTINATION ${PYTHON_SITE_PACKAGES}
|
|
+ LIBRARY DESTINATION ${PYTHON_SITE_PACKAGES}
|
|
+ COMPONENT library)
|
|
|
|
# TODO: decide on what to do with demo_ scripts and were to install
|
|
# them
|