36 lines
1.4 KiB
Diff
36 lines
1.4 KiB
Diff
diff -up ./wrappers/python/CMakeLists.txt.cmake28 ./wrappers/python/CMakeLists.txt
|
|
--- ./wrappers/python/CMakeLists.txt.cmake28 2014-03-22 20:42:53.000000000 -0400
|
|
+++ ./wrappers/python/CMakeLists.txt 2014-04-14 20:45:29.682944140 -0400
|
|
@@ -2,15 +2,16 @@
|
|
# Python extension builder
|
|
######################################################################################
|
|
|
|
-include(FindPythonInterp)
|
|
+#include(FindPythonInterp)
|
|
include(FindPythonLibs)
|
|
|
|
find_program(CYTHON_EXECUTABLE cython)
|
|
|
|
# Figure out installation path
|
|
execute_process(COMMAND
|
|
- ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(prefix='${CMAKE_INSTALL_PREFIX}')"
|
|
+ ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)"
|
|
OUTPUT_VARIABLE PYTHON_SITE_PACKAGES OUTPUT_STRIP_TRAILING_WHITESPACE)
|
|
+message(STATUS "PyPath: ${PYTHON_SITE_PACKAGES}")
|
|
|
|
# Figure out numpy include path
|
|
execute_process(COMMAND
|
|
@@ -31,9 +32,11 @@ set_target_properties(cython_freenect PR
|
|
target_link_libraries(cython_freenect freenect_sync)
|
|
include_directories(${PYTHON_INCLUDE_PATH} ../c_sync/ ${NUMPY_INCLUDE_PATH})
|
|
|
|
+message(STATUS "PyPath: ${PYTHON_SITE_PACKAGES}")
|
|
+
|
|
# Install the extension
|
|
install(TARGETS cython_freenect
|
|
- DESTINATION ${PYTHON_SITE_PACKAGES})
|
|
+ LIBRARY DESTINATION ${PYTHON_SITE_PACKAGES})
|
|
|
|
# TODO: decide on what to do with demo_ scripts and were to install
|
|
# them
|