Update to release 0.4.2
- Add platform detection for aarch64
This commit is contained in:
parent
8454871a25
commit
7373ead94a
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
/libfreenect-v0.1.2.tar.bz2
|
/libfreenect-v0.1.2.tar.bz2
|
||||||
/libfreenect-de79349de52e0458da38f3eaa721f2ca4b45ff29.tar.gz
|
/libfreenect-de79349de52e0458da38f3eaa721f2ca4b45ff29.tar.gz
|
||||||
|
/libfreenect-a35642fefd533c6b21864cd3bab7fefb9f0e2f00.tar.gz
|
||||||
|
12
libfreenect-0.4.2-aarch64.patch
Normal file
12
libfreenect-0.4.2-aarch64.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up ./OpenNI2-FreenectDriver/extern/OpenNI-Linux-x64-2.2.0.33/Include/OniPlatform.h.aarch64 ./OpenNI2-FreenectDriver/extern/OpenNI-Linux-x64-2.2.0.33/Include/OniPlatform.h
|
||||||
|
--- ./OpenNI2-FreenectDriver/extern/OpenNI-Linux-x64-2.2.0.33/Include/OniPlatform.h.aarch64 2014-05-05 18:15:56.817039757 -0400
|
||||||
|
+++ ./OpenNI2-FreenectDriver/extern/OpenNI-Linux-x64-2.2.0.33/Include/OniPlatform.h 2014-05-05 18:16:43.015509240 -0400
|
||||||
|
@@ -39,7 +39,7 @@
|
||||||
|
# include "Android-Arm/OniPlatformAndroid-Arm.h"
|
||||||
|
#elif (__linux__ && (__i386__ || __x86_64__))
|
||||||
|
# include "Linux-x86/OniPlatformLinux-x86.h"
|
||||||
|
-#elif (__linux__ && __arm__)
|
||||||
|
+#elif (__linux__ && (__arm__ || __aarch64__))
|
||||||
|
# include "Linux-Arm/OniPlatformLinux-Arm.h"
|
||||||
|
#elif _ARC
|
||||||
|
# include "ARC/OniPlaformARC.h"
|
12
libfreenect-0.4.2-libdir.patch
Normal file
12
libfreenect-0.4.2-libdir.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up ./cmake_modules/SetupDirectories.cmake.libdir ./cmake_modules/SetupDirectories.cmake
|
||||||
|
--- ./cmake_modules/SetupDirectories.cmake.libdir 2014-05-05 18:27:34.066386294 -0400
|
||||||
|
+++ ./cmake_modules/SetupDirectories.cmake 2014-05-05 18:28:14.961891390 -0400
|
||||||
|
@@ -8,7 +8,7 @@ ENDIF (PROJECT_OS_WIN)
|
||||||
|
STRING (TOLOWER ${PROJECT_NAME} projectNameLower)
|
||||||
|
SET (PROJECT_INCLUDE_INSTALL_DIR "include/${projectNameLower}")
|
||||||
|
SET (PROJECT_MANPAGE_INSTALL_DIR "share/man")
|
||||||
|
-SET (PROJECT_LIBRARY_INSTALL_DIR "lib")
|
||||||
|
+SET (PROJECT_LIBRARY_INSTALL_DIR "lib${LIB_SUFFIX}" CACHE PATH "Library installation directory")
|
||||||
|
|
||||||
|
MESSAGE (STATUS "${PROJECT_NAME} will be installed to ${CMAKE_INSTALL_PREFIX}")
|
||||||
|
MESSAGE (STATUS "Headers will be installed to ${CMAKE_INSTALL_PREFIX}/${PROJECT_INCLUDE_INSTALL_DIR}")
|
@ -1,4 +1,4 @@
|
|||||||
%global commit de79349de52e0458da38f3eaa721f2ca4b45ff29
|
%global commit a35642fefd533c6b21864cd3bab7fefb9f0e2f00
|
||||||
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||||
|
|
||||||
%{?filter_setup:
|
%{?filter_setup:
|
||||||
@ -7,7 +7,7 @@
|
|||||||
}
|
}
|
||||||
|
|
||||||
Name: libfreenect
|
Name: libfreenect
|
||||||
Version: 0.4.1
|
Version: 0.4.2
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Device driver for the Kinect
|
Summary: Device driver for the Kinect
|
||||||
License: GPLv2+ or ASL 2.0
|
License: GPLv2+ or ASL 2.0
|
||||||
@ -19,6 +19,10 @@ Source0: https://github.com/OpenKinect/%{name}/archive/%{commit}/%{name}-
|
|||||||
Patch0: %{name}-0.4.0-cmake28.patch
|
Patch0: %{name}-0.4.0-cmake28.patch
|
||||||
# Freenect openni driver is a plugin lib, and doesn't need soversion symlinks
|
# Freenect openni driver is a plugin lib, and doesn't need soversion symlinks
|
||||||
Patch1: %{name}-0.4.1-openni2.patch
|
Patch1: %{name}-0.4.1-openni2.patch
|
||||||
|
# Detect aarch64
|
||||||
|
Patch2: %{name}-0.4.2-aarch64.patch
|
||||||
|
# Allow for proper libdir
|
||||||
|
Patch3: %{name}-0.4.2-libdir.patch
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: Cython
|
BuildRequires: Cython
|
||||||
@ -94,17 +98,22 @@ It was originally a separate project but is now distributed with libfreenect.
|
|||||||
rm -rf platform/windows
|
rm -rf platform/windows
|
||||||
%patch0 -p0 -b .cmake28
|
%patch0 -p0 -b .cmake28
|
||||||
%patch1 -p0 -b .openni2
|
%patch1 -p0 -b .openni2
|
||||||
# Get rid of osx and win specific stuff
|
%patch2 -p0 -b .aarch64
|
||||||
sed -i 's|get_python_lib(prefix='\''${CMAKE_INSTALL_PREFIX}'\'')|get_python_lib(1)|' wrappers/python/CMakeLists.txt
|
%patch3 -p0 -b .libdir
|
||||||
sed -i 's|/usr/local|/usr|' wrappers/python/setup.py
|
|
||||||
chmod -x wrappers/cpp/cppview.cpp
|
|
||||||
sed -i 's|set(CMAKE_C_FLAGS "-Wall")|#set(CMAKE_C_FLAGS "-Wall")|' src/CMakeLists.txt
|
|
||||||
sed -i 's|set(CMAKE_C_FLAGS "-Wall")|#set(CMAKE_C_FLAGS "-Wall")|' examples/CMakeLists.txt
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
mkdir build
|
mkdir build
|
||||||
pushd build
|
pushd build
|
||||||
%cmake -DBUILD_AUDIO=ON -DBUILD-CPP=ON -DBUILD_C_SYNC=ON -DBUILD_CV=ON -DBUILD_REDIST_PACKAGE=ON -DBUILD_EXAMPLES=ON -DBUILD_CPACK=OFF -DBUILD_FAKENECT=ON -DBUILD_PYTHON=ON -DBUILD_OPENNI2_DRIVER=ON ..
|
%cmake .. \
|
||||||
|
-DBUILD_AUDIO=ON \
|
||||||
|
-DBUILD_C_SYNC=ON \
|
||||||
|
-DBUILD_CV=ON \
|
||||||
|
-DBUILD_REDIST_PACKAGE=ON \
|
||||||
|
-DBUILD_EXAMPLES=ON \
|
||||||
|
-DBUILD_FAKENECT=ON \
|
||||||
|
-DBUILD_PYTHON=ON \
|
||||||
|
-DBUILD_OPENNI2_DRIVER=ON
|
||||||
|
|
||||||
make %{?_smp_mflags} VERBOSE=1
|
make %{?_smp_mflags} VERBOSE=1
|
||||||
popd
|
popd
|
||||||
|
|
||||||
@ -171,6 +180,10 @@ sed -i "s|#!/usr/bin/env python||" %{buildroot}%{_datadir}/%{name}/fwfetcher.py
|
|||||||
%{_libdir}/OpenNI2-FreenectDriver
|
%{_libdir}/OpenNI2-FreenectDriver
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 05 2014 Rich Mattes <richmattes@gmail.com> - 0.4.2-1
|
||||||
|
- Update to release 0.4.2
|
||||||
|
- Add platform detection for aarch64
|
||||||
|
|
||||||
* Fri May 02 2014 Rich Mattes <richmattes@gmail.com> - 0.4.1-1
|
* Fri May 02 2014 Rich Mattes <richmattes@gmail.com> - 0.4.1-1
|
||||||
- Update to release 0.4.1
|
- Update to release 0.4.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user