Fix FTBFS in f36 mass rebuild.

This commit is contained in:
Phil Wyett 2022-01-26 22:08:31 +00:00
parent 5a0ca9b77a
commit 676ea2c2bd
2 changed files with 65 additions and 1 deletions

View File

@ -0,0 +1,58 @@
--- wrappers/cpp/CMakeLists.txt.orig 2022-01-26 21:08:55.022364517 +0000
+++ wrappers/cpp/CMakeLists.txt 2022-01-26 21:09:55.781482241 +0000
@@ -6,6 +6,7 @@
if (BUILD_EXAMPLES)
set(THREADS_USE_PTHREADS_WIN32 true)
find_package(Threads)
+ set(OpenGL_GL_PREFERENCE GLVND)
find_package(OpenGL)
find_package(GLUT)
@@ -18,8 +19,8 @@
target_compile_features(freenect-cppview PUBLIC cxx_std_11)
target_compile_features(freenect-cpp_pcview PUBLIC cxx_std_11)
- target_link_libraries(freenect-cppview freenect ${OPENGL_LIBRARIES} ${GLUT_LIBRARY} ${CMAKE_THREAD_LIBS_INIT} ${MATH_LIB})
- target_link_libraries(freenect-cpp_pcview freenect ${OPENGL_LIBRARIES} ${GLUT_LIBRARY} ${CMAKE_THREAD_LIBS_INIT} ${MATH_LIB})
+ target_link_libraries(freenect-cppview freenect ${OPENGL_LIBRARIES} ${GLUT_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${MATH_LIB})
+ target_link_libraries(freenect-cpp_pcview freenect ${OPENGL_LIBRARIES} ${GLUT_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${MATH_LIB})
install(TARGETS freenect-cppview freenect-cpp_pcview
DESTINATION bin)
--- examples/CMakeLists.txt.orig 2022-01-26 20:51:31.842178661 +0000
+++ examples/CMakeLists.txt 2022-01-26 21:15:39.575806682 +0000
@@ -13,6 +13,7 @@
# Most viewers need pthreads and GLUT.
set(THREADS_USE_PTHREADS_WIN32 true)
find_package(Threads)
+set(OpenGL_GL_PREFERENCE GLVND)
find_package(OpenGL)
find_package(GLUT)
@@ -25,11 +26,11 @@
add_executable(freenect-chunkview chunkview.c)
add_executable(freenect-micview micview.c)
- target_link_libraries(freenect-glview freenect ${OPENGL_LIBRARIES} ${GLUT_LIBRARY} ${CMAKE_THREAD_LIBS_INIT} ${MATH_LIB})
- target_link_libraries(freenect-regview freenect ${OPENGL_LIBRARIES} ${GLUT_LIBRARY} ${CMAKE_THREAD_LIBS_INIT} ${MATH_LIB})
- target_link_libraries(freenect-hiview freenect ${OPENGL_LIBRARIES} ${GLUT_LIBRARY} ${CMAKE_THREAD_LIBS_INIT} ${MATH_LIB})
- target_link_libraries(freenect-chunkview freenect ${OPENGL_LIBRARIES} ${GLUT_LIBRARY} ${CMAKE_THREAD_LIBS_INIT} ${MATH_LIB})
- target_link_libraries(freenect-micview freenect ${OPENGL_LIBRARIES} ${GLUT_LIBRARY} ${CMAKE_THREAD_LIBS_INIT} ${MATH_LIB})
+ target_link_libraries(freenect-glview freenect ${OPENGL_LIBRARIES} ${GLUT_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${MATH_LIB})
+ target_link_libraries(freenect-regview freenect ${OPENGL_LIBRARIES} ${GLUT_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${MATH_LIB})
+ target_link_libraries(freenect-hiview freenect ${OPENGL_LIBRARIES} ${GLUT_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${MATH_LIB})
+ target_link_libraries(freenect-chunkview freenect ${OPENGL_LIBRARIES} ${GLUT_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${MATH_LIB})
+ target_link_libraries(freenect-micview freenect ${OPENGL_LIBRARIES} ${GLUT_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${MATH_LIB})
install(TARGETS freenect-glview freenect-regview freenect-hiview freenect-chunkview freenect-micview
DESTINATION bin)
@@ -51,7 +52,7 @@
if (OPENGL_FOUND AND GLUT_FOUND)
include_directories(${OPENGL_INCLUDE_DIR} ${GLUT_INCLUDE_DIR})
add_executable(freenect-glpclview glpclview.c)
- target_link_libraries(freenect-glpclview freenect_sync ${OPENGL_LIBRARIES} ${GLUT_LIBRARY} ${MATH_LIB})
+ target_link_libraries(freenect-glpclview freenect_sync ${OPENGL_LIBRARIES} ${GLUT_LIBRARIES} ${MATH_LIB})
install(TARGETS freenect-glpclview
DESTINATION bin)
endif ()

View File

@ -5,7 +5,7 @@
Name: libfreenect
Version: 0.6.2
Release: 5%{?dist}
Release: 6%{?dist}
Summary: Device driver for the Kinect
# Core libfreenect is available as ASL 2.0 OR GPLv2
# OpenNI driver is available as ASL 2.0
@ -23,6 +23,8 @@ Patch3: %{name}-0.4.2-libdir.patch
Patch4: secarch.patch
# Fix the installation path for python libs
Patch5: %{name}-0.6.2-py3.patch
# BZ: https://bugzilla.redhat.com/show_bug.cgi?id=2045802
Patch6: %{name}-0.6.2-cmake-gl-glut.patch
BuildRequires: gcc-c++
BuildRequires: cmake3
@ -105,6 +107,7 @@ rm -rf platform/windows
%patch3 -p0 -b .libdir
%patch4 -p1 -b .secarch
%patch5 -p1 -b .py3
%patch6 -p0 -b .cmake-gl-glut
%build
@ -184,6 +187,9 @@ mv %{buildroot}%{_libdir}/OpenNI2-FreenectDriver %{buildroot}%{_libdir}/openni2/
%{_libdir}/openni2
%changelog
* Wed Jan 26 2022 Phil Wyett <philip.wyett@kathenas.org> - 0.6.2-6
- Fix FTBFS. Update cmake related OpenGL GLVND and GLUT.
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.2-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild