Update to release 0.5.2 (rhbz#1160258)
This commit is contained in:
parent
e8d69dace9
commit
56a14f264c
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
||||
/libfreenect-a35642fefd533c6b21864cd3bab7fefb9f0e2f00.tar.gz
|
||||
/libfreenect-9b671cd7210d16d330a88c7f4e80ce48f42d013e.tar.gz
|
||||
/libfreenect-8d957924f8a82a235aaa44d8c455113f10c0373f.tar.bz2
|
||||
/libfreenect-b2043d02b66c9c59899bbf09cb1a13206e8fa10d.tar.gz
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up ./wrappers/python/CMakeLists.txt.cmake28 ./wrappers/python/CMakeLists.txt
|
||||
--- ./wrappers/python/CMakeLists.txt.cmake28 2014-03-22 20:42:53.000000000 -0400
|
||||
+++ ./wrappers/python/CMakeLists.txt 2014-04-14 20:45:29.682944140 -0400
|
||||
@@ -2,15 +2,16 @@
|
||||
diff -up ./wrappers/python/CMakeLists.txt.cmake30 ./wrappers/python/CMakeLists.txt
|
||||
--- ./wrappers/python/CMakeLists.txt.cmake30 2015-01-26 22:01:37.000000000 -0500
|
||||
+++ ./wrappers/python/CMakeLists.txt 2015-03-04 10:19:13.007395503 -0500
|
||||
@@ -2,14 +2,14 @@
|
||||
# Python extension builder
|
||||
######################################################################################
|
||||
|
||||
@ -16,20 +16,16 @@ diff -up ./wrappers/python/CMakeLists.txt.cmake28 ./wrappers/python/CMakeLists.t
|
||||
- ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(prefix='${CMAKE_INSTALL_PREFIX}')"
|
||||
+ ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)"
|
||||
OUTPUT_VARIABLE PYTHON_SITE_PACKAGES OUTPUT_STRIP_TRAILING_WHITESPACE)
|
||||
+message(STATUS "PyPath: ${PYTHON_SITE_PACKAGES}")
|
||||
|
||||
# Figure out numpy include path
|
||||
execute_process(COMMAND
|
||||
@@ -31,9 +32,11 @@ set_target_properties(cython_freenect PR
|
||||
target_link_libraries(cython_freenect freenect_sync)
|
||||
include_directories(${PYTHON_INCLUDE_PATH} ../c_sync/ ${NUMPY_INCLUDE_PATH})
|
||||
@@ -33,7 +33,9 @@ include_directories(${PYTHON_INCLUDE_PAT
|
||||
|
||||
+message(STATUS "PyPath: ${PYTHON_SITE_PACKAGES}")
|
||||
+
|
||||
# Install the extension
|
||||
install(TARGETS cython_freenect
|
||||
- DESTINATION ${PYTHON_SITE_PACKAGES})
|
||||
+ LIBRARY DESTINATION ${PYTHON_SITE_PACKAGES})
|
||||
+ ARCHIVE DESTINATION ${PYTHON_SITE_PACKAGES}
|
||||
+ LIBRARY DESTINATION ${PYTHON_SITE_PACKAGES}
|
||||
+ COMPONENT library)
|
||||
|
||||
# TODO: decide on what to do with demo_ scripts and were to install
|
||||
# them
|
@ -1,4 +1,4 @@
|
||||
%global commit 8d957924f8a82a235aaa44d8c455113f10c0373f
|
||||
%global commit b2043d02b66c9c59899bbf09cb1a13206e8fa10d
|
||||
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||
|
||||
%{?filter_setup:
|
||||
@ -7,15 +7,15 @@
|
||||
}
|
||||
|
||||
Name: libfreenect
|
||||
Version: 0.5.0
|
||||
Version: 0.5.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Device driver for the Kinect
|
||||
License: GPLv2+ or ASL 2.0
|
||||
URL: http://www.openkinect.org/
|
||||
|
||||
Source0: https://github.com/OpenKinect/%{name}/archive/%{commit}/%{name}-%{commit}.tar.bz2
|
||||
Source0: https://github.com/OpenKinect/%{name}/archive/%{commit}/%{name}-%{commit}.tar.gz
|
||||
# Fix python installation path discovery
|
||||
Patch0: %{name}-0.4.0-cmake28.patch
|
||||
Patch0: %{name}-0.5.2-cmake30.patch
|
||||
# Freenect openni driver is a plugin lib, and doesn't need soversion symlinks
|
||||
Patch1: %{name}-0.4.1-openni2.patch
|
||||
# Detect aarch64
|
||||
@ -93,9 +93,9 @@ OpenNI2 driver. It allows OpenNI2 to use Kinect hardware on Linux and OSX.
|
||||
It was originally a separate project but is now distributed with libfreenect.
|
||||
|
||||
%prep
|
||||
%setup -qn %{name}
|
||||
%setup -qn %{name}-%{commit}
|
||||
rm -rf platform/windows
|
||||
%patch0 -p0 -b .cmake28
|
||||
%patch0 -p0 -b .cmake30
|
||||
%patch1 -p0 -b .openni2
|
||||
%patch2 -p0 -b .aarch64
|
||||
%patch3 -p0 -b .libdir
|
||||
@ -188,6 +188,9 @@ mv %{buildroot}%{_libdir}/OpenNI2-FreenectDriver %{buildroot}%{_libdir}/openni2/
|
||||
%{_libdir}/openni2
|
||||
|
||||
%changelog
|
||||
* Wed Mar 04 2015 Rich Mattes <richmattes@gmail.com> - 0.5.2-1
|
||||
- Update to release 0.5.2 (rhbz#1160258)
|
||||
|
||||
* Tue Aug 19 2014 Jiri Kastner <jkastner /at/ redhat /dot/ com> - 0.5.0-1
|
||||
- update to release 0.5.0 (rhbz#1124171)
|
||||
- Move openni plugin to libdir/openni2/Drivers (rhbz#1094787)
|
||||
|
Loading…
Reference in New Issue
Block a user